OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Status Quo?
post Feb 28 2006, 05:15 AM
Post #1

Group: Members
Posts: 5
Joined: 28-February 06
From: Augsburg, Germany
Member No.: 9,247

Simpad development seems to be stalled if it get this right.

I got a CL4 Simpad and it was getting dusty during the last few years.
I always had plans to reanimate it some time and start an own directfb-based distribution.

After fiddling around two days with various bootloaders and crosscompiling-environments I managed to install a modified version of the hh.org bootloader from (http://opensimpad.org/bootldr-simpad/blupdater.img - found the link here: http://opensimpad.org/opensimpad-forum/viewtopic.php?t=835).

However I had to modify the linuxrc script - it wrongly detected my CL4 as an SLC and thus the bootloader tried to flash erase beyond the end of the 16 MBytes.

First I tried to use the 2.5.1 siemens bootloader to boot a kernel from network, but I didn't get any output from the kernel - what now in retrospect could be caused by passing console=ttyS0 instead of ttySA0 - maybe I'll flash the old bl back the 10th time some day and check if this was the only problem %)

Been there, done that I crosscompiled the kernel and got it started on the simpad with the modified ohh bootloader.
The problem is that I can't pass a commandline to the kernel - I tried to, but it seems to get overwritten somewhere by the bootloader.
(The bootloader also tries to tell the kernel it has 64MB of RAM which isn't the case)
Also I have no chance to save the modified params somehow...

The latest status was that the rootfs (from opie 0.9....) got mounted but my kernel with this damn commandline I'm unable to modify failed to execute /linuxrc.

Anyone an idea how override that damn commandline?
Neither compiling my own commandline into the kernel worked, nor did passing the args to boot vfat zImage <args>.
However I'm quite sure I get this done with some work - help is appreciated as it does accellerate it %)

And yes, I do know there's no mq200 support in the 2.6 kernel tree, but I'm willing to port the mq200 driver to the 2.6 kernel tree. I got the full mq200 datasheet so I'm also willing to add as much hw accel as possible since I want to run directfb on it anyway.

The tda8007 also isn't in the 2.6 tree what's a minor problem. But I also wasn't able to find any image (they're all 2.4 based) for the simpad with tda8007 support.

The reason I'd like to have the tda-driver working is the following:
I'd like to look at the CS (Chip Select) and RD/WR (Read/Write) lines of the tda with my oscilloscope to figure out how "fast" the bus is.

Why that? Well I also want to add SD-support, but not the GPIO-bitbanging style.
It costs quite a lot cpu-power to do it with the GPIOs and you probably don't get much throughput. Anyone here with GPIO-SD-performance readings?

So my approach is to remove the tda and glue a low-power CPLD to the former-tda connections and to an SD-card. (But one could also connect a CF card or CF-wlan etc. to it so one could but a microdrive or internal wireless lan card into the simpad...)
This way you get 1 Byte (tda is 8-bit connected, but >16bit is too much fiddling anyway...) per bus-cycle what results in Bus speed = CF/SD throughput in Bytes/sec.
(I expect the bus to be >=8 MHz what would be >=8MBytes/sec. throughput to the CF/SD)

Anyone here with interest in this project?

One of my first problems to solve is getting a new battery :\ the old one is completely broken :\
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 23rd June 2018 - 02:30 AM