OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Phantom Partition On /dev/hda [fixed], lost my partitions
markpmc
post Dec 24 2006, 10:39 AM
Post #1





Group: Members
Posts: 62
Joined: 16-December 03
Member No.: 1,089



First this is my fault. While flashing my updated version of Cacko 1.23 for the C3000. I lost my partition table.

No big thing right? Just boot into D+B mode recreate them and then reflash right?

Well. I can't seem to create a 'good' partition table.

I've tried as both /dev/hda and /dev/hdc (w/ a CF card inserted) and I get the same 'extra' partition. After creating hda2, when I start to create hda3 fdisk autoselects partition 4.

Here's what my partition table ends up looking like.

/dev/hda1 1-204 id 83 (linux)
/dev/hda2 205-1020 id 83 (linux)
/dev/hda3 1-1 no type
/dev/hda4 1021-7936 fat32

I've even tried building the partition table backwards (from hda3 to hda1). I that case I still get the 1 block no type partition. I don't understand enough of the advanced menu in fdisk to know if I can clean this up.

I just don't get it. I will say that a few times fdisk didn't even find my hard drive. I bought my 3K the first week after they were announced, so this unit is a full 3 years old.

Is this fixable?

Thanks,

Mark

Edit to mark as fixed.
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 1st October 2014 - 06:21 PM