OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V  < 1 2  
Reply to this topicStart new topic
> State Of Os Options For C3000, is cacko/sharp only stable option?
radiochickenwax
post Feb 22 2007, 10:19 AM
Post #16





Group: Members
Posts: 158
Joined: 21-November 04
Member No.: 5,548



QUOTE(danboid @ Feb 22 2007, 08:06 AM)
I obviously got the wrong idea about this setup then as I thought that pws would've included the debian xorg packages. As I've already stated, the main reason I'm was considering jumping pdaXii13 is that the X11 keymapping is broke- it only works for a limited time before you need to restart X. I was quite happy with the thought of using pdaXii13 base and installing pws on top of that because the keyboard seems to work fine all  the time under the pdaXii13 text console, it's something to do with XFree thats causing problems I think so I thought I might be able to get round this major bug with pws.
*


Yeah, the disappearing keymapping thing in pdaxii13 is a difficulty for me too, and you're right: PWS doesn't fix this without the VNC. By the way, the disappearing keymapping isn't an issue in the standard beta3 right? We should probably start a new thread about this.

You can get the Xorg packages for debian, but then you're left without a kernel. So, it's just a matter of putting it all together, which AFAIK nobody seems to have shared as of yet.

The closest thing I've found, which appears to be abandoned is:

Debian Zaurus Project

Which also includes

A ROM Image for 5500?


QUOTE(danboid @ Feb 22 2007, 08:06 AM)
I'm sure I'm remember seeing somebody compile xorg for b3, did I not? Has anybody tried installing xorg on pdaXii13? Does the keymapping work reliably? Does CAPS LOCK work? Will all the pdaxii13/b3 X apps work under xorg? Upgrading to xorg should also mean we get the possibility of having transparent windows too right?
*


As far as xorg package goes, I tried installing the (only?) package I could find from the following thread.

Real Transparency


It failed to work on my 3200 running beta3 (or pdaxii13) so far. (I left a comment on page 2 of the above thread). Maybe beta2 would work? I haven't tried it in beta1, but that's moot for the 3000 since there isn't a beta1 right?

It's clearly possible to compile Xorg (with some patience and dedication). I wish somebody would. I don't have time to try to do this, but I probably will someday. The X11 build seems a little tricky... needs a lot of knowledge it seems.

On the other hand, you could boot directly into debian X with the VNC setup described on

http://www.eleves.ens.fr/home/leurent/zaurus.html

Which seems somewhat interesting. If you wanted to take the time, you could probably even get rid of the VNC stuff. That would probably help a lot of people out.

QUOTE(Meanie @ Feb 22 2007, 12:43 AM)
the most stable ROM for C3000 is Sharp ROM!
*


Meanie's got a really, really good point here. Have you checked out his X/QT setups? He's done a really good job with these for both pdaxrom and pocketworkstation running off the sharp roms.

I'll second speculatrix's question:

QUOTE(speculatrix @ Feb 21 2007, 06:23 PM)
QUOTE(danboid @ Feb 20 2007, 05:19 PM)
Might Hentges, Angstrom (can you currently install Angstrom on the c3000?) or Open/NetBSD offer me a more stable X(FCE) or GPE based OS than pdaXii13 on the c3000 or is Cacko/Sharp my only choice for a stable OS?
*


is there a specific reason why you don't want to use cacko/sharp?
*

Go to the top of the page
 
+Quote Post
danboid
post Feb 22 2007, 10:37 AM
Post #17





Group: Members
Posts: 682
Joined: 26-December 05
From: Rochdale, Lancashire
Member No.: 8,789



If I install cacko then I'd just be using qte apps, no disrespect to Meanies fine dev skills and gifts but I find x/qt unbearably slow for most tasks.

I don't know if this keyboard problem is present in beta3 (or 2) as I've never used b2 and I've only ever installed beta3 on my c3100 as a step in getting pdaXii13 spitz to install. Talking of my c3100, I have yet to try installing sally 5.3.1, booting and then upgrading to full afterwards. It MIGHT make it work, otherwise I'll simply have no other choice than just installing 5.3.1 and then trying to mount and install stuff myself of course but that won't fix the keyboard issue.

I hope Mr Meanie has a keyboardular solution brewing, until then I think I'll try plain Sharp ROM on the c3000 I think.
Go to the top of the page
 
+Quote Post

2 Pages V  < 1 2
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th December 2014 - 10:32 PM