OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> "hidden" Documents Menu, Problem with Cacko..
post Sep 21 2007, 01:50 PM
Post #1

Group: Members
Posts: 7
Joined: 3-January 07
Member No.: 13,673

I've had this problem as long as I can remember. However, for almost that long I've been using OpenBSD on my Zaurus (it's dual-boot), so when I recently started using Cacko again I noticed the annoyance and now I'm posting it here.

It seems that the "Documents" folder, ie /home/zaurus/Documents, is unaccessible to the Qtopia gui. I can't browse my files there under the 'Files' tab, when I'm changing wallpaper in Plasterer or the Appearance applications I can't browse there either. (I CAN change my wallpaper, but only if I manually type out the path myself. Read access to the files, but not the folders? They have the same permissions, though...)

It works fine in the console, though. I can browse there, whathaveyou...

My /home/zaurus/Documents folder is not a symlink anywhere else. The permissions are zaurus:qpe, and of course, 755 permissions set for the folder and all contents.

/home/root/Documents seems to link right back to /home/zaurus/Documents.

I am entirely unsure what it's supposed to be, or how I can allow my Qtopia applications access to this folder. It's not so big a deal for me - I'm much more of a console guy anyways...but as it currently stands I can't really use many of the Qtopia applications properly.
Go to the top of the page
+Quote Post
Start new topic
post Oct 3 2007, 05:45 AM
Post #2

Group: Members
Posts: 7
Joined: 3-January 07
Member No.: 13,673

Well, I'm stuck. Started out recursive grepping for Documents in /etc. Of course, Cacko grep has no recursive switch, grumble grumble grumble...

find | xargs grep -iH Documents in /etc. Found a reference to /hdd3/Documents. First guess is that the Qtopia GUI looks inside /hdd3/Documents, and that's why it's coughing up. It's the only guess I have to go by.

After a lot of find | xargs grep -iH hdd 2>/dev/null in /etc, I commented out all the nonsense that insisted on mounting the hard drive. There was still some left. The current plan, the only one I have, is to stop Cacko from mounting the hard drive, period -- let's stop that nonsense, it can't read it anyways. Then make /hdd3 a normal directory, and ln -s /hdd3/Documents to /home/zaurus/Documents. A poor quality, hackish solution, complete rubbish. Should fit in wonderfully in Sharp Linux/Qtopia.

So all the commands mounting the hard drives have been removed. Still no luck. Grumble, grumble. Ok, so -- the hddmount command looks interesting. I remove it -- reboot, D+B, mount /dev/mtdblock2 and move /sbin/hddmount to /sbin/hddmount.del. So at this point, as far as I can tell, all the internal commands to mount /hdd1, /hdd2, and /hdd3 are gone. There's still mount, of course, but no startup scripts used it for the hard drives that I can find. Nothing points to it, no commands to mount them, nothing. They're not on /etc/fstab or mtab. They never were, actually, but nevertheless they were mounted. (Unsuccessfully, of course, it's can't read OpenBSD partitions, and even if it could it seems to be looking for the default partition build anyways, to hell with what's actually there.)

/hdd1, /hdd2, and /hdd3 are still there, mocking me. I hate them. Again, my best guess is that the GUI is coded to look inside /hdd3/Documents. Can't imagine why, but I can't think of anything else. Besides, those three mount points represent, to me, a flaw in the system. Neither do I understand why there's an hddmount command at all, when clearly it doesn't need it or use it. (In my day, we just used the mount command...) I mean, it's not even there anymore, yet the hard drive is still mounted, unsuccessfully.

To illustrate what I mean:

$ ls /hdd2

I'd descend into /usr, but it's quite a mess in there and grep dies a painful death every time it tries to recursively venture inside. Perhaps there's an option I can set in qpe.conf, qpecustom.conf, or sharpqpe.conf to ensure it looks inside /home/zaurus/Documents instead of wherever the hell it's currently looking?

Any suggestions?

EDIT: The simplest solution works best sometimes. smile.gif My adventures with hdd2, hdd3 nonsense notwithstanding, mounting /dev/mtdblock3 to /mnt/ide completely fixes the problem. It looks in /mnt/ide, not /hdd3/Documents. This successfully adds an "Internal Disk" option to the Files tab. May want to add this into the guide, mathemajikian.

SECOND EDIT: ...more adventures. Nothing's ever simple. The solution as I just stated -- first, I had no write access. Oh yes, /mnt/ide is root:root. Fix that, sudo chown zaurus:qpe ide. Now I have write access, but it's creating a new Documents folder. (/home/Documents) It seems normal Cacko mounts /home/zaurus to /mnt/ide, not /home to /mnt/ide.

Tried to fix by linking /home/zaurus to /mnt/ide, removing /mnt/ide from fstab. Rebooted. Now have a Japanese Cacko. blink.gif Root filesystem copied into /home/zaurus. Hosed Cacko. Completely unsure what happened. Must have mounted /home as I previously told it to. But the new /mnt/ide points to /home/zaurus, so it mounted /home to /home/zaurus. But I removed that line from fstab, and I'm 100% sure I saved it. Sneaky bastard, Cacko put it back in or something, mounted anyways..

I'll have to reflash. Bloody Cacko. Previous solution can still be used, for the dual-boot people, you just have to put up with a /home/Documents folder until I can fix this mess.
Go to the top of the page
+Quote Post
post Oct 3 2007, 01:36 PM
Post #3

Group: Members
Posts: 301
Joined: 8-July 06
From: United Kingdom for now....
Member No.: 10,349

I just tried the method I stated earlier and it worked fine. I'm not sure why it's giving you a hard time. Maybe a re-flash will sort things out. rolleyes.gif
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 24th June 2018 - 01:27 AM