OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Flite In Collie?, Can't get text-to-speech program working
doug-taylor
post Nov 7 2007, 12:30 PM
Post #1





Group: Members
Posts: 22
Joined: 11-October 05
Member No.: 8,291



Hi.

I've got a 5500 running Opie under OZ 3.5.3. I'm trying to get flite (Festival-lite, the text-to-speech program) running. I have downloaded both 1.1 and 1.2, but haven't had any luck getting either one to work properly. When I run a command like

echo "hello world"|flite

all I get is a squawk, sort of like the sound I made once when I got hit by a baseball in a very bad place. :-) If I try flite on a longish text file, I just get a series of squawks.

Is there something else I need to install, like a library or a voice file? The docs seem to indicate that all I need is the flite binary. Has anyone got this working on a 5500?

Incidently, the flite_time program (which speaks the time in a Scottish accent) runs great.
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
sdjf
post Nov 7 2007, 07:32 PM
Post #2





Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551



I have flite on my Collie with Sharp ROM 2.38 and it works just fine. Ran some tests as haven't used it in a long time and the following formats all worked okay. Note that I backgrounded it so I could run lsof to see what files it was accessing while running:

# echo hello | flite
# cat myfile.txt | flite &
[1] 30187
# lsof | grep flite > lsofflite
# flite myfile.txt

Here's my output from "lsof" in case it is of interest to anyone.

CODE
flite     30187 root  cwd    DIR       31,1   48128       3523 /home/root
flite     30187 root  rtd    DIR       31,0
224         76 /
flite     30187 root  txt    REG       60,1 5906468     227630 /usr/mnt.rom/card/Flite/flite
flite     30187 root  mem    REG       31,0  105908    1293808 /lib/ld-2.2.2.so
flite     30187 root  mem    REG       31,0  163740    1922260 /lib/libm-2.2.2.so
flite     30187 root  mem    REG       31,0 1152468    1349952 /lib/libc-2.2.2.so
flite     30187 root    0r  FIFO        0,0
         588551 pipe
flite     30187 root    1u   CHR      3,176
            214 /dev/ttya0
flite     30187 root    2u   CHR      3,176
            214 /dev/ttya0
flite     30187 root    3u  unix 0xc1ce8520
         588504 socket
flite     30187 root    4u   CHR       29,0
             42 /dev/fb0
flite     30187 root    5u   CHR      2,176
            127 /dev/ptya0
flite     30187 root    6w   CHR       14,3
             38 /dev/dsp
flite     30187 root    7u   REG       31,1
   0       7076 /home/tmp/tmpfR7OuQf (deleted)
flite     30187 root    8u   REG       31,1
   0       7089 /home/tmp/tmpfyps3ql (deleted)
grep      30200 root    1w   REG       31,1
   0       6215 /home/root/lsofflite


I used it with an earbud plugged into the microphone jack. Did you also try adjusting the volume?

If you have those libraries, I could be wrong but I should think it would work as well on an Opie ROM. Do you want me to zip up my copy and put it somewhere for the heck of it?

sdjf
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th July 2014 - 02:22 AM