OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Socket Bluetooth Cf Card Not Working (surprise!), 2or0's rootfs & kernel
post Aug 1 2008, 12:06 AM
Post #1

Group: Members
Posts: 19
Joined: 29-December 07
Member No.: 21,129

Installed bluez etc. Drivers won't load.


Bluetooth: Core ver 2.11
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.9
Bluetooth: L2CAP socket layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.8

and when I take the card out and reinsert it:

pccard: card ejected from slot 1
pccard: PCMCIA card inserted into slot 1
pcmcia: registering new device pcmcia1.0

Tried playing around with hciattach and setserial, with no success.

Is this an issue with the kernel? I read about a bug (here and elsewhere) in 2.6 kernels that prevents some Socket BT cards from working, but I'm not really up to configuring a kernel for my Z from scratch, not knowing every relevant switch I should temper with in the config.

Any ideas?

Here's some output:

Zaurus:~# hciattach /dev/ttyS4 socket
Can't get port settings: Input/output error
Can't initialize device: Illegal seek
Go to the top of the page
+Quote Post
Start new topic
post Sep 9 2008, 12:36 AM
Post #2

Group: Members
Posts: 9
Joined: 18-July 04
Member No.: 4,030

I have a Bluetooth CF card on Angstrom on SL-C860.

ant, thanks for your script as it was enough to get my card working. I have no idea what manufacturer the card is - it doesn't return an ID, other than 'Bluetooth CF card', when I do 'pccardctl ident'.

This worked though:

modprobe serial_cs
modprobe hci_uart
hciattach -s 115200 /dev/ttyS4 socket 230400
hciconfig hci0 up

Perhaps I should post this on an Angstrom forum but it's late in the day and I am dozing off at the keyboard.

Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 20th June 2018 - 09:01 PM