OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> How To Bring Up Wlan0 Via Command-line?
post Aug 9 2008, 06:26 PM
Post #1

Group: Members
Posts: 7
Joined: 9-October 07
Member No.: 20,805

Hi all,

I've got a Zaurus CL-3200, using AmbiCom WL1100C-CF PCMCIA wireless card.

I'm trying to bring up wlan0 via the command-line (yeah, there's a GUI tool to do it, but I'm curious). I can connect to the wireless AP at home (sometimes).

I see the card details in dmesg after I insert it into the slot and cardctl status lists the card at socket 0. It's in suspended mode. So far so good.

I'm assuming that to get the card up I need to unsuspend it. cardctl resume prints "ioctl(): Device or resource busy", but I'm assuming that's from the built-in microdrive, which is sitting at socket 1. cardctl resume 0 doesn't print anything and seems to succeed. cardctl status shows the card in a suspended state, however. Can anyone explain why this is so?

At this stage I still can't do anything wireless-related to the card as wlan0 still doesn't exist (it isn't reported by ifconfig). Ifconfig wlan0 up prints "SIOCSIFFLAGS: No such device".

Can someone fill me in?

Go to the top of the page
+Quote Post
Start new topic
post Sep 1 2008, 04:48 AM
Post #2

Group: Members
Posts: 447
Joined: 17-November 05
Member No.: 8,551

Hey folks, if anyone is interested in trying qreset, while it technically will run without a log file, I won't be able to debug any problems if there is no such file. It's like driving with blinders on.

Just because the file is there, though, doesn't mean logging is happening. If you're online and the file has nothing in it, and it has been enabled, the system will need rebooting (a soft reset on some models) in order to get the kernel to produce the log.

If that still doesn't result in logging, then syslogd needs to be fiddled with. I'm still learning how to work with that, and am hoping it isn't necessary.

I am working on command line options for it to possibly run on dhcpcd processes, and whatever is needed for misha to run the script successfully. Again, qreset's home page is at


Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 26th May 2018 - 03:46 PM