OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Cant Boot Openbsd, new installation
post Jan 11 2009, 03:57 PM
Post #1

Group: Members
Posts: 92
Joined: 9-January 06
Member No.: 8,887

Thought i'd give my problem its own thread:

After installing OZ I decided to go back to OpenBSD. The install process went OK with my sets on a CF card and using all the microdrive for BSD. However, when it came to rebooting the Z simply dropped into the OZ splash screen with a kernel panic. I tried restoring flash and re-installing but now i get the Sharp splash scree and an hdd error.

I decided to completely clean the HDD usung the D+M menu (which takes a while) and re-installed again. Still no joy when it comes to boot. I'm stuch. Help!

Here is a df done from the emergency D+B menu
disk dev hda 4096 MB 4095737856 bytes
16 heads, 63 sectors/track, 7936 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device        Boot     Start          End         Blocks       Id     System
dev/hda4    *          1               7936        3999712+ a6    OpenBSD

cant understand why I've got hda4? doesnt make sense!

during the BSD setup my disk partition looks like this
             size           offset     fstype       [fsize   bsize     cpg]
a:    7999425           63        4.2BSD      2048    16384    1
c:    7999488             0        unused            0          0

I should add that the installation will boot if I drop back to d+b linux shell and do insmod zbsdmod.o then ./zboot. Sorry, but I really dont understand what makes a machine actually boot but clearly something is wrong here.
Go to the top of the page
+Quote Post
Start new topic
post Jan 22 2009, 02:10 PM
Post #2

Group: Members
Posts: 92
Joined: 9-January 06
Member No.: 8,887

Well, I finally worked it out, and it also seems to answer this post, where the poster was coming directly from OZ, as was I. He also claimed to be a veteran of BSD installing so went straight to the D+B menu and the insmod commands.


Having read this, I remembered that the two successful installs I had done both came from having cacko on the Z and installing the OpenBSDxx.ipk file. My experience was that this install file did no appear to do anything except hang the Z so was not worth doing. It seemed to be better to skip straight to the D+M menu and the insmod command sequence.

However, it seems that the Sharp/Cacko IPK file does something that enables the Z to boot directly into OpenBSD once you have done a successful intstall. I guess it tinkers with the scripts held in flash.

So, in summary, to install OpenBSD so that it boots without having to go to the D+B menu, make sure you start from a Sharp/Cacko build and run the BSD install IPK. You'll find it in the feed.

Go to the top of the page
+Quote Post

Posts in this topic
Wildherb   Cant Boot Openbsd   Jan 11 2009, 03:57 PM
Wildherb   Well, I finally worked it out, and it also seems t...   Jan 22 2009, 02:10 PM

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 18th June 2018 - 03:43 AM