OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> R.i.p.?, Have I bricked my 860?
Meyer
post Aug 25 2009, 06:05 AM
Post #1





Group: Members
Posts: 91
Joined: 15-July 04
From: Takarazuka, Japan
Member No.: 4,010



My SL-C860 (Sharp ROM 1.10) now freezes on the boot "Wait..." screen. I've got backups of most of the important files, but I'd like to recover the system if possible.

CORRECTION (9/8): The Zaurus was running Sharp ROM 1.40 JP.

Here's what happened:

Last week, I started getting errors when trying to access certain files on my SD card (ext2 format). I assumed the card was going bad and purchased a replacement. Today I formatted the new card and was going to transfer the files over by tar'ing convenient sized chunks, saving each tar file to system memory. The plan was then to swap cards and untar the file to the new SD card, then delete the tar file in system memory and repeat the process until all the files were transfered.

After cleaning out system memory a little by deleting ipkg and music files, I tarred the first 19M of files, powered-off, and swapped cards. Powering-on, the Zaurus didn't detect the card, which was unexpected, but I rebooted without giving it much thought. Shutdown ... "Wait" screen with cursor flashing at lower right ... Cursor flashing at lower left ... forever. Pull and replace the battery, power-on ... freeze in same place. Pull battery and replace old SD card ... same result. With SD slot empty ... same result.

Then I try the secret keys. "OK POWER" is the only combination that works (other combinations result in the same reboot to frozen "Wait" screen). On the maintenance menu, "Fault check" looks promising, but results in the same frozen reboot.

The only theory I have is that the tar ball sitting in system memory is so big there's not enough memory for the boot process to complete (though I think there was around 5M free), and if I could get up to single-user mode I could delete the tar file and maybe get the Z to reboot.

Any ideas for bringing my dear Z back to life?

Barring that, I will try restoring the NAND flash memory to see if I can at least get a usable system.

Barring that, I will have to bid farewell to a good friend and say hello to a new brick.
Go to the top of the page
 
+Quote Post

Posts in this topic
Meyer   R.i.p.?   Aug 25 2009, 06:05 AM
tux   QUOTE(Meyer @ Aug 25 2009, 03:05 PM) My S...   Aug 29 2009, 12:57 PM
Meyer   QUOTE(tux @ Aug 29 2009, 12:57 PM) Any j...   Sep 7 2009, 08:23 PM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th December 2014 - 03:04 PM