OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> C860 keyboard stops responding problem
post Jun 14 2004, 03:36 PM
Post #1

Group: Members
Posts: 8
Joined: 26-February 04
Member No.: 2,054

Occasionally the keyboard will stop responding. Usually after I have a lot of programs loaded, so maybe a memory problem? A reboot fixes this, but I was wondering if anyone else has seen the problem and knows a better way to get the keyboard going again.

I'm running Sharp's Rom.
Go to the top of the page
+Quote Post
Start new topic
Replies (1 - 7)
post Jun 14 2004, 08:12 PM
Post #2

Group: Members
Posts: 7
Joined: 23-May 04
Member No.: 3,397

My 860 would freeze when I tried to view an SD card full of pictures from my camera. Fortunately, I have the Cacko 1.21b rom with memory management app running. I created a 32M swap file on my CF card and no longer have any problems.

I would try creating a swap file on an SD or CF card manually, or better yet, flash to the latest Cacko ROM.
Go to the top of the page
+Quote Post
post Aug 3 2004, 06:13 AM
Post #3

Group: Members
Posts: 18
Joined: 14-November 03
Member No.: 925


Similar to you, I have problems with my SL-C860 keyboard not responding. I have Cacko Rom 1.21b (I recently installed the 1.21b hotfix, after uninstalling the 1.21a hotfix).

Before I installed the hotfix b, I noticed a few times that the keyboard would die, normally after unsuspending the Zaurus. This was fixed every time by rebooting.

I thought I'd address this by installing the b hotfix. Now I've done that, I've only had the keyboard behave itself once. Now, every time I boot up the box (reboot it or shutdown -r now it) the hardware keyboard doesn't work.

You'd think this might be a hardware problem, but I'm pressing the Home key to unsuspend it/boot it up, so that indicates the home key is working fine. Also note that the jogdial and cancel/enter buttons on the case-side all function fine.

I uninstalled keyhelper, thinking that that might help fix the problem, it didn't. I've rebooted the Zaurus multiple times, and still the problem is there. Is this a problem with Cacko 1.21b and the 860?

Does anyone have suggestions for investigating this (I didn't notice anything in /var/logs/dmesg), or advice for reinitialising the keyboard? Please pass your help on, before I am forced to nand restore my last backup.

Go to the top of the page
+Quote Post
post Aug 3 2004, 06:58 AM
Post #4

Group: Members
Posts: 578
Joined: 2-January 04
From: Texas USA
Member No.: 1,324

I run Cacko 1.21b on my c860 and have never had a problem with the keyboard. I don't think this is a problem with the ROM.
Go to the top of the page
+Quote Post
post Aug 3 2004, 08:33 AM
Post #5

Group: Members
Posts: 626
Joined: 13-April 04
From: Ireland
Member No.: 2,825

I agree, never ever had this issue - memory hogging the Z or not.
Go to the top of the page
+Quote Post
post Aug 12 2004, 09:01 PM
Post #6

Group: Members
Posts: 1
Joined: 12-August 04
Member No.: 4,274

I've had my c860 6 days and my keyboard has never worked. Strangely, if I press the Home/Power key when its off the unit powers on but then the keys will not function. I've made no modifications to the unit. I ordered it through Dynamism and seems to function flawlessly in every other way.

-- Mark
Go to the top of the page
+Quote Post
post Aug 26 2004, 02:10 AM
Post #7

Group: Members
Posts: 22
Joined: 25-August 04
Member No.: 4,383

I've had this problem recently since upgrading to Cacko 1.21b, on resuming from suspends

In my case, it appears to be related to having a Swap file created on SD card. If I disable it, and reboot, the problem disappears. I think this is an artifact of my SD card (or the mmcda driver...) since I also occasionally get my SD card remounted read-only after suspend/resume.

OK. Well I did have one recurrence but that was *definitely* a problem with libSDL after running Scummvm & exiting. That got fixed by re-running Scummvm and closing it nicely (instead of killing the process....)
Go to the top of the page
+Quote Post
post Sep 15 2004, 10:03 AM
Post #8

Group: Members
Posts: 5
Joined: 19-August 04
Member No.: 4,338

QUOTE(henley_regatta @ Aug 26 2004, 10:10 AM)
I've had this problem recently since upgrading to Cacko 1.21b, on resuming from suspends

The keyboard froze on me today on resuming from suspend (pdaXrom 1.1.0 "Kathrin" RC3). I had an Ambicom WiFi card inserted. Now, I remember reading something about this (or similar?) problem being solved by moving a cardctl (?) command by a line or two in some script. But I can't find that page anymore... Does anybody remember it? Thanks much in advance!
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 23rd May 2018 - 10:28 PM