OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
cwalstad doesn't have a personal statement currently.
Personal Info
cwalstad
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 25-June 04
Profile Views: 506*
Last Seen: 17th November 2004 - 04:44 PM
Local Time: Dec 19 2014, 07:43 PM
9 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour

cwalstad

Members


Topics
Posts
Comments
Friends
My Content
24 Jul 2004
So I have this Java program that uses inner classes. When I transfer the class files over to the Zaurus I get the message that filenames cannot be saved with a $ sign in them. I think the Zaurus converts the dollar sign to a %24 or something like that. When I try to run the program the vm fails to find the class. I tried using the terminal to rename the file and replace the %24 with a $ sign. If I do that the file seems to dissapear completely. How can I use inner classes on the Zaurus?

Thanks for your help.
21 Jul 2004
Hi,

I have a program that opens a raw socket. When I run this as non-root it begins and runs for a while until it comes to the code where it opens a raw socket and prints "socket: Operation not permitted". This is all as I expected. So when I su to root and run the same program with the exact same command I get the error message "Qt/Embedded data directory is not owned by user 0". I really don't know what this means but I found one source that said this is a bug in Qt and the way to solve it is to delete the qtembedded-zaurus directory in tmp. I did this. Now when I run the exact same command I get the error "QSocket::writeBlock: Socket is not open" printed 4 times and then "No Qt/Embedded server appears to be running. If you want to run this program as a server add the '-qws' command-line option. I tried adding the command line option as instructed but this didn't work.

So I also did another test to see if deleting the directory created a problem. Now when I type evm --help (my program is mostly in java and calls some c code for the raw socket) I get the "QSocket::writeBlock: Socket is not open" error message again.

I really have no idea what is going on. If anyone can offer a fix to my problem or some workaround I would be very happy. Thanks for your help.

Chris
7 Jul 2004
I found out that the zaurus kernel is not configured to support netfilter/iptables, so to get these things to work I reconfigured and recompiled the kernel to support them. The only changes I made (during menuconfig) were enabling iptables/netfilter. I installed the new kernel and everything went fine. There were no problems however after a couple hours my Zaurus started locking up and the wireless connection was always giving me the signal level is low message. I know it isn't low because my router is about 2 feet away from me. This same thing happened to my friend who installed the new kernel as well. Any ideas on why this is happening? Thanks for your help.

Chris
25 Jun 2004
I'm trying to get iptables to work on my zaurus. I have the 5600 with kernel 2.4.18 and the standard sharp ROM 1.00. I installed the iptables and iptables-modules ipk packages from the Zaurus Software Index but it still isn't working. I am trying to filter based on mac address with the command:

iptables -A INPUT -m mac --mac-source XX:XX:XX:XX:XX:XX -j DROP

but i get an error message like:

can't initialize iptables table 'filter': iptables who? (do you need to insmod?) Perhaps iptables or your kernel needs to be upgraded

Has anyone been able to get iptables running? Any advice? Thanks.

Chris
Last Visitors
cwalstad has no visitors to display.

Comments
Other users have left no comments for cwalstad.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 19th December 2014 - 07:43 PM