OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
nyar doesn't have a personal statement currently.
Personal Info
nyar
Age Unknown
Gender Not Set
Australia
Birthday Unknown
Interests
No Information
Statistics
Joined: 4-October 04
Profile Views: 361*
Last Seen: 20th April 2006 - 05:15 AM
Local Time: Dec 19 2014, 01:39 PM
76 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

nyar

Members


Topics
Posts
Comments
Friends
My Content
7 Jan 2005
Hi,

I've never quite got kismet (ipkg from zsi) working to my satisfaction; I install the hostap-wireless-drivers ipkg which works fine, but kismet will only start successfully and start scanning networks if I go to my wireless applet and try to connect to a network.

Scanning happens fine until the wireless applet gives up and shows "Disconnected"; kismet will completely give up then - it'll look like it's still scanning but it's not (no more networks will be connected, etc). This is making my Z rather useless as a wireless scanning tool at the moment, sad to say. :-(


(I can't get kismet working properly with the stock drivers on Cacko; the only way I can do it is to use the crippled non-pcap prism config line in kismet.conf, which actually has exactly the same problem - it'll only scan while the wireless applet is looking for networks, which is maybe 30 seconds max.).

I've also noticed very, very often, my Z will fail trying to connect to WEP networks, and I need to retry several times until I actually do connect. This is both with the stock drivers in Cacko 1.21b and hostap. using iwconfig seems to be rather erratic, too; I've planned to rebuild the kernel with hostap support built in but have not had any time lately.

Any clues? Anybody else have this problem - I've had it since day one, and I can't see what I'm doing wrong.

Cheers,

R
23 Nov 2004
Hi,

I've had lots of fun with my Z, but I'm still not using it for what I originally bought it for - a PDA.

Although I've installed the Ki PIM tools, I'm still using the default Sharp ones as they're much faster.

In any case, the reason why I'm not really using it as a PDA is that I haven't found a sync solution that I like. I use iCal on my mac, and was using Qtopia Desktop on my PC but I never got it to sync properly with newer Cacko's.

I'm not sure what solution exactly I want. I developed a web-based PIM tool some time ago that I might start using if I can get it to sync with my Z, but it'll mean the Z needs to talk some standard format and be able to understand updated entries, etc.

For now, I'd be happy with it syncing over my 802.11b wireless card, my todo's/calendar, to preferably iCal on OS X, but any decent application on Windows/Linux.

What applications/sync methods are people using to achieve this? Do you use your Z as a PDA, or a expensive toy? :-)
5 Nov 2004
Howdy,

Did a little experiment recently, wanted to see how long my SL-C860 would last when used as purely a portable 'wireless' media player (i.e. streaming audio from a shoutcast station). I found a hack on these boards to stop suspend, threw my wireless card in (Netgear), tuned into cliqhop, put the volume 75% up, turned off the screen, and let it run.

I let it run for about 12 hours, and it said it still had 90% battery left - wow. Would have left it for longer but I use my Z daily :-)

Anybody else care to share what kind of battery life they get out of their Z with various usage? My Z has the best battery life of any PDA I've seen, hands down.
4 Nov 2004
Hi,

I'm using HostAP drivers with a Netgear CF card on Cacko 1.21b. The drivers came in an ipk called hostap-wireless-drivers_1.12-1_arm.ipk (which is a rather old version of hostap!).

It seems flaky as hell; iwconfig output is strange to say the least, and I notice connecting to a HostAP-based WEP network doesn't work; if I take WEP off the network, connect to it, then turn WEP back on, it can reconnect with WEP fine.

Kismet (3.0-something, from another ipk) seems also rather picky; it won't start unless you tell the Wireless applet to start scanning for a network. trying iwconfig commands to do things such as changing channel or mode often fail, until it is tried a second time.

I'm willing to bet this is a problem with an incompatible HostAP compile, and wireless-tools (the iw* suite), and having a reasonable bit of experience with wireless/hostap I'd like to fix it (please see my other thread about kernel sources!).

I'd also like to compile the hostap drivers with support for uploading firmware, because my Netgear card has firmware 1.4.9 (which is known to have problems).

Wondering if others are having the same problems though - no point fixing it if it ain't broke.
4 Nov 2004
Hi,

Where does one find kernel source for various ROMS/devices? I'm looking at compiling a few extra modules and need the sources to be able to do this. I'd also like to investigate what the pdaXrom kernel (patches?) would be like on Cacko.

It appears that all the 3rd party ROM kernels are based off patched versions of the original Sharp ROM's kernel. Is this right? i.e. pdaXrom and Cacko both use the original 2.4.18 sharp ROM, but with their own compiliations / patches added?

Are the newer 2.4.20 kernel sources (SL-C3000) available? Anybody tried this on older devices / 3rd party ROM's?

If so, where does one get the original ROM, and where does one get the patches for each popular ROM (or even better, is there a kernel tree maintained for each project)?

I've been Googling, but I can't find much. Apologies if this is obvious.
Last Visitors


7 Feb 2008 - 3:44

Comments
Other users have left no comments for nyar.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 19th December 2014 - 05:39 AM