OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
vorondil28 doesn't have a personal statement currently.
Personal Info
vorondil28
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 20-January 06
Profile Views: 291*
Last Seen: 18th March 2007 - 07:00 PM
Local Time: Dec 18 2014, 10:15 PM
36 posts (0 per day)
Contact Information
AIM Vorondil28
Yahoo Vorondil28
ICQ No Information
MSN goodjearb@gmail.com
* Profile views updated each hour

vorondil28

Members


Topics
Posts
Comments
Friends
My Content
16 Mar 2006
I got samba v3.0.10 installed the other day and after fiddling around in smb.conf, I finally got it working. I could browse to and from my 6000L over WiFi. File xfers were slow, but they worked. I've spent part of today continuing to play with it and suddenly, many of the samba programs stopped working. For instance,

CODE
root@Navi:~# smbpasswd -h
(output omitted, but list of options is correct)
root@Navi:~# smbpasswd -a user
Bus error
root@Navi:~# smbpasswd
Bus error
root@Navi:~# _


Where "user" is a valid username on my Z.

Another example,

CODE
root@Navi:~# smbclient -L \\\\COMPUTER -U=user
Password:
Domain=[COMPUTER] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
Bus error
root@Navi:~# _


Where "user" is a valid username on the WindowsXP machine: "COMPUTER," and the password was typed correctly.

Smbd seems to be having problems too:

CODE
root@Navi:~# smbd -i
smbd version 3.0.10 started.
Copyright Andrew Tridgell and the Samba Team 1992-2004
===============================================================
INTERNAL ERROR: Signal 7 in pid 4113 (3.0.10)
Please read the appendix Bugs of the Samba HOWTO collection
===============================================================
PANIC: internal error
BACKTRACE: 2 stack frames:
#0 smbd(smb_panic2+0x6c) [0x1649e8]
#1 [(nil)]
Aborted
root@Navi:~# _


This happens when I start smbd in interactive mode (-i) and attempt to connect to it from a WindowsXP machine by going Start > Run... > "\\IP_ADDRESS_OF_ZAURUS". The "INTERNAL ERROR" occurs immediately after hitting OK in the Run dialog. (Note that "smbd -i" continues to appear in a ps listing although I still cant view shares on the Z from another machine.) And the Windows machine then says: "\\IP_ADDRESS_OF_ZAURUS No network provider accepted the given network path." I've been all over Google and this forum but I have yet to find anyone who's seen this error. huh.gif

The Bugs portion of the Samba HOWTO doesn't yield anything useful other than how to submit a bug report and where to go to join a mailing list to ask about it. (Which I plan on doing if I can't figure this out. No need in bothering the Samba devs if a fellow OZ user happens to have seen this before. tongue.gif )

I've tried reinstalling Samba ("ipkg remove samba; ipkg -dest home install samba; ipkg-link add samba;" and even "ipkg -dest home -force-reinstall install samba") Reboots don't change anything. Haven't tried reflashing, which would probably work, but if I reinstalled Windows every time I had a problem... wink.gif


I'm at a loss. I've no clue what to try. Does a fellow OZ'er have any ideas?

Thanks for your help! smile.gif
13 Mar 2006
Hi all.

Installed gpe-filemanager v0.20-r2 on my 6000L under OZ-3.5.3/GPE today to /home/packages/. During install, ipkg didn't give me any errors. Used "ipkg-link add gpe-filemanager" to link it to root. It complained about not finding libs the first time I invoked it, so I manually created links from /home/packages/usr/lib/ to /usr/lib/ for each library it couldn't find (since ipkg also installed the libs it depends on to /home/packages/). Once that was taken care of, gpe-filemanager starts up and immediately gives the error: "Error: Invalid URI" and stays running. For every directory you try to look at it gives the same error. It also seems to exit cleanly and in the terminal I invoked it from, there's a pile of "GPE-ERROR: Error: Invalid URI" lines between prompts.

Here's an example of me invoking, attempting to get listings of four different (and valid) directories, then exiting:

CODE
vorondil@tosa:~$ gpe-filemanager
Installing monitor failed: Invalid URI
GPE-ERROR: Error: Invalid URI
GPE-ERROR: Error: Invalid URI
GPE-ERROR: Error: Invalid URI
GPE-ERROR: Error: Invalid URI
vorondil@tosa:~$ _


(Note that it behaves the same way whether invoked from sh or the icon created in the Utilities folder on the desktop.)


Any idea what I'm doing wrong? unsure.gif
Thanks in advance.
5 Mar 2006
Hi all.

When I suspend my 6000L under OZ-3.5.3/GPE while the internal wireless interface is enabled, it can't be brought back up after resume unless the unit is rebooted. dry.gif This is a known bug (http://bugs.treke.net/show_bug.cgi?id=698). However, I found that if I brought the interface down with "ifdown wlan0" before suspending, it would come back up with "ifup wlan0" after resume just fine.

So my question is: Is there any way to script (sh, perl, etc') bringing down the interface on suspend (both when the power button is held and when it "falls asleep")? It would also be nice to bring it back up on resume if it was up before suspend and leave it down if it was down before suspend.

This would be a nice workaround for the suspend bug until it's fixed but I don't know how to go about it. Of course, writing the script to bring down the interface is cake, but I don't know how to get it to run on suspend. unsure.gif


Any ideas?


Thanks in advance. smile.gif
4 Mar 2006
Hi all, I'm a new SL-6000L user. I flashed my unit to OZ/GPE last night and it doesn't seem to "see" the internal WiFi adapter. sleep.gif It worked fine under the Sharp ROM. Am I correct in assuming I don't have the proper kernel module installed for it? If so, I've no clue where to find a package for it.

Can anyone lend a hand?
Thanks in advance. smile.gif
22 Feb 2006
Hi all. I won a 6000L on ebay a little while ago; should be here Monday. happy.gif I can't wait.

Anyway, there seems to be bunches of 6000 owners around here (made evident by your respective sigs tongue.gif ), and I'm just curious as to what Zaurus accessories you (personally) consider essential? Cases? Cables? Extra Batteries? Screen protecors? Styli? CF/SD Cards? Others? What brands/models do you like/hate?

I am, of course, looking for 6000 accessories, but feel free to share your favorites for other Zaurus models if the inspiration so moves you!
Last Visitors
vorondil28 has no visitors to display.

Comments
Other users have left no comments for vorondil28.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 18th December 2014 - 07:15 PM