OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
> How can I restore my IMEI myself?
post Mar 20 2019, 01:37 PM
Post #1

Group: Members
Posts: 1
Joined: 19-March 19
Member No.: 844,513

Notice that I said myself, I dont have any interest in sending my phone to planet computers to be serviced.

That being said, after a flash I lost my NVRAM and subsequently my IMEI. I've tried just about everything and I THINK I could get it to work if I could find the valid MTK drivers for Windows but that doesnt seem to be working either.


I've found a few ways to go about this.

APPS: (Requires root)
  • Chamelephon
  • MTK Engineering mode
  • Termux

Software: (Requires MTK drivers)
  • Read&Write by WangWenJiang
  • SN Writer Tool
  • Maui Meta

So, as far as my experiences with them.

Chamelephon is the only one I've been able to get to work, and somehow the only time it worked was when I had flashed rooted android, but had not fully rooted it with magisk. I was able to go from no sim card detected to invalid IMEI. With the invalid IMEI status I was able to text and call but not receive cellular data. So I thought maybe if I completed the root with Magisk and tried again I would get cellular but no, after giving Chamelephon root privileges and trying again I went back to no SIM Detected

MTK Engineering mode is supposed to let you change IMEI under CDS Information, but that was not an option listed on my phone.

Rooted Termux apparently allows you to send some 'AT' commands to /etc/radio or something or other but that seemingly had no effect.

I am unable to get ANY of the software to work because I cannot install the MTK drivers properly. I have allowed for unsigned drivers each time and installed via add legacy programs in the device manager manually each time and while I am able to get them installed the drivers are listed as Code 10 (This device cannot start) each time. I have tried the MTK 65xx drivers and the MT6577 drivers, both giving me USB VCOM 8/9 Ports with code 10.

I just want my phone to work as a phone again If anyone has any extra avenues to try, or knows of the proper drivers that work with IMEI Writing software, let me know.
Attached thumbnail(s)
Attached Image
Go to the top of the page
+Quote Post
post Mar 21 2019, 12:41 AM
Post #2

Group: Admin
Posts: 905
Joined: 30-April 08
From: Italy
Member No.: 21,713

I'm also missing the CDS Information option under the MTK Engineering mode on my non-rooted Android. Have you tried the Engineering mode on a rooted system? Maybe in that case the option might become available.

How are you trying to send the AT commands under Termux? I'd like to give it a try, though I guess I'd have to root my system first, as you mentioned.

Also, do you have access to a PC with Linux installed? The MTK drivers might be already available under Linux, though I have seen that that's not the case with Void Linux, at least on my laptop.

Go to the top of the page
+Quote Post
post Mar 26 2019, 04:50 AM
Post #3

Group: Members
Posts: 1
Joined: 25-March 19
Member No.: 844,873

You don't need to send the device in, but the easiest way is contact Planet Computer support (hello@planetcom.co.uk), explain and ask for them to generate a replacement NVRAM partition. They'll ask for some sort of proof of IMEI (it's written on the packaging, so I just took a picture). They can then generate the right NVRAM partition for you to flash back to your Gemini.

I did this yesterday, and it definitely works.

I've been down the other route (rooted, termux) previously and managed to get IMEI working in Android, but the NVRAM partition also holds WiFi Mac and Bluetooth ids, and not having those causes a lot of other problems too. On Sailfish, I had absolutely no connectivity (wifi or 4G) without a working NVRAM partition. Likewise, I had no luck obtaining MTK drivers.

Hope that helps!
Go to the top of the page
+Quote Post
post Mar 28 2019, 09:40 AM
Post #4

Group: Members
Posts: 248
Joined: 13-January 18
From: UK
Member No.: 816,386

Planet's instructions for flashing include taking a backup of your NVRAM partition before making any changes.

This thread shows just why that's important… smile.gif

So, to everyone else, please take this as a reminder!
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 19th August 2019 - 07:14 PM