OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
James_L doesn't have a personal statement currently.
Personal Info
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
No Information
Joined: 14-February 10
Profile Views: 1,626*
Last Seen: 20th March 2010 - 02:16 PM
Local Time: Jan 26 2020, 04:13 PM
6 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour



My Content
24 Feb 2010
Allow me to introduce myself, and have been involved with the Zaurus since the SL-5500 came out. (I'm probably the first person to get mplayer working.) I used to run OZ and such, but got interested and involved in other projects, given the lack of support of collie (especially the sd, which finally got working) I recently saw an SL-6000L on ebay, and got it. Alas, the current state of support, wasn't as I thought it was from my looking at various sites.

Currently the status of Zaurus for me, broken down by category:
2.6.29 works, except for usb.
As far as I can tell, there is a conflict due to the way the tc6393 chip is accessed. The chip is only accessed via dma, but ohci-tmio and associated ohci calling it with due to patches, which use dma_*_coherent calls, which can't be called with interrupts disabled. Resulting in basically killing any ability to use it after that. If this were fixed, I would consider it fully usable after the distro specific issues (mostly keymaps) are resolved.

I'm working on tracking down what the problem is, but I honestly have not too high of an expectation of success, given my lack of experience with that portion of

2.6.33-rc8 has a compilation error which I have resolved. However, there are issues with the backlight. See: http://www.mail-archive.com/zaurus-devel@l...g/msg00189.html for more information.

Now, with that angstrom (dev branch):
Angstrom works mostly with opie, however, keys aren't right (this will be a common theme) Other than that, it works. Networking can be used via the CF slot. Though there isn't a web browser I've gotten working on opie, so I'm not using it. It by far has the best keymap, but even that lacks, as the numlock doesn't work.

X11 (GPE)
Similar situation with opie, though the keymap is also messed up, there are no numeric keys, Fn+ doesn't even work.

Using 1.1 (I think, 9.04 based) and the same 2.6.29 kernel most things work, as configured, it will boot such that the touchscreen is rotated in an odd way. Prior to booting, you need to copy /etc/keymap-2.6 from angstrom. You must logout from X. Then run ts_calibrate. The keymaps are messed up badly in X. I have not managed to generate one that works. Currently, I'm messing with Shepard's, which is fairly close, resulting in most keys being displaced one right or left.

According to some people in #ubuntu-arm, 9.04 is the last version for which it might work on armv5, without some serious recompiliation, which they said would take months. (I found that surprising, given how any other build system (gentoo, OE) I'm familiar with would give a usable system within at MOST a week, on anything relatively modern. They seem to have a problem with cross compilation, or something, it wasn't very clear.)

I've tried emailing the guy (cortez) whose blog is omegamoon, unfortunately, I haven't gotten any response. This, if I could get it working, might well be the best way to go.

Sharp ROM:
Works mostly, and what I've mostly been using, due to the usb bug. I have not tried X/Qt.

I'm mostly on freenode IRC as James_L, and frankly, I'd love to help or have other people with tosas help me.

I'd love any thoughts others have.
Last Visitors
James_L has no visitors to display.

Other users have left no comments for James_L.

There are no friends to display.
RSS Lo-Fi Version Time is now: 26th January 2020 - 01:13 PM