OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Testing TP2, lock-on-close-lid and brightness not working
psionlover
post Mar 25 2019, 11:42 AM
Post #1





Group: Members
Posts: 34
Joined: 25-June 18
Member No.: 825,001



A year ago I did a lot of testing on my gemini linux device and finally left it alone, because it did not work for the (very limited) use case I need it for. After a year I had some spare time and blew the dust from my gemini. The good news is that I made some progress and have more hope to use the gemini for my daily life. I want to use the gemini just offline and sync it with my desktop while being at home:
- agenda, contacts, tasks
- notes taking and text editing
- basic (osm) maps (foxtrotgps seems to fit the bill)
- music listening
- reading and annotating books and articles
Syncing is really a pain in the arse. Many progs don't like interference with their data from external systems. Other programs (like evolution) just refuse to work if there is no connection with a (caldev or carddev) server. I finallly found some very down to earth progs which just take what they are offered as data (calcurse, abook, wikidpad) and I succesfully using them for a while now. But I still have quite a few hick-ups which I hope you can help me with. I have TP2 installed and as far as I know I installed everything like I should. I did not use the flashtool to make a new image. Just upgraded from TP1. My main problem is that lock-on-close-lid is not working. I made sure 'enable lid watcher' is off as I understand it would interfere with 'xss-lock gemian-lock'. Another thing is that brightness is not working (not by 'Lxqt settings', nor by using Fn-N/Fn-B ). It used to work, I am not aware to have changed something.

If someone can give me hints I would very much like to hear.
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Adam Boardman
post Mar 26 2019, 10:30 AM
Post #2





Group: Members
Posts: 173
Joined: 29-December 17
Member No.: 815,489



So things like the kernel and the android system.img require a reboot before they take effect.

Your kernel version should be from a few days ago (yours is almost a year old May 2018!). I'd not go linking things just yet, try a reboot, and also check the date on the /usr/share/kernel/linux-boot.img file that you just wrote to you boot partition to see that it also has a build date of very recent. Is it possible you've not pressed the right combination of keys on boot to select boot3? (and then also have a linux kernel on one of the other boot partitions that you have actually booted?)

You can also check 'sudo cat /proc/cmdline' to see what 'androidboot.bootpartition=boot*' is set to to see which boot partition we think you selected.

Sorry I've not tried caldav calendars, but the point of sync stuff is that you have both ends being independent but tracking changes so that then you can sync them up later. I just did a google of 'syncevolution between two laptops' and the top two ubuntu forums with suggestions that sounded plausible, sorry again, not actually tried them, tool options - syncevolution or msynctool.

I'm hoping that the new kernel will solve your sleep issues (your May 18 one is ancient), so we'll look at that after you've confirmed Mar19 kernel is booting.

Uncertain whats going on with the brightness problem, the shortcuts just run '/usr/share/lxqt/scripts/brightness +' (or -), so try running those and see if they work or not? That'll tell us if the problem is on the shortcuts side or the brightness side.
Go to the top of the page
 
+Quote Post
psionlover
post Mar 26 2019, 12:52 PM
Post #3





Group: Members
Posts: 34
Joined: 25-June 18
Member No.: 825,001



QUOTE
Your kernel version should be from a few days ago (yours is almost a year old May 2018!)

You are right about the date, but it also states it is version 3.18.41 and that is the one you mention in your TP2 manual. So which is true ? A reboot (actually doing this continuously) does not help. I retried installing the new kernel and will show what I did. In both methods "sudo apt install gemini-kernel-image-3.18" and "sudo apt install gemian-modular-kernel" I finally get errors like
CODE
depmod: ERROR: could not open directory /lib/modules/3.18.41+: No such file or directory

/lib/modules/3.18.41+ indeed is missing on my system. I supposed that 3.18.41+ could be the same as 3.18.41 and made a symlink:
CODE
ln -s /lib/modules/3.18.41 /lib/modules/3.18.41+

Now both "sudo apt install gemini-kernel-image-3.18" and "sudo apt install gemian-modular-kernel" end without errors.
CODE
sudo apt install gemian-modular-kernel
[sudo] password for <user>:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages will be REMOVED:
  gemini-kernel-image-3.18
The following NEW packages will be installed:
  gemian-modular-kernel
0 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
Need to get 0 B/99.6 MB of archives.
After this operation, 5,108 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
dpkg: gemini-kernel-image-3.18:arm64: dependency problems, but removing anyway as you requested:
gemian-desktop-minimal depends on gemini-kernel-image-3.18 | gemian-modular-kernel; however:
  Package gemini-kernel-image-3.18:arm64 is to be removed.
  Package gemian-modular-kernel is not installed.

(Reading database ... 166557 files and directories currently installed.)
Removing gemini-kernel-image-3.18:arm64 (0.1+0~20190310135701.31~1.gbpf74f54) ...
dpkg: warning: while removing gemini-kernel-image-3.18:arm64, directory '/usr/share/kernel' not empty so not removed
dpkg: warning: while removing gemini-kernel-image-3.18:arm64, directory '/lib/modules/3.18.41' not empty so not removed
Selecting previously unselected package gemian-modular-kernel:arm64.
(Reading database ... 165282 files and directories currently installed.)
Preparing to unpack .../gemian-modular-kernel_0.2+0~20190321181532.42~1.gbpf8ea9a_arm64.deb ...
Unpacking gemian-modular-kernel:arm64 (0.2+0~20190321181532.42~1.gbpf8ea9a) ...
Setting up gemian-modular-kernel:arm64 (0.2+0~20190321181532.42~1.gbpf8ea9a) ...
running depmod%] [#########################................................]
Kernel images installed to /usr/share/kernel/
You need to write the correct kernel to the correct boot partition based upon your boot configuration.
eg: sudo dd if=/usr/share/kernel/linux-boot.img of=/dev/disk/by-partlabel/boot2
or: sudo dd if=/usr/share/kernel/linux-boot-stowaways-debian.img of=/dev/disk/by-partlabel/boot3
After writing the kernel image a reboot is necessary to use the new kernel.
$ sudo dd if=/usr/share/kernel/linux-boot-stowaways-debian.img of=/dev/disk/by-partlabel/boot3
29072+0 records in
29072+0 records out
14884864 bytes (15 MB, 14 MiB) copied, 2.01651 s, 7.4 MB/s
$ sudo shutdown -r now
$ ssh <user>@gemini
$ uname -a
Linux geminiPDA 3.18.41+ #7 SMP PREEMPT Wed May 30 16:45:45 MSK 2018 aarch64 GNU/Linux

So if my system really still has an old kernel, I am afraid I don't know what to do else to get a recent kernel. Only thing I can think of is using the flashtool to install TP2 from scratch. But I *hate* that, it feels like doing trial and error and that is exactly what I want to avoid by using a device like gemini.
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th November 2019 - 10:52 PM