OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
Pete G. doesn't have a personal statement currently.
Personal Info
Pete G.
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 9-February 18
Profile Views: 142*
Last Seen: Yesterday, 10:15 AM
Local Time: Aug 18 2018, 03:57 AM
40 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

Pete G.

Members


Topics
Posts
Comments
Friends
My Content
21 Jul 2018
Looking at my battery usage, I see "Cell Standby" as the second-highest usage after the screen. From a web search, this seems to be a utility looking for a strong cell signal. Strange... because my unit is WiFi only!

Anybody have an explanation? And know how I might get rid of it? (I'm fairly sure it wasn't there the previous time I looked, though I suppose I could have missed it.)
28 Jun 2018
I would very much like to be able to launch Android apps (in particular, Firefox) from a Termux command line. This seems to be possible through the 'am' command (included in basic Termux, though I think it's actually part of the SDK(?)), but I'm not having any luck.

I found a topic on StackOverflow that seems to show how to do it -- using the Android Browser as an example:

CODE
   am start -a android.intent.action.MAIN -n com.android.browser/com.android.browser.BrowserActivity


This works fine -- except that I refuse to use that browser...

I've tried all sorts of similar lines for Firefox, such as:

CODE
am start -a android.intent.action.MAIN -n org.mozilla.gecko/org.mozilla.gecko.LauncherActivity


but I always get back something like:
CODE
Starting: Intent { act=android.intent.action.MAIN cmp=org.mozilla.gecko/.LauncherActivity }
Error: Activity not started, unknown error code -2


I've been getting the possibilities from the Firefox AndroidManifest.xml (extracted from the APK and unpacked from the binary, but I don't know anything about it, really, so I'm pretty much lost. Here's a severely extracted section of the file:

CODE
<?xml version="1.0" encoding="utf-8"?>
<manifest
.....
<application
.....
android:value="com.google.android.gms.version" />
<service
android:name="org.mozilla.gecko.RemotePresentationService"
android:exported="com.google.android.gms.version" />
<activity
android:theme="com.google.android.gms.version"
android:name="org.mozilla.gecko.LauncherActivity"
android:exported="com.google.android.gms.version"
android:taskAffinity=""
android:excludeFromRecents="com.google.android.gms.version"
android:relinquishTaskIdentity="com.google.android.gms.version" />
<activity-alias
android:label="Firefox"
android:name=".App"
android:targetActivity="org.mozilla.gecko.LauncherActivity">
<intent-filter android:priority="com.google.android.gms.version">
<action android:name="android.intent.action.MAIN" />
<category android:name="android.intent.category.LAUNCHER" />
<category android:name="android.intent.category.MULTIWINDOW_LAUNCHER" />
<category android:name="android.intent.category.APP_BROWSER" />
<category android:name="android.intent.category.DEFAULT" />
</intent-filter>
<intent-filter>
<action android:name="android.intent.action.VIEW" />
<category android:name="android.intent.category.DEFAULT" />
<category android:name="android.intent.category.BROWSABLE" />
<data android:scheme="http" />
<data android:scheme="https" />
<data android:scheme="about" />
<data android:scheme="javascript" />
<data android:scheme="firefox" />
</intent-filter>
.....
</activity-alias>
<activity
android:theme="com.google.android.gms.version"
android:label="com.google.android.gms.version"
android:name="org.mozilla.gecko.BrowserApp"
android:exported="com.google.android.gms.version"
android:taskAffinity="org.mozilla.firefox.BROWSER"
android:launchMode="com.google.android.gms.version"
android:configChanges="com.google.android.gms.version"
android:alwaysRetainTaskState="com.google.android.gms.version"
android:windowSoftInputMode="com.google.android.gms.version" />
<activity-alias
android:name="com.android.internal.app.ResolverActivity"
android:exported="com.google.android.gms.version"
android:targetActivity="org.mozilla.gecko.BrowserApp" />
.....
</application>
</manifest>


Anybody deep into Android enough to know what I might do?
27 Jun 2018
I thought the termux-widget add-on -- which supposedly adds shortcuts to termux scripts on your home screen -- would be a useful thing to have, so I installed it, but I can't get any action out of it. I gather that any script in $HOME/.shortcuts should appear in a screen shortcut, but I never see anything. The web is totally unhelpful. Has anybody used it?
24 Jun 2018
As the Gemini's strength is its text editing, one of the things I expected to do a lot would be to either grab text from another machine and edit it, or just create the text on the Gemini and send it somewhere else. But I've completely failed to find any decent file-transfer app for Android! I thought at least there'd be ftp. I found one "Send to FTP", but its UI is terrible, so I dumped it again. NitroShare also looked good, but when I installed it on the Gemini and my laptop (Mint), the two completely fail to communicate. (I've added an issue on its Github page, so maybe it could be solved.)

Of course I have termux, which has FTP, but the command-line is not the most convenient interface here!

Does anyone know of something more useful?
20 Jun 2018
I've been trying to find a way to communicate between termux work and android apps, and eventually stumbled across xdg-open, which in Linux "opens a file or URL in the user's preferred application". I have a test html file in my termux area that I'd like to open in Firefox -- which I've set as my default. However if I invoke xdg-open on it, it only gives me a choice of Chrome, plus some other irrelevant options. Anyone know what's going on here -- and how to get what I want?
Last Visitors


12 Jun 2018 - 23:34


9 Feb 2018 - 23:43

Comments
Other users have left no comments for Pete G..

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 18th August 2018 - 02:57 AM