OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Gemini multiboot - Boot problems
Will Atl
post Jan 26 2019, 02:28 PM
Post #1





Group: Members
Posts: 28
Joined: 8-December 18
Member No.: 837,835



I recently got my Gemini 4G and flashed multiboot Android 41GB and Linux 15GB (Please see Multiboot file attached).

Got Debian and Linux running ok but I experienced a few freezes and crashes on Debian as mentioned elsewhere.
After a few times it did not boot anymore into anything.
As I had very little data, I just re-flashed the Gemini again and it started to work fine.
I used it in Linux and Android with no problems. Rebooted it into Linux and Android several times to test it with no issues for a few days.

After that I started downloading apps, data and configuring it.

All of a sudden and with no apparent cause, it did not boot into Android any longer. It continued to be able to boot perfectly well into Linux and into Recovery mode.
But when I tried to boot into Android it just stayed stuck in the Planet image forever. (Did not get to the part that says “Powered by Android”, nor the spinning Planets).

In Recovery Mode I did a "Root integrity check” and everything was fine. Also through recovery Mode rebooted the system, and rebooted into boot loader with the same results.
(I could always boot into Linux perfectly fine but not into Android)

While trying to fix it, I tried using the Flash Tool set to “Download Only” instead of “Firmware Upgrade”, but nevertheless it erased everything (I had hoped it would preserve the data).

I cannot point to any evident cause to generate this. The only thing I can mention is that right before it started to happen I tried to copy files on Linux from a MicroSD card I had used with another Android phone before (using a USBC Adapter that worked fine with Note 9 and Mac - The card is separate from the one on the Gemini). Linux said it could not read it, so that is why I decided to boot into Android to have it reformat the card to avoid issues. It never rebooted into Android.
(This seems completely unrelated though)

I fear it might continue to happen again and again after investing a lot of time setting everything up just to erase it all again.

I just emailed Planet Computers support but in the meantime is this a known issue ?
Seems something to do with the boot loader. I am sure the underlying data was fine. Had anyone else experienced this?

If I only used Android would this potentially happen too ? Or that is much more reliable ?
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 4th June 2020 - 07:59 PM