OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
> Is there anyone who can create a well-working linux package for debian, small little glitches which make hard to work with Gemini official img
szilveszter domo...
post Jun 7 2019, 01:43 AM
Post #1

Group: Members
Posts: 7
Joined: 4-June 19
Member No.: 849,313


I tried both Kali and Debian stretch on my gemini, and it seriously hard to work with it currently. Is here anyone who can share a flash able image, which consistent and components working well, well is the key. I am personally saw this GUI first time in my life (used Xdebian/Xubuntu,Gnome , KDE and might couple of more, but for one time i can't even recall)...

Issues which actually make life harder is that out-of-box new image come with conflicts/incorrect dependencys. Debian has libreoffice by default, but it will fail the upgrade. on Kali it even worse, because the conflict will rise during the upgrade and you will not be able to boot the device anymore, if you can't solve it in that session, as far i remember packages which were involved are vim,vim* and kali distribution. What I could do remove from catalog and binarias, could not resolved via dpkg and apt. Furthermore if you upgrade KDE imported apps will not work properly , like ARK which will be not able to extract or create archive.

So a custom debian which support the following options would be really good:
Consistent apps and version
More useable gui like kde/gnome
Allowing f1-f12 by default to check the console messages and dbus during the boot, and if GUI fails somewhy still possible to do anything else than reflash...
Supporting all pheriphereis, I still struggling with bluetooth audio, can connect and trust but pulseaido fail and reset pulse each time (with max volume on speaker) biggrin.gif when you want to select the bloototh device in Bluetoothctl I can see connected as audio-card...

These were the first pains i observed on my first week, I was trying out sailfish as well, but I don't think that will be enough for me at all smile.gif... Gemini should keep drivers updated, but it seems not happening in general . I also read some articles at maemo forum, and it seems that are couple people already put a good system together, what I would like to have a flashable image of one of the all working systems.
Go to the top of the page
+Quote Post
Thiago Alves
post Aug 3 2019, 07:41 PM
Post #2

Group: Members
Posts: 11
Joined: 20-July 19
Member No.: 852,376

This is my personal recipe for a perfect install. Sorry I'm copying pasting my notes, so if it is not clear, just ask me. What I found out is that Android 8 is sketchy at best. When I tried to dual boot Gemian and Android 8 I was having all sorts of problems (apparently they both share the same kernel, IDK). Then I reflashed the whole thing with Android 7 and Gemian and things started to work a bit better. After installing the old Android 7 + Gemian duo, here is my after install perfect recipe:


1. Install old image (Linux + Android 7)
2. Don't apt upgrade the system as it will break it, but update the repository info:
wget http://gemian.thinkglobally.org/archive-key.asc
sudo apt-key add archive-key.asc
sudo apt update

3. Install gemian-modular-kernel and gemian-modular-kernel-headers:
sudo apt install gemian-modular-kernel gemian-modular-kernel-headers

4. Set timezone:
sudo dpkg-reconfigure tzdata

5. pick a language_location specific UTF8 locale:
sudo dpkg-reconfigure locales

6. Disable sleep:
sudo nano /etc/X11/xorg.conf

At the top of the file there is a ServerFlags section. Add/replace the following in the ServerFlags section:
    Option "OffTime" "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "BlankTime" "0"

7. Lock the MAC address

Install hexedit:
sudo apt install hexedit

sudo hexedit /nvdata/APCFG/APRDEB/WIFI

and set a mac address in bytes 04-09 (mind that the base is 0, so it starts at the 5th byte) of the first row (0)
TIP: This can be optional as most times the MAC address is already set in there. So just close hexedit and proceed.
set the i attr on the file:
sudo chattr +i /nvdata/APCFG/APRDEB/WIFI

This will lock down the mac address.

8. Change user name: https://askubuntu.com/questions/34074/how-d...nge-my-username
NOTE: usermod only works on root. So all commands must be ran on sudo su

9. Touchscreen as touchpad: https://www.oesf.org/forum/index.php?showto...p;mode=threaded

10. Bluetooth mouse:
sudo apt install bluetooth blueman
Go to the top of the page
+Quote Post
Eric BF
post Aug 4 2019, 10:16 AM
Post #3

Group: Members
Posts: 84
Joined: 25-June 18
Member No.: 824,997


I am curious: why disable sleep?
Go to the top of the page
+Quote Post
post Aug 5 2019, 09:33 AM
Post #4

Group: Members
Posts: 180
Joined: 7-January 18
Member No.: 815,997

I'd suggest to perform the updates. Without updates you won't get updated versions of i.e. the camera app which work with the Gemini. Well, without updating the old image you won't even get the modular kernel. The broken Libreoffice update is fixable:
@see: https://www.mygnu.de/2019/02/libreoffice-update-failure and some topics in this forum

All other updates worked for me.

Go to the top of the page
+Quote Post
Thiago Alves
post Aug 6 2019, 04:41 AM
Post #5

Group: Members
Posts: 11
Joined: 20-July 19
Member No.: 852,376

@Erick BF: I disabled sleep because it was annoyingly stopping long processes. I would leave the Gemini compiling something big just to find out later that the auto sleep had put the device to sleep and killed all my processes. Not to mention that the auto sleep is (at least on my device) a bit buggy. Sometimes the device would enter in seep mode to never wake up again. I would have to hold the "on" button for several seconds until the device rebooted.

@mithrandir: I'm not talking about LibreOffice update. When I apt upgrade my system after a fresh install, it is breaking something that prevents lxqt panel to initialize. The system was still booting and running, but was very hard to use without the panel taskbar. When I tried to figure out where the problem was, it looked like something related to pulse audio, which then was hanging the little volume control that was in the panel, which then hanged the panel initialization. I reflashed the system twice and the same problem happened. I had no issues when I apt upgrade from the new Android 8 + Linux image. So perhaps there is something from the old image that doesn't update properly. However, even without the upgrade I was able to get the modular kernel:
$ uname -a
Linux localhost 3.18.41 #1 SMP PREEMPT Fri May 24 19:53:00 UTC 2019 aarch64 GNU/Linux

$ lsmod
Module                  Size  Used by
mousedev               11309  0
joydev                 11231  0
uio_pdrv_genirq         3587  0
uio                     9769  1 uio_pdrv_genirq
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 10th July 2020 - 02:06 PM