OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
> C860 won't charge batteries
post Jul 14 2004, 02:09 PM
Post #1

Group: Members
Posts: 91
Joined: 28-April 04
From: Guildford, UK
Member No.: 3,047

I think I have a problem- my C860 was bought secondhand but doesn't seem to charge the battery (I have three batteries so I don't think it's the battery!).

I only noticed on the train last night when I pulled out the Z to read an ebook (Linux for dummies wink.gif ) and the battery only lasted five minutes before the Z told me it needed charging. this was odd because the Z had been on a power supply (a sharp one) all day....

I have tried the Z with the power supply it came with (5V 2A), another Sharp PSU from a minidisc player (5V 800mA) and a USB sync/charge cable. I checked the output of the two sharp PSUs and they are both outputting 5.2V. The charge light comes on solid and the GUI says it's charging but when I remove the power the battery charge drops down to where it was before. I've tried charging the unit with the PDA turned off too, same result. I have a sharp desktop battery charger so I can still use the Z, but swapping batteries out in the field is a bit of a PITA.

I did a search and Stubear seems to have had this problem before, but I don't think anyone knew exactly what the issue was.....

Anyone got any ideas? Do I have a faulty Z? sad.gif
Go to the top of the page
+Quote Post
post Jul 15 2004, 02:11 AM
Post #2

Group: Members
Posts: 626
Joined: 13-April 04
From: Ireland
Member No.: 2,825

It sounds like the charging circuit is damaged... suggest putting a cheap multimeter inline with the power supply and monitor the current... if it's near minimal when the Z is in suspend then it's not charging.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 22nd October 2017 - 04:08 AM