OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Can't Mount Cf Card, I think i'm missing something.
cybernetseraph
post Oct 25 2005, 01:39 AM
Post #1





Group: Members
Posts: 31
Joined: 31-January 05
Member No.: 6,363



Hey,
I've installed the snapshot (as of the 23rd oct i believe). and i've been configuring it to my liking. However, i've hada problem mounting my cf card.

I know it's /dev/wd1c, it's fat32 formatted. however, there's no mount_vfat option for mount, and mount_msdos gives the error
CODE
mount_msdos: /dev/wd1c on /mnt/cf: Inappropriate file type or format


is it possiblt to mount this drive? or am i going to have to reformat it fat16?

I need to use it on windows (at Uni), and linux at home, so ffs wouldn't be suitable.

apart from this little hiccup i'm very happy with it.

One other question. does anyone know if they're working on autorotation? I don't use it often, but it would be handy.

I know pdaXrom has it, but i think they use a different mechanism (they have a shell script that runs when it rotates, OBSD's is in the xorg.conf).

thanks for any help.

-0-
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Wildherb
post Oct 3 2008, 05:38 AM
Post #2





Group: Members
Posts: 92
Joined: 9-January 06
Member No.: 8,887



I'm having real trouble mounting CF card on OBSD 4.3

before starting X, If I insert or remove the CF card I see it referenced as wd1 and wdc1

If I do disklabel wd1 I see a c partition (unused) and an i partition (MSDOS)

fdisk wd1 shows four partitions, the first being formatteed Win95 FAT and the others all unused.

There cant be a technical problem becuse I installed the operating system from the same media card!

very similar story if I put a memory stick on the USB host cable, is shows as sd1 with disklabel partitions c and i, four partitions under fdisk.

I'm confused. 8(

====EDIT====
Ive concluded that somehow my system was screwed as I could also not edit simplt files such as kismet.conf
Done a rebuild and now I can mount CF and also, I can mount SD is this a first on OBSD??

mount_msdos /dev/wd1i /mnt/cf
mount_msdos /dev/sd0i /mnt/card

BINGO!
Go to the top of the page
 
+Quote Post
Lance
post Oct 3 2008, 03:35 PM
Post #3





Group: Members
Posts: 15
Joined: 20-January 04
From: Wichita Falls, TX USA
Member No.: 1,484



<QUOTE>
Done a rebuild and now I can mount CF and also, I can mount SD is this a first on OBSD??
</QUOTE>

Mounting and reading an SD card is no problem. It's writing to the SD card that's been the problem.
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th October 2014 - 02:12 AM