OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Opera Mini, ... on the Z
post Jan 9 2006, 05:24 AM
Post #1

Group: Members
Posts: 129
Joined: 29-May 04
Member No.: 3,485


just a quick note for those interested: the low memory version of Opera Mini (UserAgent: Opera/8.01 (J2ME/MIDP; Opera Mini/1.1.2421/lofi/nordic/de; mobile phone; de; U; ssr)) will run on the Z using Jeode in conjunction with ME4SE. biggrin.gif

I'll leave the decision whether or not this is a sensible thing to do to the readers ... rolleyes.gif

Best regards,
Go to the top of the page
+Quote Post
Start new topic
post Feb 15 2006, 04:16 PM
Post #2

Group: Members
Posts: 27
Joined: 30-July 04
From: NJ, USA
Member No.: 4,160

Here is how I got it to work:
Get the following files all into one directory.
*-------Optional if you have trouble with the above----------------------------*


Rename operette-lofi-us.jar to opera-mini-1.2.2960-basic-us.jar
Rename operette-hofi-us.jar to opera-mini-1.2.2960-advanced-us.jar
Or direct link
Or directly from:
Make a shell script to launch OperaMini.
-Copy the lines below without the copy and paste sections they are just markers.
-Create a file and paste the lines into it. I named mine OpraMini.sh.
-You may have to change the permisions on the file you created.
-The file works with either Linux Java or Jeode on a Zaurus.
-Run the script.

if [ `which evm 2>/dev/null` ]
evm -Xprogress -XappName=$0 -cp "me4se.jar:javapng-2.0-rc3.jar:opera-mini-1.2.2960-basic-us.jar"" org.me4se.MIDletRunner com.opera.browser.Browser

if [ `which java 2>/dev/null` ]
java -cp "me4se.jar:javapng-2.0-rc3.jar:opera-mini-1.2.2960-basic-us.jar" org.me4se.MIDletRunner com.opera.browser.Browser
Are we allowed to post these files on here? I can post a complete archive with everything needed. I'll also see if I can make a clickable icon so you wont have to launch it from a shell. smile.gif

The fonts really small, but you press "*" to get started and then click OK, you only need to do this once.

BTW, the script works with either Java on a Linux machine or the Zaurus at least on my two setups it worked.

Obviously this is what works for me. Your milage may vary.
Go to the top of the page
+Quote Post
post Apr 7 2006, 04:58 PM
Post #3

Group: Members
Posts: 6
Joined: 28-December 05
Member No.: 8,797

Thanks a lot for these instructions!
Five remarks:

1. basic operamini works on my Zaurus SL-5500 cacko rom, while advanced doesn't (so if someone is worried that it will not work at all just change to basic option)

2. there are inverted commas missing at one point in the script (after the second-time opera-mini-... should be twice, i.e. "") so it should properly be:


if [ `which evm 2>/dev/null` ]
evm -Xprogress -XappName=$0 -cp "me4se.jar:javapng-2.0-rc3.jar:opera-mini-1.2.2960-basic-us.jar"" org.me4se.MIDletRunner com.opera.browser.Browser

if [ `which java 2>/dev/null` ]
java -cp "me4se.jar:javapng-2.0-rc3.jar:opera-mini-1.2.2960-basic-us.jar"" org.me4se.MIDletRunner com.opera.browser.Browser

3. my script filename is simply " operamini " without " sh " as commonly Zaurus executables have no extension, I don't know if it changes anything

4. Obviously remember to change references in the script to the proper filenames - in my case that was opera-mini-1.2.3214-basic-uk.jar

5. I also put the relevant jad file in the same directory - just in case - so try that if else it doesn't work

Go to the top of the page
+Quote Post
post Jan 2 2007, 03:51 PM
Post #4

Group: Members
Posts: 213
Joined: 13-May 04
From: Tucson, AZ
Member No.: 3,262

I'm seeing this when I try to run opera on my 5500 running OpenZaurus

---=== ME4SE Version 2.5.1 ===---
Exception in thread "main", java.lang.NoSuchMethodError: java/lang/System.setProperty(Ljava/lang/String;Ljava/lang/String;)Ljava/lang/String;
at javax.microedition.midlet.ApplicationManager.setSystemProperty (bytecode 21)
at javax.microedition.midlet.ApplicationManager.<init> (bytecode 186)
at org.me4se.MIDletRunner.main (bytecode 147)

my script reads

evm -Xprogress -XappName=$0 -cp "me4se-2.2.0.jar:javapng-2.0-rc6.jar:opera-mini-3.0.6540-basic-int.jar" org.me4se.MIDletRunner com.opera.browser.Browser
Go to the top of the page
+Quote Post

Posts in this topic
chrget   Opera Mini   Jan 9 2006, 05:24 AM
Meanie   QUOTE(chrget @ Jan 9 2006, 11:24 PM)Hello, j...   Jan 9 2006, 06:52 AM
cwaig   How exactly do you use me2se to run Opera-mini? I...   Jan 26 2006, 01:13 AM
ashikase   QUOTE(chrget @ Jan 9 2006, 10:24 PM)just a qu...   Feb 15 2006, 12:21 AM
eji   Yeah, can anyone specify exactly how to get it run...   Feb 15 2006, 12:32 AM
chrget   QUOTE(eji @ Feb 15 2006, 10:32 AM)Yeah, can a...   Feb 15 2006, 01:06 PM
eji   Chris, I'm getting an "opt" error th...   Feb 15 2006, 03:42 PM
Lexx   Here is how I got it to work: Get the following fi...   Feb 15 2006, 04:16 PM
paxel   Thanks a lot for these instructions! Five rema...   Apr 7 2006, 04:58 PM
JohnKiniston   I'm seeing this when I try to run opera on my ...   Jan 2 2007, 03:51 PM
rjohnson1969   QUOTE(JohnKiniston @ Jan 2 2007, 05:51 PM)I...   Sep 18 2007, 11:47 AM
ashikase   After realizing that there were multiple versions ...   Feb 15 2006, 05:12 PM
eji   I'm repeatedly getting a java.lang.NoClassDefF...   Feb 20 2006, 06:38 AM
Lexx   @ eji RE: Size of a US Quarter I guess your runni...   Feb 20 2006, 08:26 AM
eji   QUOTE(Lexx @ Feb 20 2006, 04:26 PM)@ eji RE:...   Feb 20 2006, 09:24 AM
Lexx   Ah! OK. I run it on the desktop as well as on ...   Feb 20 2006, 04:54 PM
Meanie   QUOTE(Lexx @ Feb 21 2006, 10:54 AM)Ah! OK...   Feb 20 2006, 05:28 PM
Lexx   @Meanie Nice! It'd be very nice if that co...   Feb 21 2006, 06:52 PM
matrix200   How does it compare to Opera 7.55? I am running 7....   Feb 22 2006, 12:04 PM
ashikase   QUOTE(matrix200 @ Feb 23 2006, 05:04 AM)I am ...   Feb 22 2006, 04:17 PM
ShiroiKuma   Reviving a very old topic, maybe someone still use...   Sep 5 2008, 06:30 AM
sdjf   Can anyone with Sharp ROM or an sl6000 explain whe...   Nov 21 2011, 08:52 AM
sdjf   More details on my most recent attempt to run: ba...   Nov 21 2011, 08:58 AM
Dromede   Microemulator might be a better way of running J2M...   Nov 23 2011, 09:04 AM
cybersphinx   QUOTE(sdjf @ Nov 21 2011, 05:58 PM) The f...   Nov 23 2011, 03:30 PM
sdjf   QUOTE(cybersphinx @ Nov 23 2011, 04:30 PM...   Nov 23 2011, 06:24 PM
sdjf   The command has to go in a shell script as bash co...   Nov 23 2011, 11:06 PM
sdjf   I am still struggling with this, it is finally jus...   Nov 29 2011, 07:56 AM
sdjf   Well, with Quickening's assistance, I got it r...   Nov 29 2011, 04:26 PM
sdjf   Got it running on Tosa as well. Had to install Je...   Dec 1 2011, 07:16 AM

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 24th June 2018 - 09:00 AM