OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Opie-feed Gcc Compile Woes!, Help needed to set variables to compile.
snowfarthing
post Jun 19 2006, 11:33 AM
Post #1





Group: Members
Posts: 32
Joined: 29-October 04
Member No.: 5,265



I'm currently trying to compile teTeX on my 5500 Zaurus (with OpenZaurus 3.5.4 installed) using the gcc files available from the Opie feed: g++ 3.4.4-r5, g++-sympinks, g++-rc 0.1.9-r1, g77 and etc, gcc and etc, and gcov. I've followed everything according to the teTeX INSTALL instructions, and when I try compiling, I get:

CODE
loading cache ./config.cache
checking whether make sets ${MAKE}... no
checking for gcc... arm-linux-gcc                                        # or whatever I set CC to be
checking whether the C compiler (arm-linux-gcc -O -g) works... no
configure:  error:  installation or configuration problem:  C compiler cannot create executables.

I've tried setting CC to gcc, cc, arm-linux-gcc, and g++, and I get the same results every time.

When I tried an even more basic program, hello.cpp, I received the following:

CODE
root@collie:  /media/card/.../tetex-src-3.0 # gcc -O -g hello.cpp
hello.cpp: 1: 22: iostream.h:  No such file or directory
hello.cpp:  In function `int main()':
hello.cpp:  5:  error: `cout' undeclared (first use of this function)
hello.cpp:  5:  error:  (Each undeclared identifier is reported only once for each function it appears in.)
hello.cpp:  8:  2:  no newline at end of file

Since I get similar results when I try to compile hello.c, I'm certain that I need to set variables for certain paths; unfortunately, I have no idea what those varialbes would be, or what paths I need to set! What do I need to do in order to compile things successfully?
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
snowfarthing
post Jun 28 2006, 05:51 PM
Post #2





Group: Members
Posts: 32
Joined: 29-October 04
Member No.: 5,265



Just yesterday I got a laptop (Pentium, 48 Meg, not much else) that I'd like to put DSL Linux on. I was unsuccessful because of floppy drive problems; nonetheless, I realized that I'd rather put Opie on it biggrin.gif

To get back on topic, I was finally able to download the above files and install them on my Zaurus. (The feed is finally working again! I really wish I could set up my Zaurus on a network; unfortunately that isn't an option for me right now sad.gif .) I'd like to note that libc6-dev needed the following dependencies:

linux-libc-headers-dev
glibc-extras-nss
libthread-db1
.

For good measure I also installed libsdtc++-dev.

Now hello.cpp gives a lot of errors when I try to compile! So many, I decided to attach them rather than list them here.

I wonder if I need more gcc options to get it to work. I haven't yet tried compiling anything, though, so I don't yet know if I have everything I need. (I think I will also need make).

Ironically, I discovered yesterday that tetex is in the feed. I'll be trying to download those and install them. Even so, I still would like to be able to compile things! In particular, I'd like to install Macaulay 2, and YACAS, and perhaps KSEG (except that KSEG relies too much on regular Qt).

(As you can probably guess, I'm a mathematician. Unfortunately for me, I'm a mathematician who thinks that a Zaurus with a Targus keyboard is the perfect size for a laptop, if only it could run everything.)
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th August 2014 - 04:41 AM