OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Akita To Xp ... Are You There?
Armagon
post Nov 18 2006, 08:31 AM
Post #1





Group: Members
Posts: 106
Joined: 19-October 05
From: Cardston, AB, Canada
Member No.: 8,348



I'm wondering how to move data between my Akita (C1000) and a Windows XP box (such as those used at work.)

TCP/IP over USB

It appears that TCP/IP over USB not working with a C1000 and XP is a known issue:

QUOTE(papercrane @ Mar 29 2006, 12:32 PM)
The Cxx00 doesn't talk to Windows correctly yet. Richard Purdie "has some hints" which should make it work but he hasn't had time to implement them yet. :-/
*


Mass storage device

It appears to me that the mass storage device doesn't work without patching the kernel, and that's really not something I want to do. [I did play around with trying to modprobe g_file_storage with different devices, including a special file, as described here, but my PCs (running Linux or Win XP) weren't happy about it, and continually reset the usb connection. [I can add more details if it helps.]]

Other alternatives

Sigh. My SD card is ext2 formatted and running an altbooted GPE; I don't have a CF card.

... Wait a second ... I have a FAT formatted SD card in my camera ... and sure enough, I can write to it from my Z! [Wow, using that to transfer data does rather strike me as (almost) ... abusing ... the camera!]

Well, that's probably easier than trying to force my 500 mA max USB to serial port converter to work (not to mention the fact that it means I don't need to make a null-modem cable) (although, perversely, if I had the time, I think I'd give it a try. Surely normal communications use nowhere near 500 mA! I just posted another question finding out if it is safe to use or not.)

The only other option (barring really esoteric things like playing back and recording data encoded in audio) I could see was IRDA, and my Z is the only device that uses it. [Hmm... Still want to try to make it work as a TV remote control...] And no, I don't have any bluetooth or wifi hardware at all.

Questions

My questions, then: am I right that the first two options do not currently work (and are they being addressed? -- ack... I didn't see them in the bugtracker. Is there a guide for writing up OE bugs anywhere, or shall I just wing it?), and, um, was there any communication option that I've overlooked that might work for me.

Thank you,
Armagon
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd September 2014 - 02:16 AM