OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

> Some Questions About The C3200, Some help for new C3200 owner?
post Aug 1 2007, 06:28 AM
Post #1

Group: Members
Posts: 21
Joined: 14-December 05
Member No.: 8,715

Hello. I have had my C3200 for about a week now. Before that, I had an SL-5500. So far my impression is "why did I wait so long to upgrade?" I thought the SL-5500 was like a mini computer, the C3200 is so much more so.

Sorry in advance for long post. The bold headings are the parts that are most important. There are a few things I was hoping to get working on my C3200 that I haven't been able to yet. I have done many searches and just haven't got these fixed yet, so I was hoping maybe someone knew the answers or could better point me in the right direction. I'm still using the stock ROM. I've installed stuff, but haven't flashed anything yet.

First of all...thanks a ton to Meanie. I'm sure everyone says that. I would still be reading Japanese on my Zaurus if it weren't for those extensive customization pages. And also thanks to Cresho because he was very helpful back in my SL-5500 days and I know he does a lot of helping around here.

What works:
USB-Keyboard - usbkbd-en_2.4.20_arm.ipk (I need to reconfigure the xml mapping, though, because some keys weren't mapped properly)
USB-Mouse - inputhelper_1.0.1-1_arm.ipk
Zemufeex - zemufe_0.1.1-3ex_arm.ipk (so far, I tested SNES9X and ZNESTER, I also installed snes9x-sdljoy to work with my joypad, the buttons work but the directional controls do not, see below)
opie-embeddedkonsole (qkonsole crashes when the mouse is plugged in, so I used the terminal app from my SL-5500 in non-mag mode)
qpose - space trader is finally available on my Zaurus, yay
2GB Sandisk SD card - worked perfectly without any coaxing (didn't work on SL-5500)

What does not work:
USB HDD I bought a 120GB USB HDD, it is formatted as NTFS. I installed automounter_c3000_0.5.0_arm.ipk and ntfs-zaurus_2.4.20_arm.ipk ... I can get fdisk to show me that the drive exists and that it is NTFS, but it doesn't mount, and if I try to mount it manually (mount /dev/sda1 /mnt/usbstorage) then it tells me that it's an invalid argument.

WiFi I have a sandisk plus CF wifi 128MB card that doesn't work. I tried installing sandisk-plus_arm.ipk and it still wouldn't work. So I bought a Socket wifi card from eBay. If I can get that one to work, then I won't care that the sandisk one does not.

Joypad I also have a nice cheap retractable USB joypad which is a very nice small size. The Zaurus recognizes it and all of its buttons except turbo and clear (I don't care). I have verified this with jstest.

snes9x-sdljoy works nicely except for the directional controls. I can pause, unpause, open the menu, cancel, and okay just fine (all 6 snes controller buttons work), but cannot move at all.

I tried to use joy2key-z -config kbd1 and joy2key-z -config snes9x, and even tried to figure out how to use joy2key-z without arguments to configure itself to my joypad. When I did that, axis 0, 1, 2, 5, and 6 all did not respond, but axis 3 (up/down) and axis 4 (left/right) did respond. But even so, the buttons should have worked and I can't get any other apps to respond to any button pressing while joy2key is active. There's not a lot of documentation available, but I found one site in Japanese that seems to suggest that I need to install tetsu's special kernel.

Tetsu's kernel So on that note, I searched for tetsu's special kernel. I found the page at http://tetsu.homelinux.org/zaurus/kernel and downloaded zImage-v18h-3200.bin then followed a link above it to get updater.sh.3200. Because these pages are in translated Japanese ... I just want to make sure that these are the files I need before I do this. Meanie's page gives instructions, but he mentions an ipk to install after the kernel update. I can't find an ipk, so I'm assuming updater.sh needs to be run after the zImage is installed?

X/QT and Java The next step is getting X/QT and Blackdown Java 1.3 working. I did install Jeode and it works, except the text editor I wrote for my SL-5500 appears to need to be run in magnified mode. I haven't played around with Jeode's AWT on the C3200 yet, but I suspect it's going to be difficult to get the toolkit windows working correctly in landscape mode. I tried to install Blackdown, but got a lot of errors, ending up with one saying the device is full. I have 30MB left in the program area, so I was a bit surprised. Maybe I need to install it to the HDD instead? But non-GUI Java doesn't interest me much (Jeode would be just fine in that case), so I am going to try X/QT before I try Blackdown again. Any advice about which one? It seems like I should install X/QT Jumbo, but I wasn't sure.
Go to the top of the page
+Quote Post

Posts in this topic
Heather   Some Questions About The C3200   Aug 1 2007, 06:28 AM
Heather   Update on usb hdd: I used fdisk to change it to fa...   Aug 1 2007, 11:34 AM
Drake01   QUOTE(Heather @ Aug 1 2007, 02:34 PM)mount /d...   Aug 1 2007, 03:45 PM
Meanie   QUOTE(Drake01 @ Aug 2 2007, 09:45 AM)QUOTE(He...   Aug 2 2007, 12:57 AM
Heather   The directory usbstorage exists, and /dev/sda1 exi...   Aug 2 2007, 05:21 AM
speculatrix   QUOTE(Heather @ Aug 2 2007, 02:21 PM)Edit: US...   Aug 2 2007, 12:32 PM
pelrun   QUOTE(Heather @ Aug 2 2007, 01:21 PM)Fdisk di...   Aug 2 2007, 01:52 PM
Heather   Thanks pelrun. Well, formatting on the PC fixed it...   Aug 2 2007, 02:04 PM
Heather   Okay, I tried to update to Tetsu's special ker...   Aug 13 2007, 03:37 AM
adf   I've seen a couple of issues that might be aff...   Aug 13 2007, 01:26 PM
Heather   Should I be able to read the updater.sh as I would...   Aug 13 2007, 02:43 PM
speculatrix   QUOTE(Heather @ Aug 13 2007, 11:43 PM)Should ...   Aug 13 2007, 02:57 PM
Meanie   QUOTE(speculatrix @ Aug 14 2007, 08:57 AM)QUO...   Aug 13 2007, 05:18 PM
adf   QUOTE(Meanie @ Aug 13 2007, 05:18 PM)QUOTE(sp...   Aug 13 2007, 05:25 PM
speculatrix   QUOTE(Meanie @ Aug 14 2007, 02:18 AM)QUOTE(sp...   Aug 14 2007, 01:27 AM
Heather   I'm trying to flash Tetsu's kernel from Te...   Aug 14 2007, 02:28 AM
adf   when you flash to tetsu's kernel, if you ad th...   Aug 14 2007, 11:46 AM
Heather   I definitely prefer that over the blank screen tha...   Aug 14 2007, 03:36 PM
adf   welcome. btw, the X/gtk stuff, like firefox and g...   Aug 14 2007, 04:13 PM
Capn_Fish   Unless I'm mistaken, Cacko comes with Tetsu...   Aug 14 2007, 06:46 PM
adf   QUOTE(Capn_Fish @ Aug 14 2007, 06:46 PM)Unles...   Aug 14 2007, 06:50 PM
matthis   Tetsuu has added the sound patch to his latest ker...   Aug 14 2007, 07:44 PM
Heather   I know it's faster on pdaxii13, but I like my ...   Aug 15 2007, 08:59 AM
adf   pdaX has qt3.5 NOT the same as QTE, though. Nice j...   Aug 15 2007, 05:37 PM
Heather   There are some programs that I have carried over f...   Aug 16 2007, 02:32 AM
adf   I doubt any QTE app from the 5500 will run on pdax...   Aug 16 2007, 03:47 PM
Heather   Whatever benefit can be gained by running pdax isn...   Aug 19 2007, 04:45 PM
Heather   Well, I have gotten myself confused now. I was hop...   Aug 21 2007, 02:47 AM
speculatrix   you can download Cacko from my website - see sig. ...   Aug 21 2007, 04:51 AM
walts   QUOTE(speculatrix @ Aug 21 2007, 12:51 PM)you...   Aug 21 2007, 07:01 AM
Heather   It probably doesn't help that I don't have...   Aug 21 2007, 08:17 AM
speculatrix   QUOTE(Heather @ Aug 21 2007, 05:17 PM)Thanks ...   Aug 21 2007, 12:16 PM

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 21st June 2018 - 04:02 PM