OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Angstrom Hangs With Soft Lockup
Mainframe-junkie
post Mar 9 2008, 12:32 PM
Post #1





Group: Members
Posts: 15
Joined: 9-March 08
From: Ebbelwoi-Town
Member No.: 21,482



Hello friends,

after reading the thread abut the new image with PCMCIA support i decides to flash the image http://www.angstrom-distribution.org/unsta...ad.rootfs.jffs2,
after rebooting Simpad hangs with the following messages :
CODE
.udev/ already exists on the static /dev!                                        
Starting the hotplug events dispatcher udevd                                            
Synthesizing the initial hotplug events                                      
hostap_cs: Registered netdevice wifi0                                    
hostap_hw.c: INTERRUPT BEFORE DEVICE INIT!                                          
hostap_cs: index 0x01: , irq 1, io 0xc4800000-0xc480003f                                                        
wifi0: NIC: id=0x800c v1.0.0                            
wifi0: PRI: id=0x15 v1.1.1                          
wifi0: STA: id=0x1f v1.7.4                          
wifi0: NIC: id=0x800c v1.0.0                          
wifi0: PRI: id=0x15 v1.1.1                          
wifi0: STA: id=0x1f v1.7.4                          
Waiting for /dev to be fully populated                                      
Remounting root file system...                              
root: mount: special device /dev/mtdblock/2 does not exist                                                          
Setting up IP spoofing protection: rp_filter.                                            
Configuring network interfaces... SIOCGIFFLAGS: No such device                                                              
eth0      No such device                        

udhcpc (v1.2.1) started                      
udhcpc[2641]: udhcpc (v1.2.1) started                                    
SIOCGIFINDEX failed!: No such device                                    
udhcpc[2641]: SIOCGIFINDEX failed!: No such device                                                  
done.    
Starting portmap daemon: portmap.                                
BUG: soft lockup - CPU#0 stuck for 11s! [hwclock:2664]                                                      

Pid: 2664, comm:              hwclock                                    
CPU: 0    Not tainted  (2.6.24 #1)                                  
PC is at __do_softirq+0x4c/0xd0                              
LR is at __do_softirq+0x2c/0xd0                              
pc : [<c003d240>]    lr : [<c003d220>]    psr: 60000013                                                      
sp : c2c03d84  ip : c2c03d84  fp : c2c03d9c                                          
r10: c032d424  r9 : c2c02000  r8 : 00000002                                          
r7 : 00000003  r6 : 0000000a  r5 : c0358e5c  r4 : 00000022                                                          
r3 : 20000013  r2 : c0358e20  r1 : 00000104  r0 : 00000000                                                          
Flags: nZCv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment us                                                            
Control: c2c1b17f  Table: c2c1b17f  DAC: 00000015

I attach the logs for further information.Attached File  Simpad_boot.txt ( 22.72K ) Number of downloads: 6


Thanks for any suggestions and help

Oliver
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Mainframe-junkie
post Mar 20 2008, 05:19 AM
Post #2





Group: Members
Posts: 15
Joined: 9-March 08
From: Ebbelwoi-Town
Member No.: 21,482



Hello mr nice,

just flashed the image and tried if simpad will boot without soft lockup, but unfortunally the error is still there .....

CODE

Starting portmap daemon: portmap.  
Machine: Sim            
SA110
BUG: soft lockup - CPU#0 stuck for 11s! [hwclock:2076]iteba                                                

Pid: 2076, comm:              hwclock0]        
jffs2_scan_eraseblock():
CPU: 0    Not tainted  (2.6.24 #1)x01459a04: 0xbee0 inry cache hash
PC is at __do_softirq+0x54/0xcc2768 bytes)                    
LR is at __do_softirq+0x3c/0xcc                              
pc : [<c003e0dc>]    lr : [<c003e0c4>]    psr: 60000013tead    
jffs2_scan_eraseblock(): Magic bitmask 0x1985
sp : c3027d74  ip : c3027d74  fp : c3027d9c                                          
r3 : 20000013  r2 : 00000104  r1 : c3026000  r0 : 00000000            
stead=4, C          
jffs2_scan_eraseblock():
Flags: nZCv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment user                                                                
Control: c3fbb17f  Table: c3fbb17f  DAC: 00000015                                  
stead    
jf
[<c0026fd8>] (show_regs+0x0/0x4c) from [<c006471c>] (softlockup_tick+0xf4/0x13c)                                                                            
TC

r4:00000028 configured
[<c0064628>] (softlockup_tick+0x0/0x13c) from [<c00429cc>] (run_local_timers+0x1              
stead6:000          
jffs2_scan_eraseblock(): Magic bitmask 0x19
8/0x1c)ound at
[<c00429b4>] (run_local_timers+0x0/0x1c) from [<c0042c9                                                      
r5:00000000 r4:c034d79c                
Starti
[<c00649ec>] (handle_IRQ_event+0x0/0x108) from [<c00667e4>] (handle_level_irq+0x
Console: switching to                    
Synthesizing the initial hotplug ev
ac/0x154)ag at    
r8:00000104 r7:00000105 r6:c034d79c r5:0000001a r4:c035r /dev to be                      
                    
[<c0025000>] (__exception_text_start+0x0/0x60) from [<c0025aa0>] (__irq_svc+0x40A1100 flash: CFI device at 0x0                                                  
/0xb0)    

Exception stack(0xc3027d2c to 0xc3027d74)0itebackements = 000000                  
7d20:                            00000000 c3026000 00000104 20000013 c037a71c          
VFS: Can't find a valid FAT filesystem on dev hda.devices at 0x0
7d40: 00000022 0000000a c037a6e0 00000001 c037ba20 00000000 c3027d9c c3027d74                        
FAT: invalid media value (0x00)                    
7d60: c3027d74 c003e0c4 c003e0dc 60000013 ffffffff    
VFS: Can't find a valid FAT filesystem o    
r6:00000011 r5:fa050000 r4:ffffffff
eth0      No such device          
[<c0025000>] (__exception_text_start+0x0/0x60) from [<c0025aa0>] (__irq_svc+0x40    

Pid: 2077, comm:              hwclock found on MTD devic                
[<c0064f68>] (setup_irq+0x0/0x264) from [<c006529c>] (request_irq+0xd0/0xf8)
r7:c01e7f80 r6:0000001e r5:c3e5fee0 r4:00000000
[<c00651cc>] (request_irq+0x0/0xf8) from [<c01e7b9c>] (sa1100_rtc_open+0x2c/0x10
8)
[<c01e7b70>] (sa1100_rtc_open+0x0/0x108) from [<c01e6b64>] (rtc_dev_open+0x64/0x
d8)
r5:c3dd6800 r4:c3dd6938
[<c01e6b00>] (rtc_dev_open+0x0/0xd8) from [<c009119c>] (chrdev_open+0x1dc/0x1fc)

r6:c31f805c r5:c3dd6938 r4:00000000
[<c0090fc0>] (chrdev_open+0x0/0x1fc) from [<c008bfa4>] (__dentry_open+0x140/0x22
8)
r8:c3e81980 r7:c0090fc0 r6:c31f805c r5:c30e0680 r4:00000000
[<c008be64>] (__dentry_open+0x0/0x228) from [<c008c12c>] (nameidata_to_filp+0x38
/0x4c)
[<c008c0f4>] (nameidata_to_filp+0x0/0x4c) from [<c008c17c>] (do_filp_open+0x3c/0
x44)
r4:00020000
[<c008c140>] (do_filp_open+0x0/0x44) from [<c008c1dc>] (do_sys_open+0x58/0xe4)
r5:00000000 r4:00020000
[<c008c184>] (do_sys_open+0x0/0xe4) from [<c008c2a0>] (sys_open+0x24/0x28)
r8:c00260e4 r7:00000005 r6:0007804c r5:00000000 r4:00000000
[<c008c27c>] (sys_open+0x0/0x28) from [<c0025f40>] (ret_fast_syscall+0x0/0x2c)


Attached is the boot-log of the image.

Anything i can do to help you (and mrdata) with the bug ??

Best regards

Oliver

Attached File  boot.txt ( 18.94K ) Number of downloads: 1
Go to the top of the page
 
+Quote Post

Posts in this topic
Mainframe-junkie   Angstrom Hangs With Soft Lockup   Mar 9 2008, 12:32 PM
koen   Did you try reading the angstrom frontpage? http:/...   Mar 9 2008, 11:59 PM
mister_data   QUOTE(Mainframe-junkie @ Mar 9 2008, 09...   Mar 10 2008, 08:11 AM
koen   QUOTE(mister_data @ Mar 10 2008, 05:11 PM...   Mar 10 2008, 08:36 AM
fredyd   Well, I vote for the inclusion of your quick'n...   Mar 10 2008, 09:38 AM
fredyd   same thing happens with r9, but I also noticed som...   Mar 11 2008, 01:26 AM
mr_nice   hi, thanks a lot for testing. On my device I am no...   Mar 12 2008, 02:32 PM
fredyd   mr_nice, If you can't reproduce the bug, is th...   Mar 16 2008, 06:26 AM
mr_nice   Hello all, once again mrdata helped us and gave me...   Mar 18 2008, 07:50 AM
Mainframe-junkie   The same happened with 2007-12 R10. Filed Bug 4084...   Mar 16 2008, 05:57 AM
Mainframe-junkie   Hello mr nice, just flashed the image and tried i...   Mar 20 2008, 05:19 AM
mr_nice   QUOTE(Mainframe-junkie)Anything i can do to h...   Mar 20 2008, 08:15 AM
Mainframe-junkie   Hello mr_nice, thanks for this image is flashed i...   Mar 20 2008, 12:56 PM
mr_nice   Hi, here [1] is another image build with a new pat...   Mar 23 2008, 09:25 AM
Mainframe-junkie   Happy easter mr nice, just flashed and booted ......   Mar 23 2008, 11:40 AM
mr_nice   QUOTEWe need to hunt on ... well ok, a new day ne...   Mar 24 2008, 12:46 AM
Mainframe-junkie   Hello mr nice, i think you pinned the bug : CODE...   Mar 24 2008, 01:59 AM
mr_nice   Fine . The bug fix is not only my work, most of it...   Mar 24 2008, 03:14 AM
Mainframe-junkie   Hello mr nice, first of all thanks to all contrib...   Mar 24 2008, 04:04 AM
mr_nice   Ok, with this image [1] suspend/resume should work...   Mar 24 2008, 06:46 AM
Mainframe-junkie   Hello mr nice, just tried the image and suspend/r...   Mar 24 2008, 08:15 AM
mr_nice   Fine, so we can hand in the patches :). I have to...   Mar 24 2008, 08:57 AM
Mainframe-junkie   Hello mr nice, so the next autoimage will be ok ....   Mar 24 2008, 09:56 AM
fredyd   Simply amazing, it boots like a charm! Thanks ...   Mar 26 2008, 12:59 AM
mr_nice   Nice to hear that you like it . QUOTE(fredyd ...   Mar 26 2008, 06:06 AM
Master One   Well done, the latest test-image (Simpad-2.6.24.rt...   Mar 26 2008, 04:27 PM
mr_nice   You have at least these options: -use gpe-mini-bro...   Mar 26 2008, 04:52 PM
Master One   Thanks, mr_nice, that did the job.   Mar 27 2008, 09:04 AM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 14th September 2014 - 06:01 PM