OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Angstrom Hangs With Soft Lockup
Mainframe-junkie
post Mar 9 2008, 12:32 PM
Post #1





Group: Members
Posts: 15
Joined: 9-March 08
From: Ebbelwoi-Town
Member No.: 21,482



Hello friends,

after reading the thread abut the new image with PCMCIA support i decides to flash the image http://www.angstrom-distribution.org/unsta...ad.rootfs.jffs2,
after rebooting Simpad hangs with the following messages :
CODE
.udev/ already exists on the static /dev!                                        
Starting the hotplug events dispatcher udevd                                            
Synthesizing the initial hotplug events                                      
hostap_cs: Registered netdevice wifi0                                    
hostap_hw.c: INTERRUPT BEFORE DEVICE INIT!                                          
hostap_cs: index 0x01: , irq 1, io 0xc4800000-0xc480003f                                                        
wifi0: NIC: id=0x800c v1.0.0                            
wifi0: PRI: id=0x15 v1.1.1                          
wifi0: STA: id=0x1f v1.7.4                          
wifi0: NIC: id=0x800c v1.0.0                          
wifi0: PRI: id=0x15 v1.1.1                          
wifi0: STA: id=0x1f v1.7.4                          
Waiting for /dev to be fully populated                                      
Remounting root file system...                              
root: mount: special device /dev/mtdblock/2 does not exist                                                          
Setting up IP spoofing protection: rp_filter.                                            
Configuring network interfaces... SIOCGIFFLAGS: No such device                                                              
eth0      No such device                        

udhcpc (v1.2.1) started                      
udhcpc[2641]: udhcpc (v1.2.1) started                                    
SIOCGIFINDEX failed!: No such device                                    
udhcpc[2641]: SIOCGIFINDEX failed!: No such device                                                  
done.    
Starting portmap daemon: portmap.                                
BUG: soft lockup - CPU#0 stuck for 11s! [hwclock:2664]                                                      

Pid: 2664, comm:              hwclock                                    
CPU: 0    Not tainted  (2.6.24 #1)                                  
PC is at __do_softirq+0x4c/0xd0                              
LR is at __do_softirq+0x2c/0xd0                              
pc : [<c003d240>]    lr : [<c003d220>]    psr: 60000013                                                      
sp : c2c03d84  ip : c2c03d84  fp : c2c03d9c                                          
r10: c032d424  r9 : c2c02000  r8 : 00000002                                          
r7 : 00000003  r6 : 0000000a  r5 : c0358e5c  r4 : 00000022                                                          
r3 : 20000013  r2 : c0358e20  r1 : 00000104  r0 : 00000000                                                          
Flags: nZCv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment us                                                            
Control: c2c1b17f  Table: c2c1b17f  DAC: 00000015

I attach the logs for further information.Attached File  Simpad_boot.txt ( 22.72K ) Number of downloads: 6


Thanks for any suggestions and help

Oliver
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Master One
post Mar 26 2008, 04:27 PM
Post #2





Group: Members
Posts: 28
Joined: 13-January 07
Member No.: 13,912



Well done, the latest test-image (Simpad-2.6.24.rtc-debug-4-image-r12) seems to be working so far, but there is not enough space left on the root partition to install minimo, and without it, it all makes no sense to me, because all I want to do with it, is surf the web.

I tried deleting as many packages, as I thought are not needed for my purpose (like all the bluetooth and irda stuff, GPE package manager, firmware-stuff, kernel-modules for cards not used), but still not enough space left:
CODE
$ df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/mtdblock1           23.8M     23.5M    304.0k  99% /
tmpfs                    40.0k         0     40.0k   0% /mnt/.psplash
/dev/mtdblock1           23.8M     23.5M    304.0k  99% /dev/.static/dev
tmpfs                     2.0M     32.0k      2.0M   2% /dev
tmpfs                    30.1M         0     30.1M   0% /dev/shm
tmpfs                    30.1M    120.0k     29.9M   0% /var/volatile
tmpfs                    30.1M      4.0k     30.1M   0% /media/ram
/dev/mtdblock2            8.0M      5.8M      2.3M  72% /home

The minimo package itself has 4.7 MB (but it has two dependencies as well), the old familiar image (which allowed me to install minimo without problem) was 14.027 KB, this Angstrom image has 17.984 KB.

What can be done to make minimo fit in?
What else could I delete / remove?
Go to the top of the page
 
+Quote Post

Posts in this topic
Mainframe-junkie   Angstrom Hangs With Soft Lockup   Mar 9 2008, 12:32 PM
koen   Did you try reading the angstrom frontpage? http:/...   Mar 9 2008, 11:59 PM
mister_data   QUOTE(Mainframe-junkie @ Mar 9 2008, 09...   Mar 10 2008, 08:11 AM
koen   QUOTE(mister_data @ Mar 10 2008, 05:11 PM...   Mar 10 2008, 08:36 AM
fredyd   Well, I vote for the inclusion of your quick'n...   Mar 10 2008, 09:38 AM
fredyd   same thing happens with r9, but I also noticed som...   Mar 11 2008, 01:26 AM
mr_nice   hi, thanks a lot for testing. On my device I am no...   Mar 12 2008, 02:32 PM
fredyd   mr_nice, If you can't reproduce the bug, is th...   Mar 16 2008, 06:26 AM
mr_nice   Hello all, once again mrdata helped us and gave me...   Mar 18 2008, 07:50 AM
Mainframe-junkie   The same happened with 2007-12 R10. Filed Bug 4084...   Mar 16 2008, 05:57 AM
Mainframe-junkie   Hello mr nice, just flashed the image and tried i...   Mar 20 2008, 05:19 AM
mr_nice   QUOTE(Mainframe-junkie)Anything i can do to h...   Mar 20 2008, 08:15 AM
Mainframe-junkie   Hello mr_nice, thanks for this image is flashed i...   Mar 20 2008, 12:56 PM
mr_nice   Hi, here [1] is another image build with a new pat...   Mar 23 2008, 09:25 AM
Mainframe-junkie   Happy easter mr nice, just flashed and booted ......   Mar 23 2008, 11:40 AM
mr_nice   QUOTEWe need to hunt on ... well ok, a new day ne...   Mar 24 2008, 12:46 AM
Mainframe-junkie   Hello mr nice, i think you pinned the bug : CODE...   Mar 24 2008, 01:59 AM
mr_nice   Fine . The bug fix is not only my work, most of it...   Mar 24 2008, 03:14 AM
Mainframe-junkie   Hello mr nice, first of all thanks to all contrib...   Mar 24 2008, 04:04 AM
mr_nice   Ok, with this image [1] suspend/resume should work...   Mar 24 2008, 06:46 AM
Mainframe-junkie   Hello mr nice, just tried the image and suspend/r...   Mar 24 2008, 08:15 AM
mr_nice   Fine, so we can hand in the patches :). I have to...   Mar 24 2008, 08:57 AM
Mainframe-junkie   Hello mr nice, so the next autoimage will be ok ....   Mar 24 2008, 09:56 AM
fredyd   Simply amazing, it boots like a charm! Thanks ...   Mar 26 2008, 12:59 AM
mr_nice   Nice to hear that you like it . QUOTE(fredyd ...   Mar 26 2008, 06:06 AM
Master One   Well done, the latest test-image (Simpad-2.6.24.rt...   Mar 26 2008, 04:27 PM
mr_nice   You have at least these options: -use gpe-mini-bro...   Mar 26 2008, 04:52 PM
Master One   Thanks, mr_nice, that did the job.   Mar 27 2008, 09:04 AM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th December 2014 - 03:31 AM