OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

> Get Online Only Using Bash And A Usb Card
Allelectrix
post Oct 24 2008, 01:21 PM
Post #1





Group: Members
Posts: 85
Joined: 7-April 08
Member No.: 21,602



Hi all,

Heres how to get online with BT3:

insert the USB Card into the Hub. we are dealing here with the rt73 Card Edimax EW-7318USg Card but any RT73 card should do it.

open a BASH Shell and issue:

ifconfig rausb0 up
iwconfig rausb0 essid "essid_of_AP" channel X mode managed enc ABCDEF0123456789 ap 00:11:22:33:44:55


where:

1. essid_of_AP = the essid of the AP in quotes
2. X = channel AP is on. enter 2 for channel 2 or 11 for channel 11 etc,etc...
3. ABCDEF0123456789 = the HEX encryption key if the Network is using WEP. this will be either 6 or 13 bytes long.
4. ap = 00:11:22:33:44:55 replace this with the AP's MAC addresss

Now, if the HTTP control page is at 192.168.1.254 do next:

hostname

bt

the hostname is bt

finally, to get online using DHCP do:

dhcpcd -h bt -G 192.168.1.254 rausb0


if this command don't complete almost immediately, it will fail to connect. then check:

Is USB Card connected to a powered hub ?
Is the card on the same channel as the AP ?
Is the AP's MAC displayed after you issue iwconfig ?

QUESTIONS


Can someone please answer these for me:

1. How do we get the AP's MAC address listed with iwconfig in pdaXii13 using a USB Card ?
2. I have tried this method with pdaXii13 on a Zaurus SL-C1000. All commands load except:

iwconfig rausb0 ap 00:11:22:33:44:55

even though this command completes correctly, the AP's MAC is still not listed when afterwards we issue iwconfig .
therefore, does anyone know the solution to this ? because if we then try the dhcpcd command above, it fails,
as I said, all other parameters get loaded except AP, a rather annoying little problem.

Hope someone can help.

Thanks all, Allelectrix

Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
sdjf
post Nov 1 2008, 06:58 PM
Post #2





Group: Members
Posts: 454
Joined: 17-November 05
Member No.: 8,551



I do not know pdaX roms. All I know is that if a command or file can only be accessed or performed by root and you are not root, you will fail. It is a kernel thing.

Run the following: echo $USER

That should tell you who you are running as.

Are you typing all this every time or working with a script to automate the parts you are sure of?

sdjf
Go to the top of the page
 
+Quote Post
Allelectrix
post Nov 10 2008, 05:00 PM
Post #3





Group: Members
Posts: 85
Joined: 7-April 08
Member No.: 21,602



QUOTE(sdjf @ Nov 2 2008, 02:58 AM) *
Run the following: echo $USER

sdjf


Hi everyone, I'll try to answer everyones thoughts here, first sdjf:

the C1000 did nothing to this command.:

echo $USER

root )

QUOTE
Are you typing all this every time or working with a script to automate the parts you are sure of?


yes, typing each command.

Speculatrix, you mention the command :

id -a

this just gives an error in PdaXii13 with no output.

sdjf, you write again:

QUOTE
Please show the results. If it is a kernel thing, it should be fixable somehow.


right, here is all the results from the new kernel config:

first of all several screenshots from running;

make menuconfig

Attached File  kernel_conf.tar ( 950K ) Number of downloads: 2


and the resulting .config file:

Attached File  config.tar ( 33.5K ) Number of downloads: 2


replace .tar with .txt this is a text file not a tar file.

here is my extended, compiled 2.4.20 1.3Mb kernel for you all to try:

Attached File  zImage.tar ( 1.23MB ) Number of downloads: 1


remove the .tar from the end, this is a zImage file. install it with the following file:

Attached File  updater.tar ( 2.03K ) Number of downloads: 1


rename to updater.sh

put this updater.sh file and the above zImage file into the root of a CF or an SD card and do a full reset, then
flash the kernel, once the kernel is flashed, the computer will ask you to reboot.

the Computer will now boot with the new kernel.

with this Kernel configuration, dhclient runs, but it does not aquire an DHCP assigned IP address still. also:

iwconfig rausb0 ap 00:45:AC:4C:BB:89

still does not list the AP's MAC address when afterwards we do:

iwconfig

neither does rausb0 fetch the MAC address of the AP off the air, and even though the kernel image is now 1.3Mb in size,
thats 100,000 bytes more than usual, we still are hitting a brick wall.

dhcpcd rausb0

also yields no results, but only brings the Wifi interface down.

Ah! Pelrun, typing:

whoami

the C1000 outputs:

root

root )

so, does this mean that we no longer need to type :

sudo X whatevercommand ?

speculatrix, you wrote:

QUOTE
ping the gateway and look at the arp table ("arp -an") or find the arp file in /proc/sys/net (something like that ) which gets populated when you ping the gateway.


alas a good idea mate, but, pinging is useless if you have not got an IP address of your own to start with, therefore:

arp -an

returns nothing.

OK, the C1000 is still sorely lacking USB Wifi connectivity, so, please, please , please keep those thoughts rolling in here, I want to
see if we can make this OS the best EVER for the C1000.

thanks to everyone who has contributed so far, do you have any more ideas ?


Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st September 2014 - 04:10 PM