OESF | ELSI (coming soon) | Community Links (coming soon) | LinuxPDA | Ibiblio


Welcome Guest ( Log In | Register )

> Akita Multiboot "how To" Help
post Apr 17 2010, 03:21 AM
Post #1

Group: Members
Posts: 19
Joined: 29-January 06
From: Wellington, New Zealand
Member No.: 9,018

I have tried most "how to" in this forum and elsewhere and none have worked for me. I am not a developer but a user of the Zaurus. So when an "how to" assumes it is clear to everybody without actually including all the detailed steps, it does not always work for everybody, as shown in many of the posts in this forum. I have tried almost all distros by flashing them on my Akita and they all worked fine. But now the emphasis is more and more on kexecboot or multiboot methods. So I would like to write a complete multiboot "how to" for users (not developers) for the Akita hopefully with all your help.

Here is what I want to do:

1- Have multiple OS for my SL-C1000 on a SD card
- Zubuntu 2.0
- Cacko 1.23
- Angstrom
- Poky
- Igelle (http://www.igelle.com/)
2- Use the kexecboot or Omegamoon version

I have been using mainly Cacko but I now need to have a more mini computer (with Perl, Pyton, PHP and Apache) for when I am on a train or plane. I also mainly travel by bike and carrying a laptop is not an option for me, I need to travel as light as possible hence the Zaurus is perfect for that.

Here is what I tried so far:

1- I have configured a 2GB SD card with ext3 using fdisk and mkfs the same way as on Omegamoon:
2- I already had Cacko running on my Akita (capable of reading SD cards higher than 1GB)
3- I obtain the Katastrophos rootfs files and modules from this post:
4- Put the them on one of the partition of the SD card
5- Obtain the Sptiz Zubuntu 2.0 rootfs and addition files from this page:
(That actually did not work, when I tried to gunzip and tar -xvf the content on my Linux box, I got a few mknode permission denied).
6- Put them on a 1GB partition on the SD card
7- Obtain the kexecboot kernel and update file from Omegamoon:
8- Put them on a CF VFAT card (my SD card formatted as VFAT did not get recognized by my Akita)
9- Flashed update them on the Zaurus and rebooted as per the instruction on Omagamoon:
10- After rebooting my Akita, I obtain the Omagemoon kexecboot menu with 2 items in the list, one for Cacko and one for Zubuntu.
11- Selecting the Cacko did not work, got a kernel panic (init not found)
12- Selecting the Zubuntu did not work just stopped in the console and never booted the actual desktop.

I read all the posts in this forum related to this topic and there are many incomplete solutions but none of them seem to work for me.

So I want to start from the absolute beginning and want to write down every single steps that need to be taken for using kexecboot on Akita. Remember this is for the users not the developers.

Step 1: Format a SD card

- Partition and make an ext3 filesystem on a 2GB SD card with some swap space
(enter the exact and complete steps here)

Step 2: Prepare your Zaurus

- ...

Step 3: Obtain rootfs files, kernel-cmdline, kernel images for each OS

etc. ...

Shall we start?

Thank you for your help.
Go to the top of the page
+Quote Post
Start new topic
post Apr 17 2010, 08:12 PM
Post #2

Group: Members
Posts: 39
Joined: 20-August 08
Member No.: 22,227

For Prepping your Akita, do a trisoft nand restore. this will get your partition tables correct and proper.

flash cacko per the cacko instructions, BUT make sure that the root partition is 53MB no more, no less.

once this is done, boot into cacko to verify that it flashed correctly.

on your sd card, for the cacko that is now in nand, you only need the /boot folder.
sd /boot should have 3 files in it:
the cacko kernel that you want to use.
Kernel command line: console=ttyS0 root=/dev/mtdblock2 mtdparts=sharpsl-nand:7168k@0k(smf),59392k@7168k(root),-(home) jffs2_orphaned_inodes=delete EQUIPMENT=0 LOGOLANG=1 DEFYEAR=2006 LOGO=1 LAUNCH=q

Image.nfo file that is plain text that identifies this kernel/ distro


flash the multiboot kernel from omegamoon (it is modified to read the .nfo otherwise it is the same as angstrom)

reboot and insert your special sd card.

you should see cacko with a sd icon, select it and cacko should load now.

I have not gotten the extracted rootfs from cacko to work when it is on a sd card. I think that there are too many pointers to the nand and there is some weird jffs2 linking to cramfs, for me to untangle it. flash cacko to nand and be happy.

multibooting does weird things to cacko, you can't dl too many packages at once, cacko gets confused and becomes unstable. Install a couple of packages at a time, then reboot. this is stupid, but it works and i think it has something to do with the fs switching compression algorithms or something.

if cacko is working for you with the multiboot kernel on nand, then in your zubuntu sd partition, extract the rootfs of your choice from omegamoon, and try booting from it. personally i prefer the hardy/8.04 version zubuntu rootfs. (quick and lightweight)

more to follow....need sleep.
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 29th April 2017 - 05:34 PM