OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
jeevandras doesn't have a personal statement currently.
Personal Info
jeevandras
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 15-July 06
Profile Views: 690*
Last Seen: 17th September 2007 - 10:27 AM
Local Time: Oct 31 2014, 04:54 PM
21 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

jeevandras

Members


Topics
Posts
Comments
Friends
My Content
10 Oct 2006
Has anybody been able to play .3gp files on Z? I have tried 3GP files coded using the Nokia suite but I get video but no audio. It outputs "Cannot find codec for audio 0x726D6173". I believe I have used AMR codec for sound. Any idea what am I missing? I've tried -ac ffamrnb but get message cannot find codec "amr_nb" in libavcodec.

Thanks for your help!

Jeev
29 Sep 2006
Hi,
I am always hitting a brickwall with installing vlc for my Z. I have got OZ and Opie 1.2.
I downloaded an Opie friendly VLC from
http://www.videolan.org/vlc/download-familiar.html

Tried installing the file opie-vlc_0.6.0_arm.ipk through the package manager and I get the error

Error: Cannot satisfy the following dependencies for opie-vlc:

opie-base
opie-libsdl

Also tried installing the file opie-libsdl from the same site and I get the error
Error: Cannot satisfy the following dependencies for opie-libsdl

task-opie

I see that task-opie and opie-base are the culprits here

I looked at the Packages installed using Package Manager on Opie and I find that a myriad of task-opie-something packages installed including task-opie-base installed. Is this what its looking for and don't see?

I assume that the packages i have could be older version and need to be updated?

How do I get them?

I know ipkg update should help with updating the ipks, no? Is that one of its uses? However, I have still not able to get my Z connected to my laptop to get it on the Internet. My more optimistic option would be to put them onto my CF or SD cards. Can anyone advise on if this is the way of doing it and how should I go about this, properly?

Also, I see that in the Package Manager configurator there is a means to specify the src of my feed. My Z's previous owner has left some ipks on the SD card he has given to me. However, when I do and ipkg update I get the error

"wget: not an http pr ftp url: /media/card/progs/Packages"

the folder /media/card is where my sd card is mounted on and just to state the obvious /progs is a folder on my sd card containing various ipks.

I can see that its obvious that why wget would fail if its looking at /media/card/progs/ because its no path on an HTTP server or FTP server but merely the path on my sd card.

So I assume thats not a good src for ipkg update. How else can I do an ipkg update if I don't have network connection to my Z.

I must say that some of the things I assume above could be rubbish coz I am a newbie to Z and linux. I appreciate any advice you can give. I am slowly but persevering at learning to figure out my Z and really appreciate your help. Many thanks!

Jeev
28 Sep 2006
Hi,
Still trying to figure out this Zaurus of mine.
I was hoping to get a suitable media player running on my Z.
I have Opie and it comes with opiemediaplayer2. It works fine with mp3 files but just crashes with .avi files running divx. I have tried reducing the resolution of my .avi file and yet still crashes.

When i run the opiemediaplayer2 on the terminal, the output i get last is

All resize done
Hoehm: 160925 <-> 30
Killed.

Don't seem to be able to find a dump file anywhere.
I checked the source code for the player, it seems to happen at

void XineVideoWidget::paintEvent2 ( QPaintEvent * )
{
if ( m_buff == 0 ) {
return;
} else if (m_lastsize){
{
QDirectPainter dp ( this );
int rot = dp. transformOrientation ( ) + m_rotation; // device rotation + custom rotation
bool rot90 = (( -m_rotation ) & 1 );
int _vw,_vh;
switch (rot90) {
case true:
_vh = m_framesize.width();
_vw = m_framesize.height();
break;
default:
_vw = m_framesize.width();
_vh = m_framesize.height();
break;
break;
}
int middle_w = _vw/2;
int middle_h = _vh/2;
m_thisframe.setRect(width()/2-middle_w,height()/2-middle_h,_vw,_vh);
uchar *fb = dp. frameBuffer ( );
uchar *frame = m_buff;

// where is the video frame in fb coordinates
QRect framerect = qt_screen-> mapToDevice ( QRect ( mapToGlobal ( m_thisframe. topLeft ( )), m_thisframe. size ( )), QSize ( qt_screen-> width ( ),
qt_screen-> height ( )));

uchar * src = frame;
uchar * dst = fb+framerect.y()*m_bytes_per_line_fb+framerect.x()*m_bytes_per_pixel;

/* clean up the fb screen when shrinking the image only! */
if (old_framerect.isValid() && old_size.width()==width()&&old_size.height()==height() &&
(old_framerect.width()>framerect.width() || old_framerect.height()>framerect.height())) {
uchar*_dst = fb+old_framerect.y()*m_bytes_per_line_fb+old_framerect.x()*m_bytes_per_pixel;
for (int z=0;z<old_framerect.height();++z) {
memset(_dst,0,m_bytes_per_line_fb);
_dst+=m_bytes_per_line_fb;
}
}
old_framerect=framerect;
old_size = size();

if (framerect.height()!=m_framesize.height()) {
odebug << "Hoehm: " << framerect.height() << " <-> " << m_framesize.height() << oendl;
}
for (int y = 0;y<framerect.height();++y) {
switch (rot) {
case 0:
memcpy(dst,src,m_bytes_per_line_frame);
src+=m_bytes_per_line_frame;
break;
case 1:
memcpy_step ( dst, src, m_thisframe.size().width(), m_bytes_per_line_frame );
src -= m_bytes_per_pixel;
break;
case 2:
memcpy_rev ( dst, src, m_thisframe.size().width());
src-=m_bytes_per_line_frame;
break;
case 3:
memcpy_step_rev ( dst, src, m_thisframe.size().width(), m_bytes_per_line_frame );
src += m_bytes_per_pixel;
break;
default:
break;
}
dst += m_bytes_per_line_fb;
}
}
}
}

Though I can't tell exactly whats happening.

After reading a few posting on the forum i decided to give up on OpieMediaPlayer2 and try Xmms-MPlayer.

Does anyone know where and how can install these two packages?

I managed to get hold of the package mplayer-xmms-embedded-qtopia_0.00005pre1_arm.ipk and installed it but it complains of cannot satisfy dependency

libSDL

I assume there are something else missing. Can somebody advise on an easy way for me to get divx .avi files playing on my Zaurus. Appreciate any advice u can give. Thanks!

Jeev
ps. Does anybody have a sample .avi file i can use to test on my player? Thanks again!
28 Sep 2006
Hi,
I am still pretty new with my zaurus and linux trying to figure a lot out.

I m running OZ 3.5.4.1 Kernel 2.6.16 and Opie 1.2.1 on a C860.

I find that when I transfer a file from my XP through a card reader to my CF or SD card and then plug the card onto my Z, I don't see these files.

However, when I reboot Z, the files finally appear and whatever changes i have made on my cards are shown on my File Manager.

Does anybody know why this is happening? Do I need to reboot everytime I copy files over. I assume this has something to do with mounting the device. Is there someting I should do 1st before i plug and unplug my card.

I appreciate any advice you can give. Thanks!

Jeev
15 Jul 2006
Hi,
Just bought a 2nd hand C860 today. My very first task was trying to get it to sync with my laptop running XP. I have managed to install QTopia Desktop 1.7 on my laptop. And then I hooked up my pda onto my usb port and XP did not detect the device therefore unable to complete install drivers. I assume one of the problem could be due to a bad cable. However, I am not entirely sure about that coz the pda is still able to be charged by the suspicious cable. Is there anyway to ascertain that my IO-USB port on my pda is running ok with some sort of a loopback test? Should there be certain configuration I should look out for? Btw... I m running Opie 1.2 but not sure what release of OZ I am using. Also, how can I find out what version of OZ I am using? I really hope somebody could advise me on how to solve this problem. I have to say that its been a while since I had been on the linux environment and USB hardware details and workings are quite foreign to me. Though i have a fairly good grasp on networking. So any advice would really be appreciated. I thank you in advance for the help you can give me.

Regards,
Jeev
Last Visitors


7 Aug 2010 - 4:23

Comments
Other users have left no comments for jeevandras.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 31st October 2014 - 03:54 PM