OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
scrapheap doesn't have a personal statement currently.
Personal Info
scrapheap
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 8-August 06
Profile Views: 405*
Last Seen: 30th July 2009 - 12:49 AM
Local Time: Oct 26 2014, 05:28 AM
42 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

scrapheap

Members


Topics
Posts
Comments
Friends
My Content
6 Nov 2007
Well, the other day I deletes the symbolic link to grep, egrep and fgrep. This wasn't a problem at the time as I have compiled the full version of grep and it was in /usr/local/bin. The problem was that I have /usr/local/ symlinked to a directory on my SD card and when I rebooted I discovered that the zaurushw startup script needed grep and it couldn't find it as it hadn't mounted the SD card yet.

"Not a problem" I thought, "just log in an move grep and it's libs into /bin/ and /lib/", but then I discovered that without the zaurushw script having run correctly or because grep was missing I couldn't log in.

"Great" I thought, "now I can try out the UBoot emergency console"

So I booted into it (holding down OK when restarting the Zaurus) and up popped the emergence console. The SD card was auto mounted but the NAND partition wasn't, but a little experimentation later and I had mounted the NAND partition (/dev/mtdblock2 with a filetype of jffs2). I copied the grep commands across to /bin/ on the NAND partition and then copied the relevant libraries for them to the /lib/ (I figured out the libraries required by simply running the command and when it complained about not being able to find a library I moved it)

After all that I rebooted, logged in and everything is back running fine again.
30 Oct 2007
Hi,
Does anyone have the kernel headers available as a tar so that I can quickly add them to my Zaurus for compiling modules. I have tried making them on the zaurus but I have no idea what the configuration used for pdaxrom's 2.6.16 kernel is.

Thanks
29 Oct 2007
Hi,
I just recently picked up a USB LAN NIC which according to blurb on the site I brought it from was a rtl8150 what do I find when I get it. It is a ST268 instead. Has anyone managed to compile the drivers for this with for use with the R198?

From what I have read it should also work with the dm9601 drivers but of course those aren't in R198 either.
21 Aug 2007
When booting up I get the error

/usr/bin/alsactl: load_state:1236: no soundcards found...

I then don't have any sound devices available

Has anyone encountered this and if so how did you fix it? (I can't remember if it has always done this on R198 as I haven't tried using the sound till now).
17 Jul 2007
I have got blackbox running on my C1000 fine and I have even manged to compile bbkeys for it (And after mapping the Calendar, Address, Mail, Home and Menu buttons to F1-F5 it has made things a lot nicer)

The problem I am having is that after suspending when I resume I have to restart the Zaurus as it seems to hang. I don't know if this is caused by blackbox not knowing it has been suspended and resumed or some other reason.

Does anyone have and Ideas or suggestions as to what could be causing this?
Last Visitors


13 Dec 2008 - 17:26

Comments
Other users have left no comments for scrapheap.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 25th October 2014 - 08:28 PM