OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
fump doesn't have a personal statement currently.
Personal Info
fump
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 7-December 06
Profile Views: 243*
Last Seen: 15th January 2007 - 03:22 PM
Local Time: Dec 19 2014, 02:38 PM
2 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

fump

Members


Topics
Posts
Comments
Friends
My Content
7 Dec 2006
Hello
some weeks ago i got a SL-5500G from a friend. the device didn't boot anymore. I tried to flash it with the newest Sharp ROM. Flashing worked but after the Sharp image at boot i ended up with the following error:

CODE
INIT: version 2.78 booting
e2fsck 1.19, 13-Jul-2000 for EXT2 FS 0.5b, 95/08/09
Couldn't find ext2 superblock, trying backup blocks...

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with alternate superblock:
  e2fsck -b 8193 <device>

ext2fs_check_if_mount: No such file or directory while determinating whether /dev/mtdblock1 is mounted.
e2fsck Invalid argument while trying to open /dev/mtdblock1

*** An error occured during
*** the file system check.
*** Dropping you to a shell;
*** the system will reboot
*** when you leave the shell.
/etc/passwd: root password garbled
Give root password for maintence (or type Control-D for normal startup):


I tried to recover the filesystem but got an error from fsck all the time
So i decided to flash the newest OpenZaurus release. Again flashing went well but now i couldn't see any boot screen at all. The only thing that happens after reset is the battery led lights up. Later i flashed nearly every distribution i could find and also tried to reflash the sharp rom - result is everytime the same: no boot.
After some investigation i found information about the diag menu. Here is a short summary about what i found out with the help of this menu:

- when flashed OZ and looked in the checksums with pressing "v" the ROM C.S. is red
- when flashed Sharp ROM checksums look all good
- CF card is ok
- battery is ok
- you can get into a extended menu by pressing "Fn"+ ".:"
- here you have some more flash options like full flash erase, parameter erase or erase factory default, but nothing helped
- flashing works because the checksums and the version number of the diag menu is changing

I also found this thread which sounds like the same problem but solution is not working for me.

Could it be a bootloader or a filesystem issue? Is there a possibility to flash a new bootloader or is there a distribution out that writes a whole new filesystem into the ROM?

If you have any clue then please answer an help me getting the Z back to life.
Last Visitors
fump has no visitors to display.

Comments
Other users have left no comments for fump.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 19th December 2014 - 05:38 AM