OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
papercrane doesn't have a personal statement currently.
Personal Info
papercrane
34 years old
Gender Not Set
Santa Rosa
Born July-6-1980
Interests
No Information
Statistics
Joined: 23-February 04
Profile Views: 633*
Last Seen: 8th June 2007 - 01:19 PM
Local Time: Aug 29 2014, 02:27 PM
65 posts (0 per day)
Contact Information
AIM TheAngreal
Yahoo jedi_92
ICQ 19506525
MSN TheAngreal@hotmail.com
Contact Private
* Profile views updated each hour

papercrane

Members


Topics
Posts
Comments
Friends
My Content
25 Apr 2007
I've gotten a kernel module written and working for the CE-RH2 in-line audio remote for the Cxx00 machines for the 2.6 line of kernels. I'd like the same driver to work for the CE-RH1 remote but don't have a Cxx0 or the CE-RH1 to test with. If someone with one of these devices could oblige me I'd like to get the module tested and get and values updated so that the buttons work correctly.

See http://thread.gmane.org/gmane.comp.handhel...1352/focus=2729 for my original announcement and the URL to the patch. This patch is also integrated into OpenEmbedded so you can compile yourself to test as well.

If you're interested in helping me (I can provide images if you do not wish to build them yourself) then please e-mail me at papercrane@reversefold.com.
20 Jul 2005
I've successfully gotten lineakd to compile and work on my C3K and I'd like it to work for the other clamshells as well. lineakd is basically a daemon which runs in X and listens for special keypresses. When a key is pressed it will run any command you want. I've gotten it to work very well on my C3K with my CE-RH2 audio remote controlling mpd via mpc. mpd is the music player daemon and mpc is a controller for it. (I've also added other mpd clients to OE but that's beside the point.)

I'm looking for a C7/8x0 owner with a CE-RH1 audio remote to get me the X keycodes for their remote. To do this easily you need another linux machine with X installed (remember that you can always use Knoppix on, say, a Windows computer to do this). Bring up your Zaurus and get into GPE. Run "xhost" on the command line with the IP of the other Linux computer with X (ex: xhost 192.168.0.45). Go to the other linux computer and open a terminal. Set DISPLAY to go to your zaurus (ex: export DISPLAY=192.168.0.42:0.0). Now start "xev". You should see a window pop up on your zaurus. Now press each of the keys on the remote and look for the "keycode XXX" entry in the output. Note the keycode and which key it is. Post the info back here or PM it to me and I'll add support for the CE-RH1 to lineakd. I'll even help you set it up if you like. smile.gif
24 Jun 2005
I'm attemting to use the serial port (Sharp port with a SerialIO serial cable) as a serial terminal. To test I started up minicom on both my z and PC and set the baud rates and such the same. When I type on the PC nothing happens. When I type on the Z I see what I typed displayed on the PC. I've tried playing with the settings on both ends and I can't get data from the PC to show up on the Z.

I can see three possibilities.
1) The serial port is one way. (I hope this isn't it....)
2) I'm setting something up wrong. (Entirely possible)
3) The serial port is set up as one way by the kernel.

I tend to think it's option 3 as when I rebooted my Z while the serial cable was connected I got kernel/boot output (but only until the sceen came up). One of the lines output is:

CODE
COMMANDLINE= console=ttyS0 root=/dev/mtdblock2 mtdparts=sharpsl-nand:7168k@0k(smf),5120k@7168k(root),-(home) jffs2_orphaned_inodes=delete EQUIPMENT=4 LOGOLANG=1 DEFYEAR=2005 LOGO=1 LAUNCH=q


Anyone have any ideas?
22 Feb 2005
I'm trying to use dev_img to compile parted on my C3000. I had to get and compile e2fsprogs, which worked fine. I also had to play with the ./configure values for parted, but nothing horrible (--without-readline --disable-dynamic-loading). However, it fails to compile, complaining about a missing symbol, stat64.

After looking around on the web, it looks like Sharp hasn't compiled this into glibc on the Zaurus (argh, damn Sharp for their proprietary-esque fiddling). I tried adding the macros from glibc into the header files, but nothing seems to have worked. Does anyone know how I might be able to fix this?
15 Feb 2005
Is there anywhere I can get a definitive list of QCop messages? Is there anyw ay to perhaps query an app to see what it can do? I've found some listings of the system qcop messages, but I'm actually looking for the messages that can be sent to the Music Player on the C series (I have a C3000).
Last Visitors


25 Jan 2008 - 21:43


4 Nov 2007 - 23:46

Comments
Other users have left no comments for papercrane.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 29th August 2014 - 02:27 PM