OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
Zaurus SL-C1000, 2Gb SD Transcend, CF WLAN D-LINK, Altboot and Angstrom 2007.1 on SD.
Personal Info
zensei
37 years old
Male
Germany, Karlsruhe
Born Aug-14-1977
Interests
No Information
Statistics
Joined: 28-January 08
Profile Views: 867*
Last Seen: 15th December 2008 - 02:18 AM
Local Time: Nov 27 2014, 10:56 PM
13 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

zensei

Members


Topics
Posts
Comments
Friends
My Content
15 Feb 2008
Hello,
I have qtopia 4.3 on the zaurus, and I want to recompile/install and try some applications, but I cannot found how-to install they on the qtopia. The package manager can download packages from internet only.
Is it possible to install the homebrew applications?

Thank you.
Alexandr.
8 Feb 2008
laugh.gif
I cross compile qtopia 4.3 for SL-C1000 and it works.
1. It's fast
2. Keyboard and touchscreen work
3. Sample application works

Problems:
1. By default settings the device profile c3200 has wrong screen size (QWS_SIZE="240x320").
2. When I change QWS_SIZE="480x640", when it started, but I have black borders on the screen.
3. When I change it (QWS_SIZE="640x480", when it start, the qtopia desktop screen come with clock for 1 sec, and then it terminated with 3219 Segmentation Fault.
4. When I change "qtopia look", using the "widget manager", to the non-qtopia standard (3/4 option), when It started with QWS_SIZE="640x480" without black border.

Question, is qtopia 4.3 has pda-edition style ? i.e. to start one application you should navigate in many menus.

Thank you.
Alexandr.

P.S: When somebody want to try it, I can post qtopia image (as attachment ~ 14Mb ???)
30 Jan 2008
Hello all,
I will try to compile Qtopia 4.3 for angstrom.
The Qtopia 4.3 has device profile for zaurus models (clamshell and C3200). Which one to use for SL-C1000?

Thank you.

P.S:
The device profile C3200 has special settings for angstrom but the toolchain it used (as I can see) is not the same as on the www.angstrom-distribution.org site.
28 Jan 2008
Hello all,
I am trying to compile qtopia 2.2 with gcc 2.95 (sharp arm). On the internet I can found the same error, but no answer. The same error come, when I try to compile it with gcc 4 (angstrom). Can anyone help? The error for GCC 2.95 (Sharp arm toolchain):

P.S: Qtopia tools compiled, qt - compiled.

***********************************
********* Build Qtopia ************
***********************************
QPE_CFG=" '-edition' 'pda' '-displaysize' '640x480' -no-qtopiadesktop -prefix '$HOME/arm/qtopia' -release -platform 'linux-g++' -xplatform 'linux-sharp-g++'"

The following configuration values have been guessed or autodetected:
-arch sharp
-fontfamilies helvetica fixed micro smallsmooth smoothtimes
-fontsizes all
-fontstyles 50 50i 75 75i
-languages en_US

Symlinking header files to include directory
Creating qmake...make[1]: Entering directory `$HOME/src/qtopia-free-2.2.0/qtopia/qmake'
.make[1]: Leaving directory `$HOME/src/qtopia-free-2.2.0/qtopia/qmake'

Creating pngscale...make[1]: Entering directory `$HOME/src/qtopia-free-2.2.0/qtopia/util/pngscale'
..make[1]: *** [../../bin/pngscale] Error 1
make[1]: Leaving directory `$HOME/src/qtopia-free-2.2.0/qtopia/util/pngscale'
Failed to make pngscale

Thank you.
Last Visitors


26 Nov 2008 - 8:39

Comments
Other users have left no comments for zensei.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 27th November 2014 - 01:56 PM