OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
ajnk doesn't have a personal statement currently.
Personal Info
ajnk
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 9-April 04
Profile Views: 396*
Last Seen: 21st April 2008 - 11:36 PM
Local Time: Dec 27 2014, 09:48 PM
39 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

ajnk

Members


Topics
Posts
Comments
Friends
My Content
9 Apr 2008
Yesterday I managed to bork/recover my Debian install on the internal CF (replaced the microdrive) of my C3100. Once the debian distro was broken the Z was useless until I could get it home/disassemble/restore to CF (I still had the microdrive with the debian on from ~1month ago).

Now the setup is a 2.6.24-yonggun kernel with uboot. I believe I can install another distro on SD and boot it - I have seen various postings about using altboot/kexec/sharp bootloader. As I understand it this would do 2 things :-

1) It would boot the SD distro if I forgot to hold down '2' when I reboot - rather than panicking.
2) If I mess up the debian install again I could probably fix it using the distro on the SD (chroot anyone ?)

Can install another distro on the SD - preferably pdax as i used to use it on a c860 (although i am having trouble working out what the latest usable version is) and boot it with uboot.

I don't understand much about the uboot boot process, so would like to add a distro to my current working setup rather than fiddle around with other boot methods and risk losing Debian.

I can't believe someone isn't doing this already :-)

Please no suggestions of what *might* be possible, contributions about confirmed working setups would be much appreciated.
8 Apr 2008
I am currently running debian armel (lenny/sid) with kernel Linux Zaurus 2.6.24-yonggun #10 PREEMPT Wed Jan 30 00:38:19 IST 2008 armv5tel GNU/Linux

I had been happily upgrading packages with apt-get update ; apt-get upgrade however on one occasion it decided to upgrade libc6 - that's where trouble began.

The libc6 upgrade failed with a kernel panic, since then i have tried various things, including manually extracting and installing the libc6_2.7-10_armel.deb manually (dpkg -x libc6_2.7-10_armel.deb libc6_extract ; cd libc6_extract ; find . | cpio -pdmuv / ), hacking the status of the package from :-

dpkg-query --status libc6
Package: libc6
Status: install reinstreq half-installed
.
.
.
Description: GNU C Library: Shared libraries
Contains the standard libraries that are used by nearly all programs on
the system. This package includes shared versions of the standard C library
and the standard math library, as well as many others.

to

Package: libc6
Status: install ok installed
.
.
.
Description: GNU C Library: Shared libraries
Contains the standard libraries that are used by nearly all programs on
the system. This package includes shared versions of the standard C library
and the standard math library, as well as many others.

but its to clever for that and gives :-

dpkg-query --status libc6
dpkg-query: parse error, in file `/var/lib/dpkg/status' near line 18674 package `libc6':
Configured-Version for package with inappropriate Status

If i try installing anything else in this case xterm (for no particular reason) :-

dpkg -i xterm_234-1_armel.deb
(Reading database ... 91573 files and directories currently installed.)
Preparing to replace xterm 234-1 (using xterm_234-1_armel.deb) ...
Unpacking replacement xterm ...
dpkg: dependency problems prevent configuration of xterm:
xterm depends on libc6 (>= 2.7-1); however:
Package libc6 is not installed.
dpkg: error processing xterm (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
xterm

So I don't seem to be able to go forwards or backwards.

The installation works fine, apart from not being able to install/update any packages so I don't really want to trash it.

Does anyone have a good installed libc6-2.7-10 package installed so i could try pasting the status file entry ? or is there a legit way to force dpkg to accept it as installed ?

The only other thought I came up with was installed pdaxrom (pdaXii3 ?) on sd and using chroot or dpkg -root to force the install on the debian environment.

Any help or suggestions would be greatly appreciated (reinstall is least favoured option).
22 May 2006
I was looking at getting a Lacie Skwarim (?) 60gb 1.8" USB drive - has anyone tried it with a C3100 ? Will it work (at all) ?
22 Dec 2005
Dear All,

I have a C860 with pdaXrom working perfectly, I have all the apps I want/need and then some. In short I am very happy with it and appreciate all the work that has gone into it.

I am expecting a C3100 to turn up around Christmas. I have read the article about porting pdaXrom to the C3000 which sounds troublesome. Therefore my question is, will pdaXrom (rc12) install into flash on the C3100 and provide the same functionality as my C860 until such times as an install to the internal HDD is sorted ?

I know it sounds like a newbie question, but I haven't seent he answer elsewhere and I don't want to brick the C3100 when it turns up if it isn't going to work.

Regards
Andy

PS. Keep up the good work
11 Aug 2005
Greetings all,

I am using a pdaXrom 1.1.0 RC10 on a C860. I am trying to build a number of simple X based games, I have a fairly weak dev background, but can make tweaks to makefiles etc if necessary.

So far builds with Makefile and ./configure scripts have been working well, however I am trying to build xmris - a X version of the classic video game Mr. Do. This has an Imakefile and requires either imake or xmkmf to build the Makefile. Using xmkmf I get the following errors :-

# xmkmf
mv -f Makefile Makefile.bak
imake -DUseInstalled -I/usr/X11R6/lib/X11/config
sh: /opt/cross/arm/3.3.2-xscale-softvfp/armv5tel-cacko-linux/bin/ld: No such file or directory
imake: No such file or directory
imake: Cannot exec /opt/cross/arm/3.3.2-xscale-softvfp/armv5tel-cacko-linux/bin/gcc.
Stop.
imake: Exit code 1.
Stop.

ld and gcc are actually located thus :-

# which ld
/opt/native/arm/3.3.6-xscale-softvfp/bin/ld
# which gcc
/opt/native/arm/3.3.6-xscale-softvfp/bin/gcc

I checked the /usr/X11R6/lib/X11/config directory and corrected the paths in the hosts.def file. I have scanned the whole filesystem, I can only find entries for the /opt/cross path in binary files. Is there a config I can change somewhere ? or do I need to rebuild some libraries ?

Any help appreciated.
Last Visitors


15 Jun 2008 - 15:45


19 Feb 2008 - 13:38

Comments
Other users have left no comments for ajnk.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 27th December 2014 - 12:48 PM