OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
walts doesn't have a personal statement currently.
Personal Info
walts
Age Unknown
Gender Not Set
Florida, USA
Birthday Unknown
Interests
No Information
Statistics
Joined: 20-April 04
Profile Views: 554*
Last Seen: 16th September 2008 - 03:50 AM
Local Time: Jul 30 2014, 05:07 AM
57 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

walts

Members


Topics
Posts
Comments
Friends
My Content
9 Nov 2007
I've been reading the forums, RTFM'ing and looking at files on my Zaurus all morning, but this has me stumped - and it's one of those really dumb issues that drives me nuts!

I came back home to pdaxii13 on my 3200 a few days ago, and then upgraded to pdaxiiv2. Everything is fine, I've gotten all the software I wanted installed and running, but could I leave well enough alone? NOOO!

I'm using icewm and really like it. I started looking at Themes (from the main menu) and changed to icedesert just to see what it looked like. When icewm started up again, the Start menu (the "X" in the lower left corner) was gone. I can still bring up the menu using the Menu key, but I'd really like to have the icon back.

After horsing around for a couple of hours, I dropped out of X and removed/installed icewm. Nothing has changed. Oh, the icewm menu editor complains it can't open /home/root/.icewm/keys and /home/root/.icewm/menu. That hasn't changed either - it was complaining before the reinstall.

I'm stumped at this point and would welcome any help I can get.

Walt


7 Nov 2007
I just came back to pdaXii13 after a trip to the 2.6 kernel via r198 and Angstrom.

I verified that I had the 5.4.9 files from the tyrannozaurus site and flashed my 3200 with the "full" version. (initrd.bin, tools.tar and updater.sh from Akita and hdimage-full.tar from Spitz)
I fixed up my wpa_supplicant.conf and wifi-radar files, and of course my wifi card (Ambicom WL1100-CF) did not work.
Based on prior experience with this ROM, I did a manual (ipkg from command line) install of hostap-drivers and hostap-utils (version 0.4.7-1) I have no idea what version is installed by flashing the ROM, but it has never worked for me in the past. (hostap-utils -v or hostap-utils --version give errors)
I also installed wifi-radar 1.9.8-2 and that gets my network going.

Then I did ipkg update and started ipkg upgrade. It ran for a while and then upgraded hostap-drivers, and the whole thing quit. Now I have no network connection.

Questions:
- How can I exclude a package from ipkg upgrade?
- Is that even a good idea? I want to keep things current but the version installed by flashing clearly doesn't work.
- How can I get things back to where they are working without re-flashing?
- The Tyrannozaurus download page clearly says this is 5.4.9, but the pdaXii13 Config Tool says 5.4.7. Who's lying and how can I find the version number other than the config tool?

TIA

Walt
16 Sep 2007
Possibly someone can help out a Linux amateur (I've graduated from N00B but still don't know a lot)

From what I have read and experienced, on the 3200 with the full install of pdaXii13, a lot of files are copied from the hard drive into RAM to improve speed during the installation process.

Now, I find many files in both locations. for example

# find / -name kismet.conf

locates a copy in /etc and another in /media/fakeroot/etc, and neither are symlinks.

Which one is the "real" kismet.conf?
Are they somehow magically kept synchronized or do I need to make sure of that manually?
Do I even care if they get out of sync?
Is /etc the RAM copy and /media/fakeroot/etc located on the hard drive?

Thanks.

Walt
11 Sep 2007
I've gotten pdaXii13 running on my C3200 and everything is great! This is the best RO
M implementation I have seen on many Zaurii over the years!

Thanks to all who have helped me to get this installed and running.

Now I have a new challenge - I'd like to use my cell phone as a modem via Bluetooth. So far the only thing I can find on the subject is on Hluc's excellent page on pdaXii13:
QUOTE
GPRS network connection via Bluetooth also works. Make sure /etc/bluetooth/pin contains your PIN and then use the PPP config tool to configure the preconfigure GPRS profile to look for your phone. Then use the PPP dialer to connect to the phone to enable the GPRS connection.


I've done that, entering my Cingular information into the PPP config tool, and when I try to connect wiht the PPP dialer, it gives
"Failed to open /dev/rfcomm0: No such device"

/dev/rfcomm0 is specified as the device on the Modem tab of the PPP config tool, and was already filled in. It's just a plain text field, no other choices offered.

Based on some other threads (not for pdaXrom) it looks like hciconfig is to Bluetooth as ifconfig is to Wi-Fi, but when I run it it returns nothing.

The Bluetooth card is an AmbiCom BT2000-CF and cardctl ident says

product info: "Compact Flash", "Bluetooth Card", "", ""
manfid: 0x0319, 0x0000
function: 2 (serial)

I'm not sure where to go from here, I'd appreciate any help or advice.

TIA

Walt
31 Aug 2007
I took a detour down the side road called pdaXrom and spent a few frustrating days trying to get WPA networking to work, and I finally gave up and decided to come back to Cacko.

First, I re-partitioned the hard drive to its factory settings using the partitioning utility on the pdaXii13 installer, then I restored the files to those partitions from Trisoft's site, and finally did a NAND restore using Trisoft's ROM.

Then having a working Sharp rom, I flashed Cacko 1.23 in the usual manner. I set the root partition to 64MB and flashed the new ROM. Everything went as expected except that when I try to boot after flashing the ROM, I get the following message in an endless loop:

grep: /var/lib/pcmcia/stab No such file or directory

I've tried flashing twice, with a freshly downloaded copy of the files the second time, but the same result.

Any help or suggestions would be welcome!

Walt
Last Visitors


5 Jan 2009 - 8:26


3 Dec 2008 - 14:42


13 Jul 2008 - 20:59


21 Mar 2008 - 0:49


18 Dec 2007 - 19:58

Comments
Other users have left no comments for walts.

Friends

2350 posts
Active: 7th December 2010 - 06:26 AM
View All Friends
RSS Lo-Fi Version Time is now: 30th July 2014 - 01:07 AM