OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
Sorearse doesn't have a personal statement currently.
Personal Info
Sorearse
Age Unknown
Gender Not Set
Tokyo
Birthday Unknown
Interests
Getting roaming WIFI working with pdaXrom. Currently using wpa_supplicant to connect to Mzone (NTT Docomo's wifi hotspot service) - but need to manually reconnect when walking between hotspots.
Statistics
Joined: 18-February 05
Profile Views: 190*
Last Seen: 6th August 2007 - 03:17 PM
Local Time: Nov 22 2014, 01:34 AM
16 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

Sorearse

Members


Topics
Posts
Comments
Friends
My Content
5 Nov 2006
Hi All,

Since upgrading to r121, I would like to summarise what has improved since beta4 (for me), and any outstanding issues....

I hope this post will be useful reference point for those deciding whether to upgrade to r121

Improvements...
1. The "double tap" issue that required a second screen tap, or key press on beta 4 in order to be recognised has been fixed in r121.
2. Auto recognition and config of Ambicom wifi card
3. Seems faster, but this may be my imagination !
4. When suspend and resume works (see below), wifi connection is re-established upon resume.
5. When exiting X, now I can key "a" without having to hold "Fn"

Issues
1. APM - suspend/resume works intermittently.
On my C760 (Husky), apm almost always refuses to suspend correctly, leaving just a flashing white cursor in the top left of the otherwise black screen. After this, the only way to bring the system back to life is by pulling out the power and battery and rebooting. I say almost always, because very occasionally it works perfectly. Could this be related to the amount of charge in the battery ? Or the flashed AD value for battery charge (currently 220).
I noticed that if the last output line after booting is
CODE
Starting switchevd     [OK]
/usr/sbin/alsactl: load_state:1236 - No soundcards found...
pdaXrom 1.1.0r121 "Kathrin"
zaurus login:

then APM fails to suspend. On the rare occasions when I can suspend, the boot messages have no errors relating to sound cards. It seems as if there is something not loading correctly which prevents alsa and apm working.
Another observation is that if I boot to the emergency system, then I can reliably suspend and resume every time - this suggests no hardware issue.

This is the most major issue I have with r121 - any help would be very welcome !

2. wpa_supplicant script [solved - as below]. Anyone trying to connect to WPA access points will need this.
Line 26 of /etc/rc.d/init.d/wpa_supplicant file. There is a double hyphen -- in the middle of the line that calls wpa_supplicant in daemon mode. This causes the wpa_supplicant not to load. Remove the -- and add the appropriate options at the top of the file, depending upon your driver. Then it works well. In my case, I added
CODE
OPTIONS="-iwlan0 -Dwext"



3. Want to bring up network at boot, then set date/time
[OK - not really an issue, more of a request tongue.gif ]
Installed ntp and ntpdate, which gets called during the init scripts, but this is before the network is started. Want to be able to bring up network (and wpa_supplicant) first, then start the ntp daemon.

4. JFFS2 Errors
When booting, the following message occurs...
CODE
JFFS2 notice: (1) check_node_data: wrong data CRC in data node at 0x062b1000: read 0x82f7b3cf, calculated 0x3c09ce76
EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended

Is this anything to worry about ? I ran e2fsck on /dev/mmcblk0p1, and fixed some errors, but the errors above still occur. How can I fix this ?

5. X-Term font issue
When using xterm, each character output is followed by a square. I use rxvt instead.

6. Distorted Text at prompt after exiting X
After exiting X, once the cursor is at the bottom of the screen, the screen output doesn't properly scroll up as desired. Remnants of text from previous lines remain.

7. Keyboard mapping [Fixed in this forum]
Certain keys, like Fn for Right Click, don't work "out of the box". Fn +1, Fn+2 (Zoom in and out), and Fn+3 and Fn+4 are not working, but can be fixed - search the forum.

That's all for now. Please add any other comments.
All of the above are observations on the C760.


Regards

Sorearse
Last Visitors
Sorearse has no visitors to display.

Comments
Other users have left no comments for Sorearse.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 21st November 2014 - 08:34 AM