OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
cho1ce doesn't have a personal statement currently.
Personal Info
cho1ce
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 18-February 05
Profile Views: 856*
Last Seen: 27th September 2006 - 02:13 AM
Local Time: Aug 2 2015, 07:29 PM
41 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour

cho1ce

Members


Topics
Posts
Comments
Friends
My Content
13 Sep 2006
busted my screen accidently, i think the backlight is str8 but the screen is most crack-ed. i'm starting to think i might have to try an figure out how to get a new zaurus sl-5500, becuase the name brand screens are so expensive!
it did serve well the 3 years i had it. smile.gif


so then it hit me, "hey maybe theres another manufacturer of a screen that 'would' work" but alas, it doesnt seem this way.

or maybe its time to upgrade to a new model?

so one more question!

is milkytracker running on any of the other zaurii, an if so how much do those usually go for, cuz i really dont want to pay much more than 200usd. i would really like to stick with something that has a cf 2 &/or sd slots.

thankyou, in advance!
-rahn
3 May 2006
i read through and tried to follow the methods to my best ability of this page:
http://s91215199.onlinehome.us/zaurus/zgcc2install.html

i can get mnt/card/.zgcc and mnt/card/.include mounted
by dropping into root using "su" an doing:
CODE
mknod /dev/loop[n] b 7 [n]


then come back to user "zaurus" an run the script "mntzgcc.sh"
CODE
mount -t cramfs /mnt/card/zgcc2Bin.cramfs /mnt/card/.zgcc -o loop
mount -t cramfs /mnt/card/zgcc2Inc.cramfs /mnt/card/.include -o loop



some reason, i cant get them to fully link or get $PATH to look in them, when i run zgcc.sh
CODE
export GCC_EXEC_PREFIX=/mnt/card/.zgcc/lib/gcc-lib/arm-linux/2.95.2/
export COMPILER_PATH=/mnt/card/.zgcc/bin:/mnt/card/.zgcc/lib/gcc-lib/arm-linux/2.95.2/
export CPATH=/mnt/card/.include/
export LIBRARY_PATH=/mnt/card/.zgcc/lib/:/mnt/card/.zgcc/lib/gcc-lib/arm-linux/2.95.2/:/lib/:/home/QtPalmtop/lib/
export CPLUS_INCLUDE_PATH=/mnt/card/.include/g++-3/
PATH=/mnt/card/.zgcc/bin:$PATH
export PATH
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/mnt/card/.zgcc/lib
export LD_LIBRARY_PATH
TMAKEPATH="/mnt/card/.zgcc/tmake/lib/sharp-onboard/"
export TMAKEPATH
ln -sf /lib/libc.so.6 /usr/lib/libc.so
ln -sf /lib/libm.so.6 /usr/lib/libm.so
ln -sf /mnt/card/.zgcc/bin/libstdc++-3-libc6.1-2-2.10.0.so /home/QtPalmtop/lib/libstdc++-libc6.2-2.so.3


it doesnt show any errors when i run this,
but then it doesnt seem to be looking for anything its suppose to be??? rolleyes.gif

the strange thing is, that while in 1 Konsole tab where an when i run the scripts, i somehow got it before to see gcc from doing "which gcc"
cant remember how i did it, tho it brung up the proper location of gcc
(And only gcc tongue.gif )

if i start another tab in Konsole, an do "which gcc" it wont find it at all.
very peculiar!!?!?

i would like to do all this in one sweep from running 1 shell script, or most preferable have it set itself up at boottime. (aiming for that one, but will be happy with the other.)

so im unsure which file i need to be modifying, making or where it would go.
Could i alleviate all this by putting a script of sorts in "/home/zaurus"? or maybe even somewhere else that is rw? maybe like /usr? i would like it to be seperate from important files, but it doesnt have to be.

for over a month now laugh.gif ive been trying to figure out how to compile this package:
http://raa.ruby-lang.org/project/opengl/
http://www2.giganet.net/~yoshi/rbogl-0.32d.tar.gz

i do imagine some of you reading this, may have seen my post at the bottom in the thread about permissions. no one was answering so i figured i should restructure an make my own thread. i did search too, but i cant figure out what the true problem is!


it seems to me that $path $Path and $PATH are all different things, an now ive gone crosseyed.

thanks for you time.
-rahn
19 Apr 2006
We Need More Ppl To Help Betatest Milkytracker, ita a music program, currently running on the sl-5500.

http://www.oesf.org/forums/index.php?showtopic=18948

i posted this message in another spot

if you wish to reply please reply to that thread above, i double posted to make sure everyone interested might get the chance.

the program is a tracker, it you dont know anything abouit tracking, this might be pretty hard for you to wrap you head around. tho if you want to learn i would personally give you links to good txt's an other documents to help you understand the methods invloved. if you dont like to read that could be a problem biggrin.gif
19 Apr 2006
if you would like to help betatest milkytracker of the Z 5500 please contact Peter at milkytracker.net @ this address:
support "at" milkytracker.net

we need as many of you who are willing to help. smile.gif

i would imagine it could also run on a 5600, but am unsure.

other zaurus models might work too.


-rahn
12 Apr 2006
i want this thread to become a Ruby resource
to other Z sl-5500 users, containing links
to Ipks, compatible libs, sample scripts and
anything else that would benefit this thread


QUOTE
i recently got ruby going on my Z, its super cool!

i did some searches of the forum an found nothing stating worth to info on this, my best bet was google.

im a noob to programming, ive been at it for about 2 years trying to figure out where to start, this seems like it might* be a break for me. thoughout my searching and studying various languages i always either find myself incompatible or the dependencies an libs are non existent to what i want to do.

so far ive actually gotten some ruby scripts to run and this is very exciting!

i set out last week to find a way to send OpenSound Control (OSC) messages, using my Z sl-5500 to communicate with all of the wonderous sound/graphics OSC enabled programs. http://www.opensoundcontrol.org/implementations


okay, here it is:

this 1st
http://www.focv.com/feed/ruby_1.8.4-1_arm.ipk
this 2nd
http://www.asahi-net.or.jp/~cv8t-hdk/archi...e_0.5.2_arm.ipk

if you havent already, open the console. an do this:
CODE
# uname -a


you should get something like this:
CODE
Linux zaurus 2.4.18-rmk7-pxa3-embedix #1 Fri, 9 May 2003 09:20:18 +0900 armv4l unknownbash-2.05$


now do this:
CODE
# ruby -v


you should get something like this:
CODE
ruby 1.8.4 (2005-12-24) [arm-linux]


i got this info from here:
http://www.caliban.org/ruby/ruby-zaurus.shtml
(i didnt include some of the other info he wrote because i do not know what it does,
i only really understand that most of what he wrote after the code above, pertained to an earlier version which put everything on an sd card.
i think* the 2nd part adds those directories to your #path, i am unsure.)

http://www.mneuroth.de/privat/zaurus/visiscript.html

i installed visiscript just tonight, seems pretty handy too.
although the OSC script i found seems to lock it up
(reason: either i really have no idea or the script i found is waiting for some kind of input from somewhere?)

here is the link to the OSC script, if anyone wants to have a go:
http://raa.ruby-lang.org/project/osc/
i have only been able to run "localtest.rb" the others produce errors..
it seems i dont have everything i need to run the others, an i dont yet know where to get them
(if you understand this, would you please tell me what i'm doing wrong?)

http://raa.ruby-lang.org/index.html
this site has alot!
Application
Documentation
Library
Ports

okay, so far this is as far as i have gotten with finding compatible libs / something i can get to work!!!! i dont know how much of these packages will work, it seems alot of them need to be compiled and i dont have the ability to compile these yet, to know how much of these will work. ive been trying to just run the .rb scripts

there is a tremendous amount of info on ruby, but since this thread is platform specific, i would like to find everything that is compatible, for our Beloved Z sl-5500'S!
i will keep updating this, if there is interest. if not, i'll be back periodically to check up.

so far,
my main plan is to build a zaurus ruby app w/ gui to use to send OSC messages/bundles to OSC enabled software, using a tabbed interface with an XY controller, programmable buttons, sliders and maybe some knobs, while having another tab for a small console for monitoring/writing new messages.

atm, i have no idea where to start, except by finding compatible ruby libs and scripts

heres some more links specifically for ruby:
mainsite:
http://www.ruby-lang.org/en/
documentation:
http://www.ruby-doc.org/downloads
the place where i found the OSC scripts:
http://www.funaba.org/en/ruby.html

i hope that we can help each other using this thread, so reply!
if not then this post will have become a waste of time an i'll probably delete it!

-----------------------------------------------------------
-----------------------------------------------------------

it seems that apparently the ruby-qte ipk above, is somehow incompatible with the 5500's. im not positive about this but im getting no indication that they are.
looks like this may have to go back some versions for things to work properly.
or figure out how to get a compiler going and find the cvs for wherever the source is
for the 5500.
i found a devel package full of examples and tutorials, so maybe i'll find the answers inside. we will see.


---------------------
well its about a week later, i took a break from messing with this, an it seems to have paid off! Archimedes wife was so undoubtedly correct. apparently i wasnt following the procedure of installing the libs correctly. i will revise this whole post, soon.
Last Visitors
cho1ce has no visitors to display.

Comments
Other users have left no comments for cho1ce.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 2nd August 2015 - 04:29 PM