OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
Blaise doesn't have a personal statement currently.
Personal Info
Blaise
Age Unknown
Gender Not Set
Toulouse / France
Birthday Unknown
Interests
No Information
Statistics
Joined: 15-March 05
Profile Views: 513*
Last Seen: 9th May 2005 - 11:49 AM
Local Time: Dec 18 2014, 10:31 PM
37 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

Blaise

Members


Topics
Posts
Comments
Friends
My Content
25 Mar 2005
In order to setup zgcc, there is a script to run called zgcc.sh that appends some pathes and makes some links. When I run it (./zgcc.sh) the pathes aren't appened but the links are made. How come ?
I copied this file elsewhere and appened at the begining of the file this line :
#!/bin/sh
But it doesn't work either.

The only way I have found to have a nice zgcc setup is to type all the zgcc.sh file in a console, which takes quite a long time on the Z keyboard (!!!).

Anyone knows how I could run this file (OZ-3.5.2, OPIE-1.2, I think sh is runing and not bash). ?
Tks
This is the original zgcc.sh file delivered by ZGCC :

export GCC_EXEC_PREFIX=/mnt/card/.zgcc/lib/gcc-lib/arm-linux/2.95.2/
export COMPILER_PATH=/mnt/card/.zgcc/bin:/mnt/card/.zgcc/lib/gcc-lib/arm-linux/2.95.2/
export CPATH=/mnt/card/.include/
export LIBRARY_PATH=/mnt/card/.zgcc/lib/:/mnt/card/.zgcc/lib/gcc-lib/arm-linux/2.95.2/:/lib/:/home/QtPalmtop/lib/
export CPLUS_INCLUDE_PATH=/mnt/card/.include/g++-3/
PATH=/mnt/card/.zgcc/bin:$PATH
export PATH
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/mnt/card/.zgcc/lib
export LD_LIBRARY_PATH
TMAKEPATH="/mnt/card/.zgcc/tmake/lib/sharp-onboard/"
export TMAKEPATH
ln -sf /lib/libc.so.6 /usr/lib/libc.so
ln -sf /lib/libm.so.6 /usr/lib/libm.so
ln -sf /mnt/card/.zgcc/bin/libstdc++-3-libc6.1-2-2.10.0.so /home/QtPalmtop/lib/libstdc++-libc6.2-2.so.3
25 Mar 2005
At ipkgfind, I can see libtiff3g.ipk , but I also need the devel package to compile an application. Does anybody know where I could find a libtiff.ipk and its related devel ipk ?
Tks
24 Mar 2005
Finaly I managed to have zgcc working on Z sl-5500 with OZ-3.5.2 and OPIE-1.2 for native compilation of MapServer. It seems that I solved all libraries dependencies (freetype, libpng, libjpeg, gd); the "./configure" command ends ok. But the "make" command fails with :
#make
... . .
yacc -p msyy -d omapparser.c mapparser.y
make: yacc: Command not found
make: *** [mapparser.c] Error 127
#

Yacc seems related to Bison. I don't understand wether I have bison installed or not :
#ipkg info bison
Package: bison
Version: 1:1.35-3
Depends: libc6 (>= 2.2.4-')
Status: install prefer,user not-installed <---- what does that mean ? ?
ARchitecture: arm

I dl "bison_1.35-3_arm.ipk" but when I try to install it, I get :
#ipkg install /mnt/cf/ms/bison_1.35-3_arm.ipk
Installing bison (1:1.35-3) to sd...
sh: /tmp/ipkg-ey3VZY/bison-PbK06y/preinst: not found
preinst script returned status 127
Aborting installation of bison
An error has occured, return value: 1.

Each time I retry to install bison, it doens't find the preinst in another /tmp/ipkg-xxxx directory.
I looked in /tmp but there is no directory like that, and if I create one, then when I retry to install bison, the name it looks for has changed.

Is Bison that difficult to install ? It seems strange. I'm geting closer and closer to my aim but now, I'm stuck with this "little" thing. Any suggestion for me to install Bison ?

btw: I think I have bison-dev ok :
#ipkg info bison-dev
Package: bison-dev
Version: 1.875-r0
Status: install user installed
Architecture: arm
Installed-Time: 11116542551
but it doesn't seem enough for the make.

Tks
Blaise
21 Mar 2005
Still willing to compile natively on sl-5500, OZ-3.5.2 and OPEI-1.2 ! I haven't be successfull with using gcc-2.95; so I would like to test this dev_img-1.5 . But the begining is still puzzling : I flash a new rom to start from scratch, dl the dev_img-1.5 from :
http://www.zaurususergroup.org/modules.php...Developer_Image
When I run image_setup.sh script, I get :
mount: Mounting /...../dev_img-1.5 on /home/zaurus/develop failed: Block device required.
It did not had cramfs in the ipkg list so I installed it, but same error.
Something to do with fstab, cramfs, my file tree ?
tks
blaise
20 Mar 2005
How can I type the { and the } charaters on the sl-5500 keyboard ? ? ?
blaise
Last Visitors


30 Apr 2008 - 0:26

Comments
Other users have left no comments for Blaise.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 18th December 2014 - 10:31 PM