OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
melee doesn't have a personal statement currently.
Personal Info
melee
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
C860 - Sharp ROM with English translations
Statistics
Joined: 17-March 05
Profile Views: 670*
Last Seen: 11th October 2007 - 08:04 AM
Local Time: Oct 2 2014, 11:27 AM
69 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour

melee

Members


Topics
Posts
Comments
Friends
My Content
30 May 2005
Hi

Some help please

I am trying to crosscompile some code which works and compiles fine under the simulated Z environment for a qws frame buffer.
I am using the /opt/Qtopia and /opt/Embedix packages with scripts to set env

I get the errors below, malloc is such a basic function it must be quite simple.

By removing the libstdc++-libc6..... lib in my /usr/lib that libqpe uses under the x86 env, I can produce a similar
problem for compilation in the X86 qws environment

Therefore malloc is in libstdc++-libc ????

The version of libstdc++-libc in my /Embedix..... is libstdc++-libc6.3-2-2.10.0.so
This is as supplied and has worked until now

The version of libstdc++-libc in my /usr/lib..... is libstdc++-libc6.2-2.so.3

Have the malloc functions changed so much that there is incompatability between those libs?

My Z is a C860 with Sharp ROM so has libqte-2.3.2 and libqpe-1.5.0. Whatever I use must remain compatable to that

The output is:-

arm-linux-gcc -Wl,-rpath,/opt/Qtopia/sharp/lib,-rpath-link,/opt/Qtopia/sharp/lib -o zword defdlg.o dictionary_impl.o \
file.o filedlg.o formatter.o main.o mkdirdlg.o mkdiredit.o scqtfiledialog.o scqtfiledlg.o shc.o shcm.o spellengine.o \
utf8.o zword.o zwordview.o moc_defdlg.o moc_mkdirdlg.o moc_mkdiredit.o moc_scqtfiledialog.o moc_scqtfiledlg.o \
moc_zword.o -L/opt/Qtopia/sharp/lib -L/opt/Embedix/native/lib -lqpe

dictionary_impl.o: In function `__malloc_alloc_template<0>::_S_oom_malloc(unsigned int)':
dictionary_impl.o(.__malloc_alloc_template<0>::gnu.linkonce.t._S_oom_malloc(unsigned int)+0x28): undefined reference to `ostream::operator<<(char const *)'
dictionary_impl.o(.__malloc_alloc_template<0>::gnu.linkonce.t._S_oom_malloc(unsigned int)+0x2c): undefined reference to `endl(ostream &)'
dictionary_impl.o(.__malloc_alloc_template<0>::gnu.linkonce.t._S_oom_malloc(unsigned int)+0x58): undefined reference to `cerr'
collect2: ld returned 1 exit status
make: *** [zword] Error 1

Any ideas

yours hopefully

Melee
19 Apr 2005
Hi

If anyone is interested, I have hacked the code for the above to increase the hardcoded tile and font sizes, so that it will display full screen in 480x640 VGA ie in portrait mode on my C860.
That's the only change to an otherwise excellent game

You needed prodigious eyesight or strong reading glasses to play the original on the higher res screen.

I have posted it on my web site { Click here to download } for anyone who wants it

It launches in 640x480 but can then be rotated into 480x640. You need portrait mode to see the tile rack and buttons.
I have tried setting Display=480x640/144dpi in the wordgame.desktop file but this has no effect

(If anyone can provide a definitive answer to how you change the display mode for launch for all apps, I would be very interested)

enjoy

Melee

PS

The 2 fonts used are smooth-times and helvetica
I'm sure that smooth-times is a standard font found in the ROM image,but it can be downloaded if your ROM doesn't have it.
I downloaded helvetica in its various sizes at some point so I have posted that also for any of you that get problems displaying fonts { Click Here to download}
23 Mar 2005
Hi
I use Midnight Commander a lot, both on my main linux box and the Z (C860).

I use it quite a lot on the main box for uploading files to a website, using the virtual file system facility eg cd /ftp:user:pass@website.address.com

My attempts to use a similar strategy with the Z have not been successful.

I can open a ssh tunnel to the Z no problem, log on as root and do whatever I want. I have all the open ssh files for client and server on the Z.

I dont know if mc can use ssh or is limited to a simple ftp connection, which the Z rejects.

Has anyone experience of accessing the Z file system directly from Midnight Commander?

Thanks
Last Visitors
melee has no visitors to display.

Comments
Other users have left no comments for melee.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 2nd October 2014 - 02:27 AM