OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
tesla_cubed doesn't have a personal statement currently.
Personal Info
tesla_cubed
Age Unknown
Gender Not Set
Joplin, Missouri USA
Birthday Unknown
Interests
No Information
Statistics
Joined: 28-April 05
Profile Views: 498*
Last Seen: 24th December 2009 - 04:02 PM
Local Time: Sep 16 2014, 03:30 PM
28 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

tesla_cubed

Members


Topics
Posts
Comments
Friends
My Content
28 Mar 2007
I installed zkbdd It works great for the leters and numbers but I have no puncuation. Replacing the lines for shift on the numbers with 0; s made some symbold work. It seems to pass shift to the X as well as shift them itself. The shifted numbers are maped like on the Z and not my IR kbd. and except for [{}] none of the puncuation dose what it should some make internatonal chars and most make unsuported chars the "~" makes a a with two dots above it. I guessed that the scan codes are difrent for difrent models of Z, some searching here reveled xev as a way to see the scancdes now things got wirerd it shows standard scancodes like on a PC, ztokens shows somthing completly diffrent. blink.gif More searching shows that X translates the codes before any apps sees them.

So somthing like
Z keyscan --> translate to pc keyscan --> X ---> aplacation

zkbdd taps in at the Z keyscan and makes my IRK act like a 2nd set of Z keys

2 questions
Can I use the pc scancodes and have zkbdd put it in the streem stright to X?
Is there somthing that will let me see the Z scancodes outside of X so I can map them for my 3200 or a place ther documented?

I also get the same strangness with usb keybords useble but flakey on some keys.

Thanks
Tesla^3
13 Mar 2007
I put together a fiew scripts to start and stop stuff depending on what I want to do. nothing fancy just saving some typing. Work start WPA, start dhcp, start samba, kinda stuff. Here is whrer things get wierd . ls shows my script ls -l shows its executable and ownd by root
CODE
-rwxrwxrwx    1 root     root           92 2007-03-13 15:10 work
-rwxrwxr-x    1 root     root           77 2006-09-22 17:53 wpa


When I try to run it i get
CODE
root-:) work
-bash: work: command not found

This also happens if I copy a binary exe from anywhere except in the Z. Things installed with ipkg and things that are made with make work. It seems to know where there from and if there copied or typed in it dosnt like them. When I first tryed pdaxII1.3 I wrote a small script to load the kennal drivers and start ZKBBD it still works though. I can edit the scripts but just not run them if I copy a working one and then edit and save as a new name it quits working.

Any sugestions?
thanks
Tesla^3
5 Mar 2007
I tryed out the kismet plugin with xroadmap and it worked except for geting the location of the detected APs very wrong. About 1/2 mile on a grid there was a AP. Well rdmkismet was converting it to ddmm.ddmmmm not ddmm mmmmm due to typo in the to nema converter to fix it yourself and rebuild change
CODE
*nmea_mmmm = (int) (kismet * 10000.0);
*nmea_ddmm = (nmea_dd * 100) + nmea_mm;

to
CODE
*nmea_mmmm = (int) (converting * 10000.0);
*nmea_ddmm = (nmea_dd * 100) + nmea_mm;

in roadmap_kismet.c

or just replace your rdkismet with this one
Attached File  rdmkismet.zip ( 20.58K ) Number of downloads: 7


Thanks meine for a easy to setup build system on pdaxii

Happy wardriving tongue.gif

Tesla^3
9 Feb 2007
I have had my 5500 for quite a while so I am uesd to linux on a handheld, but I am finding the 3200 a whole new ball game. biggrin.gif so I have a fiew probly obvious questions.

1st what do the 2 all Japanese keys do the ones after Fn Ctrl Aand before the sapce?

After I got it I flashed it over to OZ/OPIE 3.5.4.1 I run OPIE on the collie so I thought that was a good place to start. Now for the how do I make it work questions.

2nd USB as a device it worked before I flashed it thats how I copied the files to flash it now it the computer (winXP and linux both do the same) sees it as a storage device but dosnt map the drive in networking mode with linux.inf it dose the same thing the adpter shows but it says "connection failed on the computer. It acts like somting is keeping the usb bussy when I first install the driver it hangs untell I unplug the cable. So am I missing somthing on starting ? Ive tryed

CODE
modprobe g_eather

and

modprobe  g_file_storage file=/media/card


both run ok on the Z but dont talk to the computer beyond identfying themselvs.

3rd USB as a host Reconises Devises and then sits there Ive tryed mountiong by hand and it says device not ready or bussy is there a verson of the usbapplet for OPIE, If somthing is conflicting with usb will it work at all though? Random thought can you run usb host and device at the same time or do I need to stop one before starting the other?

4th IRK Belkin installs, loads and thendose nothing it actes like somthing isnt leting it find the irda I am not sure whrere to start to check it I know the irda on the Z works for xfering files and the keybord works on my old Z just fine?

I am open to sugestions of other ROMs as well. the main things I use are the PIM apps, IRK for taking notes on the Z, Wellenrighter, Zroadmap, Bluetooth for internet over my phone, WPA supplicant for internet where there is WIFI, a pdf reader, I would realy like X-screensaver if possable.

Thanks.
Tesla^3
6 Feb 2007
I just got a c3200 compared to my 5500 WOW smile.gif , but I am kind of lost on seting up wpa on it. I pulled my WiFi form my old Z and the new one found it right away it works great on open and WEP networks. So far So good so now to set it up to acces at work where we use WPA, copyed over my wpa_supplicant.conf and edited it a litle, changed wlan0 to eth0 the name of the interface changed for some reason. Then When I start wpa I get

CODE
ioctl[PRISIM2_IOCTL_HOSTPAD]: Operation not supported
Faled to set encryption.


Pluging the card back into the 5500 and its up and runing on the net at work, so I know the card can do it.

Any thing to try to get it encrypting on the 3200 ?

Thanks

TC
Last Visitors
tesla_cubed has no visitors to display.

Comments
Other users have left no comments for tesla_cubed.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 16th September 2014 - 01:30 PM