OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

Profile
Personal Photo
Options
Options
Personal Statement
crstophr doesn't have a personal statement currently.
Personal Info
crstophr
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
Interests
No Information
Statistics
Joined: 22-June 05
Profile Views: 116*
Last Seen: 19th June 2006 - 01:36 PM
Local Time: Dec 27 2014, 02:56 PM
18 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour

crstophr

Members


Topics
Posts
Comments
Friends
My Content
10 Nov 2005
Is it necessary to use gcc 2.95 to compile kernel modules?

I'm compiling natively on a 3100 running RC12. I have gcc 3.4.4 in /opt/native from the image that was provided. I have the pdaxrom pcmcia sources and I've applied the 7.18 agere driver to those sources. I have the tetsu 2.4.20 kernel with all his patches in.

Everything seems to build OK. I've copied the two new modules to the proper place with the rest of th wifi modules. I have an agere.conf file with the correct manuf id and module setting in /etc/pcmcia.

When I insert my card (Socket Low Power Rev cool.gif the module loads (show up in lsmod) but I get a big error and a backtrace in dmesg.

So I'm thinking that I should probably be using the same version of GCC to compile the modules as was used to compile the kernel. Was 2.95 the version used to compile the kernel for pdaxrom RC12? Can someone point me to an apropriate version of gcc that runs native to the Z?

Thanks for any help. I really want to see this card work again. It nearly doubles my battery life when using wifi.

Alternatively, would anyone be willing to post these two modules from the cacko 1.23 ROM?

wlags49_h1_cs.o
wlags49_h2_cs.o

Maybe I can just use his modules....

Thanks,

--Chris
14 Oct 2005
QUOTE
CODE
g++ -fno-exceptions -I/usr/include/SDL -D_REENTRANT -mcpu=xscale -mtune=xscale -WA,-mfpu=softvfp -funroll-loops -fomit-frame-pointer -pipe -DC_CORE -DPROFILING   -o VisualBoyAdvance  SDL.o debugger.o 2xSaI.o Cheats.o EEprom.o Flash.o GBA.o Gfx.o Globals.o Mode0.o Mode1.o Mode2.o Mode3.o Mode4.o Mode5.o RTC.o Sound.o Sram.o Text.o Util.o admame.o agbprint.o armdis.o bilinear.o bios.o elf.o expr-lex.o expr.o exprNode.o getopt.o getopt1.o hq2x.o interframe.o memgzio.o motionblur.o pixel.o remote.o scanline.o simple2x.o unzip.o ../gb/libgb.a ../prof/libprof.a -L/usr/lib -Wl,-rpath,/usr/lib -lSDL -lpthread -lpng -lz
/zgcc/bin/../lib/gcc/armv5tel-cacko-linux/3.4.4/../../../../armv5tel-cacko-linux/bin/ld: ERROR: /usr/lib/libSDL.so uses FPA instructions, whereas VisualBoyAdvance does not
/zgcc/bin/../lib/gcc/armv5tel-cacko-linux/3.4.4/../../../../armv5tel-cacko-linux/bin/ld: ERROR: /usr/lib/libSDL.so uses hardware FP, whereas VisualBoyAdvance uses software FP
/zgcc/bin/../lib/gcc/armv5tel-cacko-linux/3.4.4/../../../../armv5tel-cacko-linux/bin/ld: failed to merge target specific data of file /usr/lib/libSDL.so
collect2: ld returned 1 exit status


I get the above errors when I try to compile VisualBoyAdvance on pdaxrom rc12 on 3100. Ultimately I'm trying to produce an iwmmx enabled VBA but for now I would be happy to see it compile successfully once with normal compiler options. I've tried variations of -Wa,fpu=fpa fpa11 and softvfp. I've tried -msoft-float and -mhard-float.

Either I can't make it past the ./configure step where it tries to produce a C executable or I get all the way through the process and fail at the linking step at the end. Either way I get messages about FPA instructions and hard vs software FPU.

I see that VisualBoyAdvance is in the feeds and I've installed it. Can you guys tell me what options you used to get it to compile in the first place?

I'm using the zgcc you posted a little while back (3.4.4) on the cramfs image. I am not using a cross compiler. I'm compiling on the Z directly.

Thanks,

--Chris
25 Aug 2005
I've been playing with the libsdl .ipks from this site:
http://translate.google.com/translate?hl=e...n-US:unofficial

These are compiled to take advantage of the bvdd driver for better performance. Unfortunately the whole site is in Japanese and I can't make much sense from the translation.

The problem I'm having is that when I try to use them the pointer is always off by about 1cm down. i.e. where you tap is not where the screen reads the tap. This happens in barrage and crimson fields.

Just wondering if anyone else has run into or solved this problem.

--Chris
11 Jul 2005
I'm not sure if this is news but I just got gentoo working on my 3100. I'm brand new to the zaurus (my last pda was an apple newton!) but not new to gentoo or linux.

All I had to do was put the gentoo-arm distribution on the internal microdrive

I repartitioned the internal hdd to have a 2G vfat on /hdd3
made a 2G ext3 FS mounted to /home/gentoo
unpacked the gentoo-arm dist into /home/gentoo
mounted proc
chroot into /home/gentoo/gentoo-dist

emerged joe as my first test and succeeded. (had to edit the ebuild to add the arm keyword)

The neat part is that it doesn't change the default sharp rom. The OS looks for a /dev/hdc3 to mount as vfat to /hdd3. /hdd3 can be empty, the OS doen't need anything from it to boot. As long as you make some kind of vfat FS on /dev/hdc3 you're fine and you can give the rest of the space to /dev/hdc4 for ext3 and gentoo.

I'm not sure where I'm going on this I'm just desperate to do something interesting with my Z since there are no roms out for the 3100 yet.

--Chris
27 Jun 2005
Just wondering if anyone can recommend a place to buy the overlay brillant protector. I can't seem to find a place to order one. Can anyone post a link?
Last Visitors
crstophr has no visitors to display.

Comments
Other users have left no comments for crstophr.

Friends
There are no friends to display.
RSS Lo-Fi Version Time is now: 27th December 2014 - 02:56 PM