OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
rcolistete doesn't have a personal statement currently.
Personal Info
Age Unknown
Gender Not Set
Location Unknown
Birthday Unknown
No Information
Joined: 4-August 18
Profile Views: 442*
Last Seen: 1st May 2019 - 04:01 PM
Local Time: Feb 24 2020, 10:30 PM
12 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour



My Content
20 Aug 2018
Flatpak 1.0 released, aims to simplify installation of Linux apps
see the install instructions :
for Debian :
which worked on Debian @ Gemini :
$ sudo apt install flatpak
$ sudo flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

From the Flathub :
many softwares don't install on arm 64 bits, with error message "No such branch ...aarch64".
Like Dropbox, Skype, Spotify, Atom, PyCharm, SublimeText, VisualStudio Code, etc.

List of flatpak softwares with arm64 support :
- Arduino IDE (1.8.5), with some large menu/dialog fonts;
- Telegram Desktop : works very well;
- UberWriter : Markdown editor, but it is too much slow and even blocks cursor mouse movement;
- etc.

Let's comment which flatpak softwares install on Debian @ Gemini and work well.
18 Aug 2018
I'm using Debian 9.4 on Gemini with triple boot (Android, Debian, Sailfish), firmware from July 2018.

As there is no auto mounting of microSD card, I've used the following steps to have 2 partitions (FAT32, Ext4) on microSD visible on Debian :

Just once :
$ sudo mkdir -p /media/sd
$ sudo chmod 777 /media/sd
$ sudo mkdir -p /media/sdext4
$ sudo chmod 777 /media/sdext4

Created "/etc/fstab" with the content :
/dev/mmcblk1p1    /media/sd            vfat    defaults,noatime,discard,user,umask=0000        0       0
/dev/mmcblk1p2    /media/sdext4        ext4    defaults,noatime,discard        0       0

I've realized that small errors on this fstab, or microSD nor inserted, make Debian to not boot ! The above one works (if there is a microSD inserted).

Any better way to auto mount microSD partitions on Debian ?
18 Aug 2018
I'd to like to use Debian on Gemini to do microcontrollers development using USB cable (USB serial interface) to run Arduino IDE, MicroPython (via screen, rshell, etc). They use USB serial communication.

After installing the modular Linux kernel and extra module for the Gemini PDA with USB serial drivers, optimizatons, etc, from :
PL2303 serial adapter drivers?
my microcontrollers (ESP8266, BC Micro:bit, Arduino Nano, etc) are recognized as /dev/ttyACM0 or /dev/ttyUSB0, but "screen" doesn't work (closes connection after starting) and Arduino IDE doesn't show any serial port.

(2018/08/21) : SOLUTION FOUND : solution is not only to add gemini user to dialout group (it was already becuase gemini is the unique user), but also to change the group of the tty devices to dialout (it is not done automatically like other Linux) :
$ sudo usermod -a -G dialout gemini
$ sudo chgrp dialout /dev/ttyACM0
$ sudo chgrp dialout /dev/ttyUSB0

Repeat for any other USB serial tty port (USB1 for a 2nd microcontroller, etc).

Tested with :
- Arduino IDE (v1.8.5 installed using Flatpak, see other topic) with ESP8266, worked well, only some large menu/dialog fonts.
- rshell or screen connecting Pyboard with MicroPython, 100% ok !

Important : the microcontrollers were connected with microUSB & USB-A cable to a USB-C -> USB-A hub in the left port of Gemini.
Last Visitors

7 Sep 2018 - 12:41

25 Aug 2018 - 5:51

Other users have left no comments for rcolistete.

There are no friends to display.
RSS Lo-Fi Version Time is now: 24th February 2020 - 04:30 PM