OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
Geeber doesn't have a personal statement currently.
Personal Info
22 years old
Born Nov-7-1997
No Information
Joined: 12-April 19
Profile Views: 1,694*
Last Seen: 6th February 2020 - 05:29 AM
Local Time: May 25 2020, 08:46 AM
22 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
Contact Private
* Profile views updated each hour



My Content
27 Oct 2019

After Kali 2019.3 became more or less unusable on the Gemini.
I decided to try out gemian,
I found the software in debian stretch to be somewhat lacking. so (after a long session of trial and error) more or less gotten buster to run on the device pretty well.
First thing I did was install the gemian buster libc2.28 from the gemian buster repo and then:
I followed the instructions posted here https://github.com/gemian/gemini-keyboard-a...ki/DebianBuster by installing libglvnd-dev and moving the libs out of the way.
I also ran the update-alternatives command from the same page.
update-alternatives --set aarch64-linux-gnu_egl_conf /usr/lib/aarch64-linux-gnu/libhybris-egl/ld.so.conf after ran
sudo ldconfig and worked like a charm.

For anyone else that wants to run buster, I also needed to upgrade the x11-xkb-utils package or else the xserver would fail with illegal keycodes.

I also spent some time removing libs related to plasma kde as well as the majority of libreoffice packages before installing the buster libreoffice.
lxqt also conflicted but I don't use lxqt so I just removed it anyway.

However I upgraded the initramfs-tools-halium to the latest version from the gemian buster repo and first it gave an error saying /etc/ld.conf.so.d/aarch64-linux-gnu_EGL.conf no such file or directory. I fixed that by running sudo cp /usr/lib/aarch64-linux-gnu/libhybris-egl/ld.so.conf /etc/ld.so.conf/aarch64-linux-gnu_EGL.conf (I know this may not be the ideal way to solve the problem, just a workaround.) now the error is no longer there.

But after the kernel image is built it is too large for the partition. I should mention I also get a depmod error from a missing gemini.cpio.gz supposed to be located in /lib/modules, but that's not relevant to my problem.

When i run the dd command to /dev/disk/by-partlabel/boot2 dd complains that it has run out of space on the disk. When running sudo fdisk -l the partition size for /dev/mmcblk0p30 (where the linux kernel boot2 is located) says it is 16M the kernel file is 21M.

So basically is it possible to either reduce the kernel file size or resize the /dev/mmcblk0p30 partition. (It may be possible to edit the scatter file start addresses and finish addersses but I don't want to do that without knowing what I am doing.) If anything it might be a good idea to allow for more space on this partition in future as the kernel can simply end up too large to be flashed.

For now I have simply reflashed the original kernel that came with the firmware using a download only on the boot2 partition using the flash tool. but it cannot load kernel modules.

Maybe later I will try recompiling the kernel from source on the gemini with modules enabled at some point.
28 Sep 2019
Hey Guys

The current version of Kali has been updated to 2019.3 and because of an update to libc-bin to 2.29.1, a lot of packages under Kali on gemini now say that they will remove things like libhybris and xserver-xorg-video-hwcomposer driver.

Packages that are essential for Kali to run on the gemini.
Also a few other packages in the gemian buster repo that are essential currently to get audio to work under Kali.

Now attempting an install of a lot of packages such as libreoffice or wireshark will attempt the new libc-bin upgrade resulting in a lot of them being currently being uninstallable via apt-get.

I have attached a screen shot showing this.

Hopefully it can be fixed soon.
Attached thumbnail(s)
Attached Image
14 May 2019
I am just posting this to let other people know.
The kali-gem repository by re4son kernel received an update to the lxc-android package.
After I upgraded to this new version. (I update and upgrade as often as possible.)

Linux just became unbootable I could not ssh in even over USB cable. So I have just given up and reflashed.

Luckily (due to the amount of times I have had to reflash) I have written a bash script that more or less restores my system to its default. With only a few settings here and there needing to be tweaked via a GUI.

Linux did seem to boot correctly, I know this because I set up a cron job to change the brightness to 5% on system boot. Which did in fact work.

I was planning on using the logcat tool to see if I could fix the problem over ssh.

I don't really know how this problem can be solved but for now I am just going to hold the package back.
21 Apr 2019

I have enjoyed using Kali for the Gemini PDA, however audio does not work at all.
I am assuming audio under Debian works since I haven't heard any complaints about it.
I can confirm that audio works when using Android.

I can tell you some possibly useful information about this.

(My audio is not muted in pavucontrol just in case anyone thought I hadn't checked.)

1. Another user has confirmed that under Kali their audio does not work.
2. Audio does play but will not move from the first null output. Even when changed to droid sink primary.
3 My Hostname as well as sinks, sources and so on show up in pasystray when right clicked.
4. When attempting to load module-droid-card through pactl the error "connection failed, connection terminated" appears. (My pulseaudio now closes when this happens due to my messing around with it, but beforehand it used to just give an error.)
5. If attempting to load ALSA mixer a permission denied error is given even when all users are in the audio group and even as root user.
6. Occasionally when an Application that produces sound is launched from terminal. You can see a few errors when attempting to connect to AlSA mixer such as connection refused permission denied.
7. I did actually manage to get audio working correctly but the process was long, awkward and after reboot it stopped working again.

Here is how I got audio to work briefly.
This process is highly not recommended as editing dependencies in the dpkg status file could seriously mess up your software and generally you aren't supposed to edit this file.

I added the gemian think globally repo to my Kali install. Then proceeded to uninstall the Kali version of pulseaudio and installed the version from the gemian repo. to do this required downgrading or ignoring libpulse0 which mean I had to go into my /var/lib/dpkg/status file. (made a backup beforehand.) and deleted every dependency on libpulse0.
(I restored them afterwards by searching through the file and adding the deleted dependency from my backup.) Then I installed the gemian version of I think libpulse0 along with pulseaudio and pulseaudio-module-droid.

Now if I put my ear right up to the speakers when the PDA was shutting down I could hear static coming from the speakers. No luck with audio working sadly. Pulseaudio didn't show any sinks or sources.

So finally I decided to uninstall the gemian pulse audio and reinstall Kali pulseaudio. While also restoring all of the libpulse0 dependencies back to their orignal state. After I launched an application that supported sound and like magic audio was working. I don't even know if the right sounds were being played but it was definitely playing sounds.

Then after a reboot audio was gone forever and was back to not working at all.

After some googling I do have a guess that the version of pulseaudio from the gemian repo creates some necessary snd device files. But its configuration didn't work and after reinstalling the version from Kali, the correct snd files were found and therefore the audio worked correctly. I know these are created on system boot. So when a reboot was done. It would explain why there was no audio as I do think that the configuration of pulseaudio on kali seems to be correct.

I lack the experience or know-how to fix a problem of this complexity. Apologies for the long post.

Hope someone can provide some help or at the very least this can be documented as a problem.
18 Apr 2019
Hi all

Don't know whether people will find this useful.

But I managed to get a 64bit dwarf-fortress to run through qemu's user space emulation software.

Dwarf fortress is an open source video game with no ARM64 port.

This was achieved by installing qemu-user, enabling amd64 archictechture, downloading the prebuilt 64bit linux binaries from the dwarf-fortress website, and installing the required 64 bit libraries.

Some of the 64 bit libraries could not be installed correctly. So for one of them libpulse0 I apt downloaded it and unpacked the .deb file and put the libs in the correct location where the dwarf-fortress looks for them.

For the rest of them I apt downloaded them and wrote a bash script that dpkg force installs them and then runs the dwarf-fortress binary through qemu-x86_64 and after the app closes purges the force installed packages.

Performance is not very good obviously. (creating the world took a few hours because I set it to large tongue.gif)

Loading times are long but once the world is created. The game itself is actually playable. but does hang up freqently depending on what it is loading and the back of the Gemini gets a bit hot as it is constantly running a 100% CPU thread.

It may not be all that viable to run 64bit binaries on the Gemini. but I thought it was more interesting as proof that 64bit or 32bit binaries can actually be run on an ARM64. Which maybe people knew already but what the hey. I thought it was worth trying out.

Its important to note that any applications required mulithreading will fail because ARM CPUs do not support mulithreading. (I know this because I attempted to run valve's steam client in the same way, but qemu fails with a signal 11, segmentation fault, core dumped. When I looked it up people said it was to do with multithreaded applications)

In theory if you actually had an ARM64 CPU that supported multithreading I don't see why it wouldn't be possible to run mulithreaded 64 or 32bit apps through qemu-user.

Also in theory it might be possible to run a 64bit Windows program through running 64bit wine through qemu-x86_64 same way as done above. Bearing in mind that applications requiring multithreading probably wouldn't work.
Of course performance might be so terrible that the application may be rendered pretty much unusable at that point.

I may test this at some point later if I have some time to spare on it.

See the attached screenshot to see it running:
Attached Image

Its kind of a lot of work for not that much payoff but I hope some people find this to be an interesting or worthwhile experiment at the very least.
Last Visitors

29 Sep 2019 - 2:28

Other users have left no comments for Geeber.

There are no friends to display.
RSS Lo-Fi Version Time is now: 24th May 2020 - 11:46 PM