OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | #planetgemini chat on matrix.org | #gemini-pda chat on Freenode | #zaurus and #alarmz chat on Freenode | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
JohnX doesn't have a personal statement currently.
Personal Info
36 years old
Gender Not Set
Lynnwood, WA, US
Born Oct-10-1983
Cars and Computers
Joined: 4-May 05
Profile Views: 3,242*
Last Seen: 25th October 2009 - 11:35 AM
Local Time: Nov 12 2019, 08:35 PM
126 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ No Information
MSN No Information
* Profile views updated each hour



My Content
20 Dec 2005
I was poking around the openembedded build environment when I ran across musicpd. Musicpd is a music playing daemon that can be controlled from a front end that connects to it over a network connection. GMPC and Glurp are two Gtk front ends to this daemon that as of 12/19/2005 build with no errors out of the OE dev tree. The memory requirements are impressively low, especially without a front end running (music continues to play when the front end is closed). MP3s and OGGs play fine (though OGGs take 60% - 80% CPU time!). Theoretically it should support AACs and FLACs but I haven't tried either. Glurp has an interface that I find is a nice match to the 640x480 resolution that my C1000 does. Anyways, down to the important part, how to make it work. biggrin.gif
I attached the packages that I built. They're for the C1000 so they should work fine on the 5600 and up IIRC, but the interface seems to have a resolution of at least 640x480 in mind. If they depend on things not in the default GPE feeds, you might try looking in one of these two feeds:

If the dependencies aren't there tell me what it asks for and I'll try and post that package as well. If it just complains about a minor version mismatch it's probably fine to -force-depends. Also attached is a sample configuration file, mpd.conf. I added an mpd user, added him to the audio group and chown'ed /dev/dsp and /dev/mixer to be root.audio. You could of course make them world writable if you wanted to. I didn't want log files to be written to flash, so I pointed thos at /var/log. Because of permissions the user mpd won't be able to write there by default. You can either make a /var/log/mpd subdirectory or do like I did and touch the two log files and chown them to mpd.mpd before starting mpd. GMPC comes with a desktop icon. Glurp does not. I included the one that I hacked up for Glurp. It uses the same icon that GMPC does because I couldn't be bothered to search for anything more suitable. You should change the music and playlist directories in mpd.conf to point someplace more suitable for your install.

Warning: Use these at your own risk! They are barely tested! All I can say is they work for me.

Attached File(s)
Attached File  glurp_0.11.6_r0_armv5te.ipk ( 55.27K ) Number of downloads: 109
Attached File  mpc_0.11.2_r0_armv5te.ipk ( 23.61K ) Number of downloads: 97
Attached File  libao2_0.8.6_r0_armv5te.ipk ( 11.18K ) Number of downloads: 100
Attached File  gmpc_0.11.2_r1_armv5te.ipk ( 85.88K ) Number of downloads: 103
Attached File  glurp.desktop.txt ( 251bytes ) Number of downloads: 99
Attached File  ncmpc_0.11.1_r0_armv5te.ipk ( 41.19K ) Number of downloads: 99
Attached File  mpd_0.11.5_r5_armv5te.ipk ( 75.78K ) Number of downloads: 107
21 Nov 2005
OK, so I setup a bitbake build environment, I compiled mplayer-atty 1.1.5 for openzaurus. I installed bvdd (manually installed files from the ipk) from atty.skr.jp. With this stuff together I can watch video fairly smoothly on OpenZaurus, both GPE and Opie! Now GPE has come a long way, but I prefer Opie for day to day PDA stuff (notes, appointments, etc), so that's what I'm running right now. Under GPE, if I run mplayer from rxvt, I can use the keyboard to control it just like in Linux! left and right arrows to go 10 seconds backwards or forwards. up and down for a minute forwards or backwards. The OSD works and everything is swell. If I launch it from a script/icon I can't control it, which is no big deal, cause I can just have a script call an rxvt which can call mplayer. laugh.gif Under Opie however, once I run mplayer it takes over control of my Zaurus and I cannot do anything until the video is over or I ssh in and kill mplayer. Has anyone had any luck getting kino2 or zplayer or anything to properly control mplayer on OpenZaurus. I think one of the factors that's against me is that I want to use -vo bvdd for hardware video scaling. I seem to remember it working as long as I was using -vo sdl, but that was a while ago. I'll test some things and edit this later.

-John X
20 Jun 2005
I have OZ 3.5.3 flashed on my C1000. I'm very happy with it overall (much better than Sharp's ROM). I just have one nagging issue (which I suspect I caused):
Somehow I've managed to end up with the screen rotation 90° off from the screen rotation. For example: When I hit 'right' apps in Opie act like I hit 'up.' When I hit 'up' they act like I hit 'left.' Everything works correctly in a terminal (not a terminal window, but VT 1). So if someone can tell me how Opie keeps track of screen rotation in relation to keyboard orientation I would be eternally greatful. I don't need a step-by-step explanation. I'm perfectly happy to RTFM...I just couldn't find the FM in this case. wink.gif

9 Jun 2005
Seems like a pretty good price. The shipping prices aren't too bad either. Mine arrived well packed and works so I thought I might as post something in this section. (I'm not affiliated with yesmicro.com)

Last Visitors

9 Oct 2017 - 23:00

28 Nov 2008 - 9:23

13 May 2008 - 11:14

29 Jan 2008 - 19:00

11 Dec 2007 - 15:06

Other users have left no comments for JohnX.

There are no friends to display.
RSS Lo-Fi Version Time is now: 12th November 2019 - 07:35 PM